This problem occurs because your include path is incorrect. If cms is incorrect, it may be because your system environment is not configured properly. Here are two solutions to this problem.
The following is an error of Discuz.
Fatal error: require_once () [function. require]: Failed opening required '. /source/class/class_core.php '(include_path = '.; c: php5pear ') in D: webBBSindex. php on line 14
Solution
Modify the php. ini configuration file.
| The Code is as follows: |
Copy code |
|
Windows: "path1; path2"
; Include_path = ".; c: phpincludes"
Changed:
Windows: "path1; path2"
Export de_path = "c: phpincludes" |
If you are using iis, the permission configuration may be incorrect. We can try to solve the problem as follows:
For ease of writing, let me first talk about my directory structure.
1. D: FreeHost is the root directory of the website. Place the DZ Forum, wordpress blog, and zhimeng portal website under it;
2. Take the dz Forum as an example. D: FreeHostwebdz2013_JD3QC6 is the root directory of the dz program, which contains the dz program.
A. My website was set up like this at the beginning. The administrators and system have full control permissions on the root directory FreeHos of the website.
B. the permissions set for the root directory of the webdz2013_JD3QC6 program are: Full administrators, full system, and iis Guest Account IUSR_dzusr reading and running, listing and reading file directories, network service has full control permissions and does not inherit the parent directory.
Result The above error is displayed in the last step of the Forum.
The solution is as follows:
A. Add the IUSR_dzusr permission of the iis Guest account to the FreeHos folder in the root directory of the website.