Connassysdba reports ORA-01012: notloggedon, cause: shutting down the database is not followed by any of the shutdown parameters.
Conn/as sysdba reports an error ORA-01012: not logged on, cause: shutting down the database is not followed by any of the shutdown parameters.
Conn/as sysdba error ORA-01012: not logged on
Cause: shutting down the database is because the shutdown is not followed by any of the closing parameters.
Nomal ---> can be closed only when all connections are disconnected;
Transactional ---> actively disconnect after the transaction ends;
Immediate ---> proactively disconnect transactions and connections
Abort ---> immediately shut down the database. This operation is dangerous. It does not synchronize data, does not trigger checkpoints, and the rollback segment is empty directly. This operation is equivalent to power failure and the instance must be restored every time it is started.
Therefore, the database is very slow. In this case, I quit sqlplus directly, causing the Oracle file to be locked. When I start up again, the operation fails because the file is still locked. Error ORA-01012: not logged on.
After restarting the service, I can use it. I have read the oracle error explanation, which is even more confusing to me. Although the problem has been solved, the production environment cannot be down at will, so the problem is to be continued...
Kill the oracle process or disable oracle
Ps-ef | grep ora_dbw0 _ $ ORACLE_SID
Kill-9 pid
Restart oracle
Sqlplus sys as sysdba
Startup;