PHP error: Fatal error: session_start () Solution

Source: Internet
Author: User

Error message:

 

Fatal error: session_start () [<a href = 'function. session-start'> function. session-start </a>]: failed to initialize storage module: files (Path:) in c: \ USR \ phpMyAdmin \ libraries \ Session. inc. PHP on line 75

 

Solution:

1. Check the error. Log (apache2.2 \ logs) file to check whether an error report exists. Not found.

2. Check whether the value of session. save_handler in PHP. INI is files.

3. Check whether the session. save_path in the PHP. ini file has been commented out. If yes, remove the previous ";".

4. Change the path after save_path to an existing path, for example, D: \ temp.

5. Check whether the properties of the temp folder are readable and writable.

6. Restart the Apache server. OK

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.