PhpMyAdmin cannot be connected to mysql.
MySQL returns:
#1045-Access denied for user 'root' @ 'localhost' (using password: NO)
PhpMyAdmin tries to connect to the MySQL server, but the server rejects the connection. Check the host, user name, and password in the configuration file and confirm that the information is consistent with the information provided by the MySQL server administrator.
The software used is wampserver2.1. after installation, the above error occurs when phpAdmin is run. modifying the mysql password based on some methods on the Internet cannot solve the problem, and modifying the configuration file is also invalid. Who has a better method? could you please advise!
Reply to discussion (solution)
The password of the root account is not set.
By default, this account will not be empty.
The configuration file does not set the default MySQL permission account (root has no password.
Modify the config. inc. php file and then upload it.
Reinstall it. if it is in WINDOWS, it is estimated that it was not cleared during the original installation. you can set it in the Wizard.
Upstairs positive solution
Http://mwga.net.blog.163.com/blog/static/1064567282010713114759708/
Check this URL
Set the password. just reconfigure it.
Try the latest version !!
PHP 5.3.3
Mysql 5.5.8
Apache 2.2.17
PHPMyAdmin 3.2.0.1
Remove sqlitemanage 1.2
SQL Buddy 1.3.2 is added.
Learn More
/* Servers configuration */
$ I = 0;
/* Server: localhost [1] */
$ I ++;
$ Cfg ['servers'] [$ I] ['verbo'] = 'localhost ';
$ Cfg ['servers'] [$ I] ['host'] = 'localhost ';
$ Cfg ['servers'] [$ I] ['port'] = '000000 ';
$ Cfg ['servers'] [$ I] ['sockets '] = '';
$ Cfg ['servers'] [$ I] ['connect _ type'] = 'tcp ';
$ Cfg ['servers'] [$ I] ['extension'] = 'mysqli ';
$ Cfg ['servers'] [$ I] ['auth _ type'] = 'config ';
$ Cfg ['servers'] [$ I] ['user'] = 'root ';
$ Cfg ['servers'] [$ I] ['password'] = 'root ';
$ Cfg ['servers'] [$ I] ['allownopassword'] = true;
/* End of servers configuration */
$ Cfg ['defaultlang '] = 'en-utf-8 ';
$ Cfg ['serverdefault'] = 1;
$ Cfg ['uploaddir'] = '';
$ Cfg ['savedir'] = '';
/* Rajk-for blobstreaming */
$ Cfg ['servers'] [$ I] ['BS _ garbage_threshold '] = 50;
$ Cfg ['servers'] [$ I] ['BS _ repository_threshold '] = '32m ';
$ Cfg ['servers'] [$ I] ['BS _ temp_blob_timeout'] = 600;
$ Cfg ['servers'] [$ I] ['BS _ temp_log_threshold '] = '32m ';
?>
You still cannot connect to mysql. if you do not set the root user password, you can connect to mysql. what is the situation?
If you do not set a password, the password cannot be connected after the password is set. the password must be consistent with the database password. Change the password again.