XAMPP installation guide, xampp installation tutorial

Source: Internet
Author: User

XAMPP installation guide, xampp installation tutorial

First download an installation package

 

Follow the default options to install:

 

Remove unnecessary options:

 

Select the installation path:

It indicates that the installation is successful.

Open XAMPP and start the Apache service:

If Apache service cannot be started, the following error occurs:

Error: Apache shutdown unexpectedly.

This is caused by port occupation. When the local machine starts the Apache service, port 443 is occupied:

Solution:

Click the config button, select the blue option, and modify internal port 443 to solve the problem.

Port 80 is usually occupied. If the error code shows that port 80 is in use, select the first option to modify port 80 in the text. After opening the document, Ctrl + F search for the port number and modify it in sequence!

 

After the port is occupied, click the start option to enable the Apache service.

Enter localhost in the browser and press Enter. The following page is displayed. The server has been successfully enabled!

 

Click "Chinese" To Go To The following interface: The running environment is successfully installed!

As prompted, both websites can be used for verification.

So what are their differences?

First, localhot (local) is transmitted without a nic, which is not restricted by the network firewall and nic.

127.0.0.1 is transmitted through the network card and depends on the network card, and is restricted by the network firewall and network card.

Therefore, it is better for the local service to use localhost when the program is set. localhost will not be resolved to an ip address, nor will it occupy Nic or network resources.

 

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.