ADSL non-fixed IP configuration

Source: Internet
Author: User

This configuration is much more difficult than the original configuration with a fixed IP address. We need to consider all aspects of the Configuration. Here, we can avoid detours:

vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin
protocol pppoe
!
interface Ethernet0
no shut
ip address <ip address> <subnet mask>
ip adjust-mss 1452
ip nat inside
no ip directed-broadcast
!
interface ATM0
no shut
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
bundle-enable
!
interface ATM0.1 point-to-point
no ip directed-broadcast
pvc <vpi/vci>
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname <username>
ppp chap password <password>
ppp pap sent-username <username> password <password>
!
ip nat inside source list 1 interface Dialer1 overload
!
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
access-list 1 permit <ip address of ethernet0> 0.0.255.255

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.