AIX + HACMP + Oracle dual-host cluster project

Source: Internet
Author: User
Tags stop script

I. Cluster Classification
1. Category by Purpose
(1) High Availability Cluster)
(2) Load Balance Cluster)
(3) High Performance Computing Cluster)
2. Structure-based classification
(1) active-standby mode)
(2) mutual standby (mutual backup mode)
(3) multi-node cluster)
3. By vendor
(1) IBM: HACMP (High Availability Cluster Multi-Processing)
(2) HP: HPTC (High Performance Technical Computing)
(3) Sun: Sun Cluster
(4) RedHat: RHCS (RedHat Cluster)
How HA works:
Boot IP, standby IP, service IP (service IP), heart beat
Standby Network
Service A service Network Service B

Ii. Project Planning:
1. Project Process:
Cluster project steps (important)
(1) Define HA Topology Structure (defines the ha top Structure) P302
1) configure HA Cluster name (configure Cluster name)
2) Add nodes to HA Cluster (Add node)
3) configure network types between two nodes (configure the network type)
4) configure Interfaces/devices for network types (configure Interfaces/devices)
(2) Define HA resource configure (defines HA resource configuration)
1) configure 2 Application server (DB start/stop service) (configure two start and stop scripts)
2) configure 2 service IP Address (two service IP addresses are configured) (two VG groups are free of configuration)
3) configure resource Groups & participant ipating nodes (create resource Group and node configuration)
4) configure resources in each resource groups (configure resources for each resource Group)

2. hardware configuration:
Two IBM P640 minicomputers, two local SCSI hard drives and dual NICs
One IBM 7133 D40 disk array and eight SSD Hard Disks
3. Software Configuration:
AIX 5.3.0.0-0.4 operating system;
HACMP 5.3 cluster software;
Oracle 10.2 database software;
4. Goals:
1) The array hard drive is divided into two groups to implement RAID 5, which respectively belong to two minicomputers as datavg;
2) The two minicomputers run two different database services, data is stored on datavg, and the two machines implement mutual backup.
3) when any minor machine fails, the other minor machine will automatically take over the database application of the faulty machine to ensure continuous and high service availability.

Iii. project implementation:
1. Hardware connection

2. Operating System and Configuration
(1) install AIX5300-04 operating system, select 64bit kernel and JFS2 File System
(2) The list of extended packages required to install HACMP is as follows:
Bos. adt. libm
Bos. adt... syscils
Bos. clvm. enh
Bos. data
Rsct. basic. hacmp
Rsct. basic. rte
Rsct. basic. sp
Rsct. compat. basic. hacmp
Rsct. compat. basic. rte
Rsct. compat. basic. sp
Rsct. compat. clients. hacmp
Rsct. compat. clients. hacmp
Rsct. compat. clients. rte
Rsct. compat. clients. sp
(3) List of extended software packages required for installing oracle: (you can install them with the preceding package)
Bos. cifs_fs.rte
Bos. adt. prof

# Smit install
(4) Serial Port heartbeat or disk heartbeat test (either)
1) Serial Port heartbeat test (use a serial line to transmit heartbeat signals)
B802 # lsdev-C | grep tty
Tty0 Avaliable 01-S1-00-00 Asynchronous Terminal
B801 # stty </dev/tty0 B801 machine waiting to input information from TTY0
B802 # stty>/dev/tty0 B802 input information to TTY0

B802 # stty </dev/tty0 reverse test of the above process
B801 # stty>/dev/tty0
2) disk heartbeat test (using a shared disk to transmit heartbeat signals, which is supported by AIX5.1)
Create an enhanced concurrent volume group using independent PV (separated from the data VG) on the B801 machine, dedicated to transmitting heartbeat Signals
Key points:
Set volume group name to heartvg
Physical partition size in megabytes is set to 128
Physical volume names is set to hdisk9
Activate volume group automatically is set to no
Create VG concurrent capable is set to enhanced concurrent
Import the heartbeat volume group defined on B801 on B802
Key points:
Set Volume group name to heartvg
Physical volume name is set to hdisk9
Test disk heartbeat:
B801 #/usr/sbin/rsct/bin/dhb_read-p hdisk9-r
B801 waiting for input from heartbeat Disk
B802 #/usr/sbin/rsct/bin/dhb_read-p hdisk9-t
B802 output information to the heartbeat disk. link operating normally information should appear on both machines.

B802 #/usr/sbin/rsct/bin/dhb_read-p hdisk9-r reverse test of the above process
B801 #/usr/sbin/rsct/bin/dhb_read-p hdisk9-t
 


(5) Network Address Configuration:
B801 Server:
En0: 192.168.100.101/24 boot IP
En0: 192.168.99.101/24 standby IP
B801 # smit tcpip
B801 # hostname B801

B802 Server:
En0: 192.168.100.102/24 boot IP
En0: 192.168.99.102/24 standby IP

B802 # smit tcpip
B802 # hostname B802
 
 
(6) datavg configuration (it can be performed only on the host, and then imported to the slave)
B801 # smit ssaraid
-> List SSA physical disk
-> List HotSpare/Candidate/system disk
B801 # smit ssaraid
-> Change use of an SSA phydical disk

B801 # smit ssaraid select a raid member to create two arrays (hdisk)
-> Add an SSA Array

B801 # lspv lists the two physical volume PVS (hdisk) generated)
B801 # create datavg801 and datavg802 for smit vg, each with a hdisk and a PP size of 64 MB
B801 # lsvg-o check that the two volume groups are varyon.

B801 # smit chvg
Define the active automatically attribute of two datavg as No
Key points:
Volume grouop names are set to datavg801 and datavg802, respectively.
Activate volume group automatically is set to no (indicating not to do this here (controlled by the cluster software ))

B801 # varyoffvg datavg801 unmount two active volume groups on B801
B801 # varyoffvg datavg802 for the backup function to importvg the VG Information

B802 # Heavy Mgr B802 host recognition device
B802 # importvg-y datavg801 hdisk? B802 Machine recognition device
B802 # importvg-y datavg802 hdisk? B802 Machine recognition device

B802 # lsvg-o check that the two volume groups are varyon

B802 # smit chvg
Define the active automatically attribute of the two datavg as no
Key points:
Volume grouop names are set to datavg801 and datavg802, respectively.
Activate volume group automatically is set to no (indicating not to do this here (controlled by the cluster software ))

B802 # varyoffvg datavg801 groups all volumes on all machines varyoff
B802 # varyoffvg datavg802 for HA software control varyonvg/varyoff
 
 
(7) application system startup script configuration
B801 # touch/etc/801 dbstart generate B801 Server database Startup Script
B801 # touch/etc/801 dbstop generate B801 Server database stop script
B801 # touch/etc/802 dbstart generate B802 Server database Startup Script
B801 # touch/etc/802 dbstop generate B802 Server database stop script
B801 # chmod + x/etc/80 *

B802 # touch/etc/801 dbstart
B802 # touch/etc/801 dbstop
B802 # touch/etc/802 dbstart
B802 # touch/etc/802 dbstop
B802 # chmod + x/etc/80 *

  • 1
  • 2
  • 3
  • 4
  • 5
  • Next Page

Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.