Debugging problems with SVN-related programs "Go"

Source: Internet
Author: User

Resolves an issue in eclipse that appears in resource is out of sync with the file system.

Sometimes because of the urgency of the reason, so did not go to it, today again encountered it, really looked uncomfortable, so think of ways to solve the problem!

This problem is due to the fact that Eclipse Chinese is not in sync. In Eclipse, the project files are added by Eclipse Auto-Scan, and if the files in the project directory are modified externally and the auto-refresh feature is turned off, the file will be out of sync, resulting in a search that occurs resource System issues (Other features may also be the case). In addition, it is possible that the issue may be caused by an external failure to modify files in the Eclipse project.

There are two ways to resolve this:
1) Manual Refresh. That is, in the project catalog of Eclipse, right-click Refresh (or press F5).
2) To configure Eclipse options:
A) When Eclipse starts, refresh workspace, tick: Window->preferences->general->startup and Shutdown->refresh workspace on Startup
b) Window->preferences->general->workspace: Tick the option: Refresh using native hooks or polling and refresh on access;

My version of Eclipse is: Eclipse SDK 3.7.0

with Debug there was a problem with debugging--- " Source not found "

Check the Internet for a moment, explained as follows:

Our program in debugging, there may be calls to other people's code, if you in the debug when the other people's program, and other this library is not compiled into debug mode, it is more regrettable, you will certainly get this hint, this time step over on the good.


I encountered this problem because Eclipse opened two identical projects (of course, the name is different), and then debug debugging, do not know what the next call is the specific program code, or whether it is called is not the current project program files, the problem occurs.


The Java project path is specified under the Debug view, as follows:

Under Debug view

-"Right-click on the thread being debugged

-"Select Edit Source Lookup Path

-"Select Add

-"Select Java Project

Select the appropriate project to make OK OK

2 , Eclipse Right-click Engineering No response, resulting in Eclipse Card Dead (not responding) 2014-12-28

Have encountered this problem before, and today, I would like to summarize.

On the Internet, there are many reasons for the death of the card, there is no final solution. Tried a few options, still failed to solve. Here's a personal solution, simple and rude, but not necessarily for other situations, only for recording.

Solution 1: Delete the items in eclipse, but do not delete the source files in workspace, and then re-import the project into eclipse. OK, perfect solution.

3 , Solve Eclipse : Resource is out of sync with the file system error 2014-12-28

Opening the file in Eclipse failed, showing:Resource is out of sync with thefile system .

This is a file system that is out of sync because of modifications to the resource in the project outside of Eclipse, but sometimes no modifications are made outside of eclipse, and similar errors are reported.
WORKAROUND: You need to refresh the resource manager manually.
(1) in Eclipse, right-click on the project directory and select F5 (refresh)
(2) Set Eclipse Auto Refresh.
With Window->preferences->general->workspace, check refresh automatically

project in Eclipse cannot view source file, Error: Resource is out of sync with the file system. The only problem where the source files were modified outside of the Eclipse project but not refreshed. MyEclipse comes with help documentation:
Don ' t forget to refresh!
Whenever external tools to modify workspace files, you must perform a Refresh from within Eclipse to make the work Space aware of the changes. If you get a resource out of the sync error in eclipse It's a sign that there be resources in eclipse that has been modifie D outside of Eclipse.
One solution is to perform a refresh (available from a resource's popup menu) on the any resources or projects that where Modi Fied outside of Eclipse.
There is also a preference to refresh automatically. But set to auto-refresh in the engineering comparison big time price a bit big! Window->preferences->general->workspace, check refresh automatically.

Ps: Not tried because the issue was not reproduced after re-importing the project.

4. Red exclamation mark on Eclipse Project 2015-3-14

Cause: The project was imported from the outside, but expanded without any detailed indication of any errors

Direct cause: Error in the package path pointed to in Classpath in the project

Solution: Right-click the project name BuildPath---> Configure Build paht ...

Find the package with Red Cross in libraries, select and remove, OK, problem solved.

Debugging problems with SVN-related programs "Go"

Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.