Differences between VC9, VC6, Thread Safe, and Non-Thread Safe of PHP5.3

Source: Internet
Author: User
Tags vc9 zip

Differences between VC9, VC6, Thread Safe, and Non-Thread Safe of PHP5.3

PHP has provided four versions in total: VC9 x86 Non Thread Safe, VC9 x86 Thread Safe, VC6 x86 Non Thread Safe, and VC6 x86 Thread Safe, which makes me a headache for this rookie, fortunately, there is an English choose on the left where the PHP official website provides download. I have understood it. I guess it means how to select the version. So I started to look up the dictionary and search the Internet, finally, I understood the specific meaning and used it as a memo first.

I. How to select the VC9 and VC6 versions of PHP5.3

VC6 is compiled using the Visual Studio 6 compiler. If your PHP is set up using Apache, select VC6.

VC9 is compiled using the Visual Studio 2008 compiler. If your PHP is set up using IIS, you can select VC9.

II. How to select the Thread Safe and Non-Thread Safe versions of PHP5.3

First, it is literally understood that Thread Safe is Thread security, and Thread security check is performed during execution, to prevent the new thread from consuming system resources by starting the CGI execution mode. Non-Thread Safe is Non-Thread security and does not perform Thread security checks during execution.

Let's take a look at two PHP execution methods: ISAPI and FastCGI.

The ISAPI is executed in the form of a DLL dynamic library. It can be executed after a user request. After processing a user request, it will not disappear immediately. Therefore, thread security check is required, in this way, the program execution efficiency is improved. If you use ISAPI to execute PHP, we recommend that you select the Thread Safe version;

FastCGI executes operations in a single thread, so it does not need to perform thread security checks. Apart from the thread security check protection, it can improve the execution efficiency, if you use FastCGI (whether with IIS 6 or IIS 7) to execute PHP, we recommend that you download and execute non-thread safe PHP (PHP binary files have two packaging methods: msi and zip. Download the zip package ).

The Thread security check is prepared for PHP in The ISAPI mode. Because many php modules are not Thread-Safe, Thread Safe PHP is required.

Therefore, for PHP5.2, select the Thread Safe version for installation, while for PHP5.3, download the None-Thread Safe version, and execute PHP more efficiently.

Related Article

E-Commerce Solutions

Leverage the same tools powering the Alibaba Ecosystem

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.