New Computer tossing Ubuntu12.04 LT

Source: Internet
Author: User

The new computer is tossing Ubuntu12.04 LT the new computer, which will be my main tool in the future. Naturally, it cannot be left alone with the ready-to-use Ubunu. Considering the compatibility and the usage of 4G memory in Ubuntu, a 32-bit system is selected. The installation of the USB flash drive is ready-made, and it is easy to handle the problem. The result has been tossing for several days. The main board, graphics card, and wireless network card are all tricky. The first problem with the motherboard is that it cannot be installed at all. Whether it is USB flash disk installation, wubi installation, or hard disk installation, it is stuck before the installation interface appears. After searching for more than half a day, I finally had a problem. Set the BIOS and disable APIC. What is APIC? The full name is "advanced programmable interrupt controller ". I don't know how much impact it will have on the system after I turn it off, but I have to turn it off when I install Ubuntu.
The problem with the graphics board is solved. Before I can be happy, the next problem will come: After I choose to install Ubuntu, the monitor suddenly becomes black and displays "no video signal "...... The first response is the video card problem. The machine is equipped with a Nvidia GTX560SE video card. It is estimated that Ubuntu does not support this card and cannot enter the graphics mode? Finally, we found a useful method: before selecting to install Ubuntu, first press the Tab key (Press F6 in the original text, and test Ubuntu12.04 to press Tab) to modify the startup script, delete splash (delete quiet and splash in the original article), add nomodeset (because it is a Nvidia graphics card), and press enter to smoothly enter the installation interface. Well, the wireless network cannot be connected. Although the correct password is entered, it cannot be connected to the network. This is the next problem. After normal installation, the startup system still has no video signal. Under the GRUB menu, press the e key to edit the startup script, delete quiet and splash, add nomodeset, and press control + x to start and enter the system. The following figure shows how to install the video card driver. Because we are not able to access the Internet in Ubuntu, and it seems that the Nvidia driver is not available in the attached driver, we downloaded the Linux driver from the official website for convenience, assume that the driver has changed its name to Nvidia. run. Restart the computer, enter the system, control + alt + F1 to enter the first console interface, enter the user name and password to log on. Go to the directory where the driver is located, run close X, then run sudo./Nvidia. run, install the graphics card driver step by step as prompted, and then start sudo start lightdm to start X. There is a problem that cannot be solved, that is, after a relatively large update, restart the machine to find that the resolution has been lowered, and Nvidia's management tools cannot be used. No way. reinstall the graphics card driver. The prompt is that the last time the driver was installed, the file was passive. no matter whether the driver was installed or not, the beautiful interface came back.
This is the most difficult solution for Initially, the Wi-Fi network was identified, but a verification error was prompted after the password was entered. Starting from being unable to support the WPA2 encryption method, setting the vro to WPA or not encrypting does solve the problem. However, you can find that you cannot connect to the vro before record recording. The failure was repeated, and the thought was the driving problem. Since the entire process dragged on for nearly a month, during this period, I repeatedly tried this way, and many details were lost. In short, I found two available Linux drivers, one from the wireless network adapter vendor EDUP, and the other from the chip vendor Realtek. The chip model is rtl8188cus. The two drivers are basically the same, but the Realtek release date is updated. The simplest installation method is to run install. sh, but after you install the driver, you will find that the driver is activated but not in use. It is strange, isn't it? Then try to disable it and then force it to activate again, restart the computer, and the cup has happened ...... The system died in a purple background. To re-enter the system, set nomodeset in the startup parameter. This is almost a dead end, and there is no other way. Start with the error prompt for installing the NIC Driver, find a large amount of information and try again to install it once successfully, connect to WIFI smoothly, but go back after a restart. I feel that ubuntu has provided a driver, but this driver is not easy to use, but this driver is occupying hardware, so the new driver cannot be installed. I checked how to uninstall the driver and got a command: rmmod [Module name]. In fact, a group of commands are used. First, use lsmod to view the module currently loaded by the system. There is a suspicious module named "rtl8192cu". Use the preceding command to uninstall the module, install the driver again. Here, we only tried the driver from EDUP. The driver module name is "8192cu" and there is no rtl prefix. After the driver is installed in this way, it is restored to its original state. Run the lsmod command to check whether it is loaded with rtl8192cu. Repeat rmmod to install the driver ...... You can use it again. However, it is too troublesome to reinstall the driver every time you restart the instance. You can add the rtl8192cu to the blacklist. You can edit the/etc/modprode. d/blacklist file and add the blacklist rtl8192cu to it. After restarting the computer, the wireless network connection disappears. As for driver loading, you do not need to re-compile and install. sh every time. You just need to find the 8192cu. ko file after compilation and install it using insmod 8192cu. ko, or the modprode 8192cu command. The latter is said to be more powerful and does not require running in the directory where the module is located. If you want to automatically load the module at startup, there is a stupid way to put this command in the startup script.
Furthermore, because the NIC driver is installed, the nomodeset parameter that can be discarded after the graphics driver is installed must be input at each startup. You can open/etc/default/grub, which has the following line: GRUB_CMDLINE_LINUX_DEFAULT = "quiet splash ". I saw the familiar quiet and splash ...... Write nomodeset here. In addition, let's take a look at these startup parameters: quiet does not display the debugging information during startup splash displays a graphical startup interface. As for the Nvidia graphics card, nomodeset is used, and other video cards have other corresponding parameters. Because the latest kernel has moved the graphic mode into the kernel, you can specify the hardware clock frequency and register the video card before the X service loads the X driver, the intention is to provide a high-definition startup interface at the beginning, and then smoothly transition to the login interface, but the cup is not executed correctly on some graphics cards, so it ended with a black screen. After the nomodeset parameter is added, the kernel will be notified not to load the graphic mode before X is started, but to start in BIOS mode. Therefore, adding the nomodeset parameter does not need to delete quiet and splash. By Niu Bo

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.