How Linux inside VMware interacts with Windows to file files

Source: Internet
Author: User

We are often confronted with such problems. The high version of VMware encounters a low version of Linux. It is easier to use than to pull the pin, such as the low version of Linux installed in the high version of VMware.

1. Cannot display virtual machine in full screen

2. Switch out each time. Always press the Ctrl+alt key

3. Particularly hateful is the inability to transfer documents directly

For the above situation. This blog is only for the third issue, how to the VMware Linux and the outside window to transfer files, the method is very much, there are

1. Create a shared folder

2. By creating FTP, the server that uses Windows as an FTP

3. Build the TFTP for Linux. The server that used Linux as TFTP

I've only tried these three ways. None of the others have tried it, and it is not discussed here.

here are some of my strengths and weaknesses , the first way to create a shared folder. I just tried it in Fedora. This is done by watching the video, and the video is manipulated through a graphical interface. Just creating a shared folder is only useful for this fedora, and it's very difficult to port it to Linux in other versions. Of course, this is only for my Linux technology is not very good people.

So for this kind of transplant bad method I abandoned. A different approach. I want to build a ftpserver on Windows, and then your Linux as a client, upload files to the server on Windows, and then the files on Windows will be handled by you. Just when I wanted to send a folder from Linux to the Windows Ftpserver, there were two problems. The first one, I want to send a folder that is not compressed is not sent in, only can be transmitted individually. So if you want to send an entire file, you have to find a way to make it a compressed file in Linux, and then you can send it on the command line, which seems to work, but the problem is that I'm using the command line in Linux to send past files. An exception occurs when you open an FTP on Windows, whether it is a normal. c,.txt file or a tar.bz2 file that you have already compressed, and so on. There will be such an exception, the details of what reasons I do not know. May be the Windows comes with the FTP a bit of a problem, haha.

There is no problem with two of Windows communicating files.

So for the shortcomings of the two methods, I strongly recommend a method here, that is, using a third method, build a tftpserver in Linux, build this tftpserver process that is not through the Linux GUI set. This is all set with the command line, why this method is introduced, because it is better to set the portability with the command line.

The first step: first shut down your Linux firewall and SELinux, here's the command I will not introduce. Baidu will be able to.

Step two: First use the command line to see if your ftp-server is installed, with the command: RPM-QA | grep tftp-server


Assume that a successful installation will present such a message.

Step three: Assuming that no installation is available, run the following with two commands:

Yum Install xinetd

Yum Install Tftp-server

Fourth step: Use the command to see if the installation was successful. That

Rpm-qa | grep tftp-server

After success, run the command:

Vim/etc/xinetd.d/tftp


The modified file is like. Changed two places. One is Server_args, specify in the/tftpboot folder, of course, you want to create a new folder under the root folder, which folder you set, the second place is disable, said "Do not allow", of course, to choose No, It means to let him work. Save to exit.

Also note to run: chmod 777/tftpboot, change the permissions of the TFTP folder

Fifth step: Run two commands:

Service xinetd Restart or run

/ETC/INIT.D/XINITD restart

Then use the command: netstat-a | grep tftp, viewing the status of Tftpserver, appears as follows:


Now that the TFTP for Linux is configured, we'll test it on Windows and on another Linux machine:

Testing on Windows:

To make sure that Windows Tftpclient is turned on, assume that the DOS interface is turned on: you enter the TFTP command, and DOS reminds you that TFTP is not an internal or external command or an executable program. Now, let's start with a small section of configuration on Windows: The configuration steps are as follows: Go to the interface in the Control Panel first. Then click on "Turn Windows features on or off" and check the tftpclient to make sure.





Now you enter TFTP in the DOS interface, such as the following interface: The client that illustrates the TFTP of Windows can be used.
How to use the main is two commands, the first one is to download files from the tftpserver side of Linux: command: TFTP 192.168.1.106 get B.C, here 192.168.1.106 is the IP of the Linux server, my Windows IP is the 192.168.1.105 upload command: tftp 192.168.1.106 put B.C m.c START I see this put upload command thought very strange. But then I finally wanted to make it clear. B.C is a file under my Windows folder C:\Users\Administrator folder, I want to upload it to the Linux/tftpboot folder, just why the other main.c behind, assuming I am in Linux/ Tftpboot folder does not have main.c this file, first put a wrong command to enter the instructions:

Let me analyze the cause of the error, one input tftp 192168.1.106 put B.C,,,,, the other input is tftp 192.168.1.106 put B.C m.c two command prompt error message is the same. But the command is different, just the second command is a different M.C file, the error message is "Server error: File not found". Take a look at the TFTP command input format below DOS,


Look at the following example, Uers19.txt is a file of vax1. So the ability to use the put command to transfer files, so the previous error command should know how to change it, that is: Now Linux in the first command: Vim m.c save quit, do not write anything. Then use the DOS command: TFTP 192.168.1.106 put B.C m.c to execute.

See execution:




What is wrong. Tip "error on server: Permission denied". is M.C permission to write, then you chmod 777 M.C in Linux can. In the second run:




This time is really successful, also be able to view Windows folder under the B.C and Linux m.c file content is the same, this is the end of the copy of the file.





In the same way I can upload and download data to 192.168.1.106 's Tftpserver Linux with the corresponding put and get commands on another Linux, but it is not possible to upload an entire folder or download an entire folder. Because everything in Linux is file. You can only upload one or download one of the simplest files, do not include subfolders, so to upload a whole project can be used to compress it with the tar command, and then such a file is better than just between Linux, Linux to Windows a compressed file, There is always a problem, so you have to pass a compressed file. Or is it the same in Linux today?

Perhaps another linux that you use can drag files directly to Windows. That's not true. Oh. In spite of the whole set down, it is a bit troublesome, in short, feasible.

How Linux inside VMware interacts with Windows to file files

Related Article

E-Commerce Solutions

Leverage the same tools powering the Alibaba Ecosystem

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.