S5700 eth-trunk Port aggregation and trunk removal

Source: Internet
Author: User
Tags manual switches

eth-trunk Port aggregation for S5700

Link aggregation and port aggregation are port aggregations, and the stack of switches is not related to stacking and port aggregation.

Port Aggregation Concepts: (includes two layer port aggregation and three layer port aggregation)

1. Port aggregation IEEE standards are a link that aggregates up to 16 links into a single logical path. Only 8 of them can be used,

The remaining 8 articles are used as backups.

2. Do the aggregation of port configuration, physical media properties (duplex mode, interface bandwidth, etc.) must be the same

3. Port aggregation can increase bandwidth, but is not a physical improvement, but is based on increased load balancing

4. Port aggregation port can only be 2 times the number of links to do the aggregation, that is, only 2, 4, 6, 8 links do aggregation,

Cannot be an odd link to do aggregation

Eth-trunk Simple Port aggregation: (Local load Balancing)

SW1:

[Sw1]interface eth-trunk 1 #建立汇聚端口1

[Sw1-eth-trunk1]port link-type Access #更改端口为访问端口, if the following are two switches, you need to change to port Link-type trunk mode.

[Sw1-eth-trunk1]mode manual Load-balance #添加手动本地负载模式

[Sw1-eth-trunk1]quit

[Sw1]interface gigabitethernet 0/0/1

[Sw1-gigabitethernet0/0/1]eth-trunk1 #将端口0/0/1 Join ETH-TRUNK1

[Sw1]interface gigabitethernet 0/0/2

[Sw1-gigabitethernet0/0/2]eth-trunk1 #将端口0/0/2 Join ETH-TRUNK1

[Sw1]interface VLAN 1

[Sw1-vlanif1]ip Address 192.168.1.254255.255.255.0

[Sw1-vlanif1]quit

SW2:

[Sw2]interface VLAN 1

[Sw2-vlanif1]ip Add

[Sw2-vlanif1]ip Address 192.168.1.1255.255.255.0

[Sw2-vlanif1]quit

If the Gigabitethernet 0/0/1 interface is disconnected under the condition of the capture packet verification, it will automatically switch to the Gigabitethernet 0/0/2 port for communication.


the correct way to remove the trunk from the port:

(Because the port is in Vlan1 by default, if all is removed, the port has no default vlan1 configuration and needs to be added back in order to continue the next removal.) )

[Swh1]interfacegigabitethernet 0/0/2

[Swh1-gigabitethernet0/0/2]undoport trunk Allow-pass VLAN All

[Swh1-gigabitethernet0/0/2]porttrunk allow-pass VLAN 1

[Swh1-gigabitethernet0/0/2]undoport Link-type

[Swh1-gigabitethernet0/0/2]quit

Eth-trunk between different or identical VLANs:

Prepare:

192.168.10.23/24

192.168.20.99/24

192.168.30.45/24 gateway:192.168.x.1/24

These three computers are used for testing, in fact, directly in exchange for Ping can also be tested, purely personal habits.

Vlan:10 20 30

Vlanif10:192.168.10.254/24

Vlanif20:192.168.20.254/24

Vlanif30:192.168.30.254/24

Configuration:

SWH1:

[Swh1]vlan Batch 10 20 30

[Swh1]interface VLAN 10

[Swh1-vlanif10]ip address192.168.10.254 24

[Swh1-vlanif10]ip address 192.168.20.254 24

[Swh1-vlanif10]ip Address 192.168.30.254 24

[Swh1-vlanif10]quit

[Swh1]interface Eth-trunk 1

[Swh1-eth-trunk1]port Link-type Trunk

[Swh1-eth-trunk1]port Trunk Allow-pass Vlanall

[Swh1-eth-trunk1]mode Manual Load-balance

[Swh1-eth-trunk1]trunkport gigabitethernet 0/0/1

[Swh1-eth-trunk1]trunkport gigabitethernet 0/0/4

[Swh1]interface VLAN 20

[Swh1-vlanif20]ip address 192.168.20.254 24

[Swh1]interface Eth-trunk 2

[Swh1-eth-trunk2]port Link-type Trunk

[Swh1-eth-trunk2]port Trunk Allow-pass Vlanall

[Swh1-eth-trunk2]mode Manual Load-balance

[Swh1-eth-trunk2]trunkport gigabitethernet 0/0/2

[Swh1-eth-trunk2]trunkport gigabitethernet 0/0/5

[Swh1]interface VLAN 30

[Swh1-vlanif30]ip Address 192.168.30.254 24

[Swh1]interface Eth-trunk 3

[Swh1-eth-trunk3]port Link-type Trunk

[Swh1-eth-trunk3]port Trunk Allow-pass Vlanall

[Swh1-eth-trunk3]mode Manual Load-balance

[Swh1-eth-trunk3]trunkport gigabitethernet 0/0/3

[Swh1-eth-trunk3]trunkport gigabitethernet 0/0/6

[Swh1]interface gigabitethernet 0/0/24

[Swh1-gigabitethernet0/0/24]port link-type Access

[Swh1-gigabitethernet0/0/24]port Default VLAN 10

[Swh1-gigabitethernet0/0/24]quit

SWH4:

[Swh4]vlan Batch 10 20 30

[Swh4]interface Ethernet 0/0/22

[Swh4-ethernet0/0/22]port link-type Access

[Swh4-ethernet0/0/22]port Default VLAN 20

[Swh4-ethernet0/0/22]quit

[Swh4]interface VLAN 20

[Swh4-vlanif20]ip address192.168.20.1 255.255.255.0

[Swh4-vlanif20]quit

[Swh4]interface Eth-trunk 2

[Swh4-eth-trunk2]trunkport GIGABITETHERNET0/0/1

[Swh4-eth-trunk2]trunkport GIGABITETHERNET0/0/2

[Swh4-eth-trunk2]port Link-type Trunk

[Swh4-eth-trunk2]port Trunk Allow-pass Vlanall

[Swh4-eth-trunk2]mode Manual Load-balance

[Swh4-eth-trunk2]quit

[Swh4]iproute-static 192.168.10.0 24 192.168.20.254

[Swh4]iproute-static 192.168.30.0 24 192.168.20.254

SWH5:

As with the SWH4 configuration, the last static route is changed.

[Swh5]vlan Batch 10 20 30

[Swh5]interface Eth-trunk 3

[Swh5-eth-trunk3]trunkport GIGABITETHERNET0/0/1

[Swh5-eth-trunk3]trunkport GIGABITETHERNET0/0/2

[Swh5-eth-trunk3]port Link-type Trunk

[Swh5-eth-trunk3]port Trunk Allow-pass Vlanall

[Swh5-eth-trunk3]mode Manual Load-balance

[Swh5-eth-trunk3]quit

[Swh5]interface VLAN 30

[Swh5-vlanif30]ip address 192.168.30.1 255.255.255.0

[Swh5-vlanif30]quit

[Swh5]ip route-static192.168.10.0 24 192.168.30.254

[Swh5]ip route-static 192.168.20.0 24192.168.30.254

SWH3:

As with the SWH4 configuration, the last static route is changed.

[Swh3]vlan Batch 10 20 30

[Swh3]interface Eth-trunk 1

[Swh3-eth-trunk1]trunkport GIGABITETHERNET0/0/1

[Swh3-eth-trunk1]trunkport GIGABITETHERNET0/0/2

[Swh3-eth-trunk1]port Link-type Trunk

[Swh3-eth-trunk1]port Trunk Allow-pass Vlanall

[Swh3-eth-trunk1]mode Manual Load-balance

[Swh3-eth-trunk1]quit

[Swh3]interface VLAN 10

[Swh3-vlanif10]ip address 192.168.10.1 255.255.255.0

[Swh5-vlanif10]quit

[Swh3]ip route-static192.168.30.0 24 192.168.10.254

[Swh3]ip route-static 192.168.20.0 24192.168.10.254

The detection can be ping-pass, and the clutch can be automatically switched.

Note: When configuring Eth-trunk locally, the Eth-trunk configuration is also performed on the peer, and routing can be used to achieve interoperability between different network segments.





Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.