"The installation of WordPress in a 64-bit space may fail." This is a bug in WordPress. The problem is that WordPress runs on a 64-bit CPU (Linux, due to PHP-gettext parsing. an error occurs in the mo language file, which causes Wordpress to fail to use the Chinese version. It is not disabled by the legendary bluehost. mo format file. the official version has not been updated yet. We can modify \ WordPress \ WP-shortdes \ gettext. PHP File Code .
Depending on the Wordpress version, there are two solutions:
1/WordPress 2.3.2
Find this codeCopy codeThe Code is as follows: if ($ magic = ($ magic1 & 0 xffffffff) | $ magic = ($ magic3 & 0 xffffffff )) {// to make sure it works for 64-bit platforms
$ This-> byteorder = 0;
} Elseif ($ magic = ($ magic2 & 0 xffffffff )){
$ This-> byteorder = 1;
} Else {
$ This-> error = 1; // not Mo File
Return false;
}
Replace
Copy code The Code is as follows: if ($ magic = ($ magic1 & 0 xffffffff) | ($ magic = ($ magic3 & 0 xffffffff )) {// to make sure it works for 64-bit platforms
$ This-> byteorder = 0;
} Elseif ($ magic = ($ magic2 & 0 xffffffff )){
$ This-> byteorder = 1;
} Else {
$ This-> byteorder = 0;
// $ This-> error = 1; // not Mo File
// Return false;
}
2/versions earlier than WordPress 2.3.2
Find this code
Copy code The Code is as follows: if ($ magic = ($ magic1 & 0 xffffffff) {// to make sure it works for 64-bit platforms
$ This-> byteorder = 0;
} Elseif ($ magic = ($ magic2 & 0 xffffffff )){
Replace
Copy code The Code is as follows: if ($ magic = $ magic1 ){
$ This-> byteorder = 0;
} Elseif ($ magic ==$ magic2 ){
In this way, refresh the background page and the problem can be solved. If you still cannot see Chinese, sorry, there is no other way.