The config configuration file referenced in PHP will be an error. Is that a PHP version problem?

Source: Internet
Author: User
Tags array definition parse error
parse error :syntax error,unexpected '[' ············

Then I used an array.

If you want to use

$config=[]

So, what are the requirements for the version?

Reply content:

parse error :syntax error,unexpected '[' ············

Then I used an array.

If you want to use

$config=[]

So, what are the requirements for the version?

Look at the document, since 5.4 you can use the short array definition syntax and replace the array () address with []

The config file is affixed to the complete good cutting ...


  
  

如果是像上面这个样子..是没有问题的.....

看看吧:
PHP 5.3、5.4、5.5、5.6 中的新特性

  • Contact Us

    The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

    If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

    A Free Trial That Lets You Build Big!

    Start building with 50+ products and up to 12 months usage for Elastic Compute Service

    • Sales Support

      1 on 1 presale consultation

    • After-Sales Support

      24/7 Technical Support 6 Free Tickets per Quarter Faster Response

    • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.