Error: Cannot create Windows service for MySql. Error: 0解決方案

來源:互聯網
上載者:User

 

    Error: Cannot create Windows service for MySql. Error: 0

    圖示:

    當你沒有事先停止並卸載已有MySQL服務,並且使用MySQL Configuration Wizard(設定精靈)重新安裝或升級MySQL時,會遇到該問題。發生的原因是,當設定精靈試圖安裝服務時,它發現已經有一個同名的服務。

 

    解決該問題的一個方案是使用設定精靈時選擇mysql之外的其它服務名。這樣可以正確安裝新服務,但保留了原來的服務。但是這樣不好,最好是卸掉不再使用的舊服務。

 

    要想永遠卸掉舊的MySQL服務,通過系統管理權限使用者在命令列執行下面的命令:

C:\>sc delete mysql

    如果Windows版本中沒有sc工具,可以從 下載sc工具下載delsrv工具並使用delsrvMySQL文法。

 

    網上也有一些比較好的方法,現整理如下:

 

        ① 到控制台刪除mysql安裝檔案
        ② 到電腦-服務,去停止mysql服務
        ③ 去你安裝的目錄下(c盤、d盤等,全部刪除乾淨):
             一、mysql的安裝目錄,一般為C:\Program Files目錄下。
             二、mysql的資料存放目錄,一般在C:\Documents and Settings\All Users\Application Data目錄下(需要注意的時Application Data這個檔案夾預設是隱藏的,要通過 工具->檔案夾選項->查看->顯示所有檔案與檔案夾 來設定隱藏檔案可見)。
             三、刪除註冊表資料,通過regedit,刪除以下幾個檔案:
            引用
              HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Services/Eventlog/Applications/MySQL
              HKEY_LOCAL_MACHINE/SYSTEM/ControlSet002/Services/Eventlog/Applications/MySQL
              HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/Eventlog/Applications/MySQL

 

 

 

 

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.