« 家庭特點裡程碑 · 建立 日曆 »JDK 7中特點
這是由甲骨文正在開發的功能,和其他列表中,JDK 7中。
這些功能將建議列入中的Java SE 7平台JSR ,除了為實現特定的上市的。
評論:JDK7開發在openjdk.java.net
摘要
特點是按順序列出,或多或少,從最低到最高整體的JDK軟體棧。
| VM |
JSR 292:支援動態類型的語言(InvokeDynamic) |
| |
嚴格的檢查類檔案 |
| 郎 |
JSR 334:小語言增強(項目錢幣) |
| 核心 |
升級類載入器體繫結構 |
| |
一個URLClassLoader的方法來關閉 |
| |
並發性和集合更新(jsr166y) |
| I18N |
Unicode的6.0 |
| |
本地化增強 |
| |
單獨的使用者地區設定和使用者介面的語言環境 |
| ionet |
JSR 203:更多新的I / O Java平台的API(NIO.2 ) |
| |
NIO.2 ZIP / JAR歸檔檔案系統供應商 |
| |
的SCTP(流量控制傳輸協議) |
| |
SDP(通訊端直接協議) |
| |
使用Windows Vista的IPv6協議棧 |
| |
TLS 1.2 |
| 秒 |
橢圓曲線密碼編譯(ECC) |
| JDBC |
JDBC 4.1 |
| 用戶端 |
XRender管道的Java 2D |
| |
6u10圖形功能建立新的平台 API |
| |
Nimbus的外觀和感覺的Swing |
| |
鞦韆JLayer組件 |
| |
Gervill聲音合成器 [新] |
| 網頁 |
更新XML堆棧 |
| MGMT |
增強MBean [更新] |
此列表包含[新]功能,這實際上是整合的裡程碑1,但由於筆誤,此處沒有列出前。 也有一個[更新]功能。
曾經計劃JDK 7中,但後來延遲到JDK 8或更高版本的功能在本頁面底部列出。
虛擬機器JSR 292:支援動態類型的語言(InvokeDynamic)給JVM,Java語言,並在Java SE API擴充,以支援實施動態類型語言在Java語言本身的附近的效能水平鉛: 約翰玫瑰規格: JSR 292 ; java.lang.invoke相關連結: 項目頁面 的wiki頁面 , 郵件清單目標:貨幣供應M3的裡程碑嚴格的檢查類檔案在指定JSR 202 ,這是部分Java SE 6中 ,並在最近獲批准的維修修訂的JSR 924 ,類檔案的版本51(SE 7)或更高版本必須進行驗證的類型檢查驗證; VM不能失敗到老推理驗證。鉛:卡倫金尼爾規格: JSR 202 § 4.11.1目標:M9的裡程碑語言JSR 334:小語言增強(項目錢幣)一套小語種的變化,旨在簡化常見的,一天一天的編程任務:在switch語句中的字串,嘗試與資源的陳述,改善泛型執行個體建立的類型推斷(“鑽石”),簡化了可變參數的方法調用,更好地不可分割的文字,以及改進的異常處理(多副漁獲物)鉛: 喬達西規格: JSR 334相關連結: 項目頁面 , 郵件清單裡程碑目標:M11核心升級類載入器體繫結構ClassLoader的API和實現的修改,以避免在非分層的類載入器的死結拓撲鉛:卡倫金尼爾規格: java.lang.ClassLoader的 registerAsParallelCapable ,getClassLoadingLock連結: 摘要目標:貨幣供應M3的裡程碑一個URLClassLoader的方法來關閉一個方法,它釋放的基礎資源,如開啟檔案,為URLClassLoader舉行導語: 麥明康規格: java.net.URLClassLoader.close連結: 摘要裡程碑目標:M2並發性和集合更新(jsr166y)一個輕量級的fork / join架構,靈活的和可重複使用的同步的障礙,傳輸隊列,並發相連的雙端隊列,和執行緒區域偽隨機數發生器導語: Doug Lea的規格: java.util.concurrent中 : ForkJoinPool , 相位 , TransferQueue ,ConcurrentLinkedDeque , ThreadLocalRandom相關連結: 概述 ; 草案API ; 維基目標:M5的裡程碑國際Unicode的6.0支援Unicode的版本升級到6.0鉛:由香卡米亞規格: 6.0的Unicode ; java.lang.Character裡程碑目標:M11本地化增強java.util.Locale類的升級,以支援IETF的BCP 47(語言識別標籤)和非編碼區35(本機資料標記語言)規格: IETF的BCP 47 : java.util.Locale的 : forLanguageTag ,toLanguageTag ; UTR區35 : java.util.Locale的 :getUnicodeLocaleAttributes , getUnicodeLocaleType ,getUnicodeLocaleKeys連結: 概述裡程碑目標:M11單獨的使用者地區設定和使用者介面的語言環境升級處理的地區設定單獨的使用者介面的語言環境的格式語言環境規格: java.util.Locale的 getDefault , setDefault ; Locale.Category裡程碑目標:M11的I / O和網路JSR 203:更多新的I / O Java平台的API(NIO.2)檔案系統訪問,可擴充的非同步I / O操作,通訊端通道綁定和配置,新的API和多播資料報鉛: 阿蘭貝特曼規格: JSR 203相關連結: 項目頁面 ; 採訪 , 談視頻 ; java.net文章裡程碑目標:M2NIO.2 ZIP / JAR歸檔檔案系統供應商NIO.2一個全功能,並支援ZIP和JAR檔案的檔案系統供應商鉛: 阿蘭貝特曼裡程碑目標:M11的SCTP(流量控制傳輸協議)Solaris上的流量控制傳輸協議的執行特定的API鉛: 克裡斯赫加蒂相關連結: 項目頁面 , 郵件清單目標:貨幣供應M3的裡程碑SDP(通訊端直接協議)實施具體的支援,可靠,高效能的InfiniBand串連的網路,在Solaris和Linux流鉛: 阿蘭貝特曼目標:貨幣供應M3的裡程碑使用Windows Vista的IPv6協議棧網路代碼升級,優先使用舊版Windows堆棧的Windows Vista中的IPv6協議棧,可用時,導語: 麥明康裡程碑目標:貨幣供應量M1TLS 1.2添加支援傳輸層安全性版本1.2( RFC 5246 )鉛: 布拉德韋特莫爾規格: RFC 5246 , RFC 5289 , RFC 5469 ; javax.net.ssl :ExtendedSSLSession , SSLSocket.getHandshakeSession裡程碑目標:M11安全與加密橢圓曲線密碼編譯(ECC)一個標準的橢圓曲線密碼編譯(ECC)演算法的攜帶型的實施,使所有Java應用程式可以使用ECC出的鉛:文森特瑞安目標:M5的裡程碑資料庫連接JDBC 4.1升級到JDBC 4.1和1.1行集鉛:蘭斯安徒生規格: 的java.sql ; javax.sql.RowSet的 RowSetFactory , RowSetProvider裡程碑目標:M11用戶端XRender管道的Java 2D基於X11 XRender擴充,它提供了訪問許多現代GPU的功能後的一個新的Java2D圖形管道鉛: 克萊門斯Eisserer ;團隊: 德米特裡Trembovetski目標:M9的裡程碑6u10圖形功能建立新的平台API建立新平台的API原本在6u10的版本中實現的功能:透明和不規則視窗,和重量級/輕量級組件混合鉛:安東尼彼得羅夫規格: java.awt中 : 視窗 : setShape , setOpacity ; 組件目標:貨幣供應M3的裡程碑Nimbus的外觀和感覺的SwingSwing的一個跨平台的下一代的外觀和感覺鉛: 曾鈺成波茨 ;團隊: 理查德拜爾 ,彼得Zhelezniakov規格: javax.swing.plaf.nimbus相關連結: 項目頁面目標:貨幣供應M3的裡程碑鞦韆JLayer組件SwingLabs JXLayer組件裝飾平台鉛: