linux系統問題總結——更新 1.建立新使用者後切換到新使用者:No directory, logging in with HOME=/添加使用者useradd -m -s /bin/bash -g group loginname-m 建立home目錄 (不加這個要手動添加目錄,不然會出現No directory,Logging in with HOME=/ )-s /bin/bash 使用bash( 預設為 /bin/sh 使用預設不會在 $ 符前面出現loginname@ubuntu)-g 組 然後使用passwd更改使用者密碼 2.刪除使用者的時候:userdel: user hbase is currently logged in網上很多的解決解決方案如下:mv /var/run/utmp /var/run/utmp_touch > /var/run/utmp 關於:/var/run/utmputmp是一個檔案,除了utmp程式你不能編輯這個檔案,刪掉他的話,當前登陸資訊都會丟失。這個檔案在每次機器reboot起來後都會重新建立。 但是,本人自己實驗了還是不行,依舊得到同樣的提示 那就暴力刪除該使用者吧:userdel -r -f XXXX提示:userdel: warning: can't remove /var/mail/git: No such file or directoryuserdel: git home directory (/home/git) not found沒關係。實際上已成功刪除使用者。 Centos1.[las@gateway1 opt]$ vi /etc/sudoers-bash: /usr/bin/vim: Input/output error這個系統出現問題了,可能是硬體問題,暫時無法解決,換機器。 2.帶圖形介面的centos,執行service network restart失敗:Bring up interface eth0: Error: connection activation failed:Device not managed by NetworkManager or ......原因是圖形介面預設使用了NetworkManager來管理網路,而network是關閉的。執行:service NetworkManager stopservice network start這樣就可以了,如果開啟啟動,則加上 chkconfig NetworkManager off chkconfig network on