php安全執行緒編譯解決方案

來源:互聯網
上載者:User

   php 安全執行緒編譯

  網上這麼說:先安裝php5,加上--maintainer-zts

  然後安裝pthreads

  cd /usr/local/src/

  wget http://pecl.php.net/get/pthreads-2.0.5.tgz

  tar zxvf pthreads-2.0.5.tgz

  cd pthreads-2.0.5

  /usr/local/php5.5.12-zts/bin/phpize

  ./configure --with-php-config=/usr/local/php5.5.12-zts/bin/php-config

  make

  make install

  我的問題是,我下載了這個pthreads,裡面根本就沒有configure?這個該怎麼編譯?

  ------解決方案--------------------

  /usr/local/php5.5.12-zts/bin/phpize phpize路徑,改成你已安裝php目錄下的phpize試試

相關文章

Beyond APAC's No.1 Cloud

19.6% IaaS Market Share in Asia Pacific - Gartner IT Service report, 2018

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。