選擇SQL Server恢複模型確保正確備份

來源:互聯網
上載者:User

問題

在管理SQL Server時首先要做的一件事是建立一個合適的備份計劃以便將失敗事件中任何資料的丟失 可能最小化。建立備份計劃之後當然要做些資料庫配置,這些配置是建立以確保你可以正確地備份資料庫。在這篇文章裡我們將看看SQL Server所提供的不同恢複模型以及怎樣為你的資料庫選擇恢複模型。

專家解答

對於SQL Server 2000和2005,Microsoft為你的資料庫提供了三個不同的恢複模型。在你的伺服器上 ,每個資料庫可以建立得各不相同,而且你還可以根據需要改變恢複模型,所以這個選擇不是永久不變 的。

這三個恢複模型是:

Simple(簡單)

簡單恢複模型就如同它名字所顯示的,它為你提供了簡單的備份,可以在失敗或者如果你需要恢複你 的資料庫到另一個伺服器上的情況下用來替代你的整個資料庫。有了這個恢複模型你就具有了完成完全 備份(整個複製)或不同備份(從上一個完全備份之後所做的任何改變)的能力。使用這個恢複模型你就暴 露於自從上一次的備份之後的任何失敗。下面是你可以選擇這個恢複模型的原因:

你的資料不重要或很容易重新建立。

這個資料庫只用於測試或開發。

資料是靜態並且不會改變。

在上一次備份之後丟失任何或所有事務都是沒關係的。

資料是擷取的並且很容易重新建立。

你可以啟動並執行備份類型:

完全備份

差分備份

檔案和/或檔案組備份

部份備份

Copy-Only(僅複製)備份

Bulk_Logged(批日誌)

批日誌恢複如同它名字所示。有了這個模型,那麼相當一部分的批操作例如BULK INSERT、CREATE INDEX、SELECT INTO等等就不會完全記錄到交易記錄中,從而不會佔據交易記錄那麼大的空間。使用這 個恢複模型的優點是如果你進行批操作你的交易記錄也不會變得那麼大,而且你還可以進行時間點恢複 ,只要你的最後一次交易記錄備份不包括上面提到的批操作。如果沒有運行批操作,那麼這個恢複模型 就如同完全恢複模型一樣。要注意的一件事是如果你使用這個恢複模型,那麼你還需要進行交易記錄備 份,否則你的資料庫交易記錄將不斷地擴大。下面是你可能選擇這個恢複模型的原因:

資料很重要,但是你不想在日誌中記錄大量批操作。

批操作與普通操作在不同的時間進行。

你仍然希望可以恢複到某時間點上。

你可以啟動並執行備份類型有:

完全備份

差分備份

檔案和/或檔案組備份

部份備份

Copy-Only(僅複製)備份

交易記錄備份

Full(完全)

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.