一、啟動bacula的Director daemon與Storage daemon
完成上面的配置後,就可以啟動或關閉bacula了。在baculaserver上啟動或關閉控制端的所有服務,有如下兩種方式。
第一種方式如下:
[root@baculaserver etc]# /opt/bacula/sbin/bacula {start|stop|restart|status} 也可以通過分別管理bacula各個配置端的方式,依次啟動或者關閉每個服務: [root@baculaserver etc]# /opt/bacula/etc/bacula-ctl-dir {start|stop|restart|status} [root@baculaserver etc]# /opt/bacula/etc/bacula-ctl-sd {start|stop|restart|status} [root@baculaserver etc]# /opt/bacula/etc/bacula-ctl-fd {start|stop|restart|status}
由於將用戶端FD配置到了另一個主機baculaclient上,因此無需在baculaserver上啟動File daemon服務。
啟動bacula的所有服務後,通過netstat命令,觀察啟動連接埠情況:
[root@localhost etc]# netstat -antl |grep 91 tcp 0 0 0.0.0.0:9101 0.0.0.0:* LISTEN tcp 0 0 0.0.0.0:9102 0.0.0.0:* LISTEN tcp 0 0 0.0.0.0:9103 0.0.0.0:* LISTEN
其中,9101代表Director daemon;9102代表File daemon;9103代表Storage daemon。
注意在啟動bacula的所有服務前,必須啟動MySQL資料庫,如果MySQL資料庫沒有啟動,串連bacula的控制端時會報錯:
[root@baculaserver opt]# /opt/bacula/sbin/bconsole Connecting to Director 192.168.12.188:9101 19-04月 09:45 bconsole JobId 0: Fatal error: bsock.c:135 Unable to connect to Director daemon on 192.168.12.188:9101. ERR=拒絕串連
此時,執行netstat命令可以發現,9101連接埠根本沒有啟動。
二、在用戶端FD啟動File daemon
最後 ,在用戶端FD(即baculaclient)上啟動File daemon服務,操作如下:
[root@baculaclient etc]# /opt/bacula/sbin/bacula start Starting the Bacula File daemon
管理用戶端FD的服務,也可以通過以下方式完成:
[root@baculaclient etc]# /opt/bacula/sbin/bacula {start|stop|restart|status} [root@ baculaclient etc]# /opt/bacula/etc/bacula-ctl-fd {start|stop|restart|status}
本文出自 “技術成就夢想” 部落格,請務必保留此出處http://ixdba.blog.51cto.com/2895551/828996
查看本欄目更多精彩內容:http://www.bianceng.cnhttp://www.bianceng.cn/Servers/zs/