Racrman backup RMAN-06059RMAN-03002ORA-19625 due to archive unavailability Error

Source: Internet
Author: User
-- Analysis: this cause is 31. Because archived logs have been manually deleted, but related records have not been updated, rman cannot determine the File status. Solution: delete expired files after crosscheck.

-- Analysis: this cause is 31. Because archived logs have been manually deleted, but related records have not been updated, rman cannot determine the File status. Solution: delete expired files after crosscheck.

-- 10 Gb rac library in linux
-- Rman RAC backup error: (Part)
Starting Control File and SPFILE Autobackup at 13-SEP-12
Piece handle = + DATA/racdb/autobackup/2012_09_13/s_793904799.271.793904805 comment = NONE
Finished Control File and SPFILE Autobackup at 13-SEP-12
SQL statement: alter system archive log current
Starting backup at 13-SEP-12
Current log archived
Released channel: c1
Released channel: c2
RMAN-00571: ========================================================== ==============================
RMAN-00569: ==================== error message stack follows ==========================
RMAN-00571: ========================================================== ==============================
RMAN-03002: failure of backup command at 09/13/2012 17:07:11
RMAN-06059: expected archived log not found, lost of archived log compromises recoverability
ORA-19625: error identifying file/opt/ora10g/racdb1_arch/1_2_7923720.9.dbf
ORA-27037: unable to obtain file status
Linux Error: 2: No such file or directory
Additional information: 3
-- Analysis: There are three reasons
1. rman cannot determine the File status because archive logs have been manually deleted and related records have not been updated.
Solution: delete expired files after crosscheck.
2. for archive backups in rac, make sure that rman can normally access the archive logs of each node (you can manually copy the archive to the relevant node directory)
3. For rac
Solution: Modify rman configuration parallelism and script (each node in the channel is not enough)
Reference: RMAN Backup Of Archivelog Files On RAC Fails With RMAN-6059 [ID 298119.1] Applies:
Changes
Possible modification of setting for RMAN "parallelism ".

Cause
This problem can be caused by changing RMAN parallelism to too low a setting
Or initially not setting it high enough such that not ALL the node specific channels are allocated.
Solution
Check your rman parallelism setting:

RMAN> show all;
...
Configure device type disk parallelism 1;
Make sure parallelism is set to at least the number of channels you're
Allocating. For example, if you are issuing this backup command to backup
Archivelog files on a two node RAC database:

Run {
Allocate channel d1 type disk connect 'sys/rac @ node1 ';
Allocate channel d2 type disk connect 'sys/rac @ node2 ';
Backup archivelog all delete input;
Release channel d1;
Release channel d2;
}
Then set parallelism to 2:

RMAN> configure device type disk parallelism 2;
If parallelism is not set at least to the number of channels allocated, not all
Channels will be used and RMAN will not be able to access all the archivelogs specific to each node.

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.