When the primary database is corrupted today, a ORA-16019 error occurs when the logical standby is directly changed to primary, and no answer is found on Metalink. The online saying that the logical standby must be re-built, but when the primary is down, how to re-build, does this mean that logical standby is not suitable for disaster tolerance? Fortunately, I switched to the Activate command later. I don't know whether to use the command by accident. You can try again. If this is done, you can use the NID command to modify the SID, use oradim to delete the old service, create a new service, and modify the corresponding files, such as init and PWD.
The following is the modification process today.
SQL> alter database stop logical standby apply;
The database has been changed.
SQL> alter database commit to switchover to primary;
Alter database commit to switchover to primary
*
Error Row 1:
ORA-16109: failed to apply log data from previous primary database
SQL> alter database activate logical standby database finish apply;
The database has been changed.
SQL> select switchover_status from V $ database;
Switchover_status
--------------------
Sessions active
SQL> select database_role from V $ database;
Database_role
----------------
Primary
SQL>