ASP.net "hash. web" access denied

Source: Internet
Author: User
Tags hash
When debugging the asp.net program in visual studuo.net, "hash. web "access is rejected, check the program code and find no problems, restart IIS cannot solve, only restart the computer to restore normal.
Baidu cannot find a solution. google can only search for foreign websites and find the following tips:
Http://blogs.wwwcoder.com/deepak/archive/2004/10/14/885.aspx
Access to the path containing 'hash. Web' is getting denied.
After installing Visual Studio. NET and F5 a couple of times, I used to get this error frequently. the only resolution was to wait for upto 5 to10 mins or restart system, since a folder in Temporary ASP. NET files containing web. config gets locked up automatically.
After searching a while in KBs, Forums, I found one closest matching solution, which solved my problem. just wanted to share with other readers who wocould also be experiencing this issue. the problem occurs significantly if you touch web. config and ASP. NET has significant memory consumption (as seen in Windows Task Manager)
There is a service called Indexing Service which runs in the system. during F5, ASP. NET tries to JIT compile the new dll (as my understanding goes) and when simultaneously ASP. NET and Indexing service goes to the specified set of cache files, the deadlock occurs and ASP. NET throws this exception.
Solutions [solution ]:
Keep Indexing Service Manual or Stop It
In Indexing Service Preferences, Make C:/Winnt/Microsoft. NET to be excluded or placed in the exclusion catalog so that Indexing Service will not access this location.
---
Actually this solved another problem we are facing here. Thanks for the tip. The problem is like this:
One of the collegues @ my work place had a working. NET installation and was happily working on ASP. NET. sometime later he was not able to debug the asp.net applications through. NET, changed config files ran aspnet_regiis, uninstalled. NET and reinstalled it completely so many times. no use, nada, zilch. so, we finally said "Take Care" that workstation, and gave him another one. now after reading your post, I found Indexing Service was running on that machine. so I stopped it, reinstalled. NET and it is fine. just fine. thanks for the tip.
Related Article

E-Commerce Solutions

Leverage the same tools powering the Alibaba Ecosystem

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.