asp.net solutions for several common exceptions on the server. Practical tips

Source: Internet
Author: User
As follows

(1) Configure the ASP.net site ISS report: Server applications are not available. The specific exception information is as follows:

Server application not available
The Web application you are attempting to access on this Web server is currently unavailable. Please click the "Refresh" button in the Web browser to retry your request.
Administrator considerations: The error message detailing the reason for this particular request failure can be found in the WEB server's system event log. Please check this log entry to find out why this error occurred.

I check for other configurations on ISS. found that all are ASP-written sites. View the environment in the property is ASP.net Framework version 1.1. I changed to the. NET FrameWork2.0 version. This error message appears.

(1) Under normal circumstances. NET2.0 and. NET1.1 a " server application is not available" exception appears when the program pool is common. is actually a process pool call conflict problem, if the two applications accessed are 2.0 and 1.1 respectively, and they share a process pool,
IIS cannot resolve the 2 versions at the same time, and an error like this occurs.

Workaround: Modify one of the process pools, such as changing the process pool of the 2.0 application to asp.net 2.0.

(2) Method Two: Re-register IIS, net\framework\v2.0.50727 aspnet_regiis.exe run it, re-register. NET aspnet_regiis.exe-u Uninstall aspnet_ First Regiis.exe-i Reinstall sometimes reboot the server .

Sometimes the above two methods are configured. The same exception will be reported. Go ahead and check out the system event log. This is the 11-10 Day 10 O'Clock system event log on the server:

Detailed information:

1: The request could not be executed because the application domain could not be created. Error: 0x80070005 denied access.
2: Failed to initialize Appdomain:/lm/w3svc/1635210705/root Exception:System.IO.FileLoadException
Message: Failed to load file or assembly "system.web, version=2.0.0.0, culture=neutral, publickeytoken=b03f5f7f11d50a3a" or one of its dependencies. Access Denied

Google to find a reasonable solution:

1: After installing 2.0, a asp.net tag is added to the property settings of the IIS virtual directory, where the runtime is adjusted to 2.0, and the default is 1.1 run time.

2: This is a permission issue, first check the application pool properties to see what user it is running, typically the network SERVICE and then ensure that the user has access to the. NET Framework 2.0 directory, in fact there should be. The directory is Systemroot:\windows\microsoft.net\frameworks \2.0.xxxx. If all of the above two are true, unfortunately, you have a very strange problem, I last was to change the user identity of the application pool to the local system to run. According to the second solution configuration: Set the Access user of the run pool to " Local System ", then run the program, the error is not present, successfully resolved,

Of course now the site has design Silverlight integrated development of the. NET environment is 3.5 version. After installation. NET Framework3.5sp1. In the asp.net column in the attribute, it is still just 1.1 and 2.0. Some people ask why not 3.5?

Found from official treatment: 3.5 is based on 2.0, so there are only 2.0 IIS inside. The 3.5 relative 2 is only added to some types of libraries. Their JIT is the same, so IIS only needs 2.0. There is no need to have a 3.5.3.5 running or on top of 2.0

(2) When the SQL script in the use of T-SQL inserted Chinese characters appear garbled similar (????) etc. as shown in the picture.

PM handle several version updates. You need to update the database on the SQl2005 on the server. I encountered the Chinese character when I generated the database script execution by visor. It appears similar (???) Garbled. has not found a good molding solution on the Internet. So it contrasts with the SQL2000 version of the original database properties. Found that there are certain discrepancies in the collation. The default database collation on SQL2005 is: SQL_Latin1_General_CP1_CI_AS, as shown in figure.

This is the cause of the garbled. The collation is modified by the default sql_latin1_general_cp1_ci_as to chinese_prc_ci_as. Or when the T_sql statement is used to execute at creation time: ALTER DATABASE basicdb COLLATE chinese_prc_90_ci_as

Note: You must close all external connections to the database when you modify it. Otherwise the modification will not succeed. Then it takes effect by restarting the SQL service.

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.