After IIS is installed, the following problems may occur:
Reference content
Server application error
The server has encountered an error while loading an application during the processing of your request. Please refer to the event log for more detail information. Please contact the server administrator for maintenance.
The above error message is displayed when you access the IIS client.
If I encountered this problem, I did not know how to solve it. I found a solution description for him and asked him to perform the operations step by step. It's hard to say, isn't it a poor response for people who don't engage in computers? I 've been online for a few years, and I'll know how to deal with the article at a glance. As a result, this guy was busy for a long time and didn't see why ~
I have read it over again. It is true that some instructions on the Internet are too irresponsible and many are missing. It is not easy for beginners to solve the problem.
Next, this article will re-fix the server application error solution, fix the path problems involved in the command, and use the commands in this article, you will not need to care about the path problem:
1. Right-click my computer --> Manage --> local users and groups --> users, on the right side, set the password to 123 for both "IUSR _ machine name" and "IWAM _ machine name;
2. Start --> Run --> cmd, and then enter the following commands in the command line window (one line of input );
Reference content: cscript.exe % homedrive %/inetpub/adminscripts/adsutil. vbs set w3svc/wamuserpass 123
Cscript.exe % homedrive %/inetpub/adminscripts/adsutil. vbs set w3svc/anonymoususerpass 123
I need to check whether IIS is normal here, but it seems that I have encountered this problem before. This time it is still the same. Here, 90% is still the problem.
Then proceed.
Reference content: cscript.exe % homedrive %/inetpub/adminscripts/synciwam. vbs-V
Iisreset
After the operation, I am prompted that error: 8004e00f is a MSDTC Service exception. If there is no such prompt, congratulations! You have fixed it successfully.
Continue:
3. Delete the keys in the registry:
Reference content · // HKEY_LOCAL_MACHINE/system/current/ControlSet/services/MSDTC
· // HKEY_LOCAL_MACHINE/software/Microsoft/MSDTC
· // Hkey_classes_root/CID
4. continue in the CMD window just now, type the command (STOP and reinstall the MSDTC Service ):
Reference content: net stop MSDTC
MSDTC-uninstall
MSDTC-install
5. Re-follow the instructions in step 1 (set the passwords of two system users );
6. Run the CMD command to synchronize the password of iwam_myserver in IIS metabase:
Reference content % homedrive %/inetpub/adminscripts/adsutil. vbs set w3svc/wamuserpass "123"
7. Run the CMD command to synchronize the iwam_myserver password used by the COM + application:
Reference content: cscript % homedrive %/inetpub/adminscripts/synciwam. vbs-V
After the operation, although I did not receive an error message of 8004e00f, But I tested IIS, the problem persists. The access page is still "server application error ".
You have to continue the operation:
Check whether your DTC service (full name: Distributed Transaction Coordinator) can be started normally.
Run the following command in cmd:
Reference content rundll32 % WINDIR %/system32/inetsrv/wamreg. dll, createiispackage
Regsvr32 % WINDIR %/system32/inetsrv/asptxn. dll/s
This is a success!
OK, ASP page is all normal
With a hand-written batch processing of IIS repair files based on the above operations, the novice has read the above "tianshu", so there is no need to worry about it:
BAT file download
Http://download.csdn.net/source/1509576