ADB server didn't ACK 解決方案

來源:互聯網
上載者:User

標籤:style   blog   http   color   ar   os   使用   sp   div   

一直沒搞明白這個問題咋出現的,但今天看到一個方法,搞定了!原來是豌豆莢佔用了 5037 連接埠導致。

參見原文章:一個豌豆莢引發的血案——關於ADB server didn‘t ACK的問題

簡單來講,首先將Windows任務進程中的豌豆莢幹掉,如果還是不行,再繼續按下列步驟排查。

 

問題現象:

C:\Users\John>adb shelladb server is out of date.  killing...ADB server didn‘t ACK* failed to start daemon *error: unknown host service

 

1、排查哪路英雄佔用了 5037 連接埠,找出他的 PID 來算賬。 netstat -ano 命令會出現好多行,仔細找找。

 

C:\Users\John>netstat -ano活動串連  協議    本地地址              外部地址                狀態           PID TCP    127.0.0.1:5037         John-PC:0              LISTENING       5084

 

2、找到相關的 PID ,然後查看其名字,幹掉即可。

C:\Users\John>tasklist /fi "pid eq 5084映像名稱                       PID 會話名              會話#       記憶體使用量========================= ======== ================ =========== ============wandoujia2.exe                5048 Console                    1    108,240 K

 

OK,幹掉這個進程一般能搞定這個問題,感謝原文作者。

ADB server didn't ACK 解決方案

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.