標籤:
LDAP6.3在DSCC控制台啟動執行個體完成,但是操作狀態顯示“意外錯誤”,查看日誌如下:
04/May/2016:21:10:39 +0800] - Sun-Java(tm)-System-Directory/6.3 B2008.0311.0224 (32-bit) starting up
[04/May/2016:21:10:39 +0800] - Listening on all interfaces port 11111 for LDAP requests
[04/May/2016:21:10:39 +0800] - Listening on all interfaces port 11112 for LDAPS requests
[04/May/2016:21:10:39 +0800] - slapd started.
[04/May/2016:21:10:39 +0800] - INFO: 0 entries in the directory database.
[04/May/2016:21:10:39 +0800] - INFO: add:0, modify:0, modrdn:0, search:0, delete:0, compare:0, bind:0 since startup.
[04/May/2016:21:10:40 +0800] - ERROR<53761> - Plugins - conn=-1 op=-1 msgId=-1 - Connection Bind through PTA failed (91). Retrying...
[04/May/2016:21:10:40 +0800] - ERROR<53761> - Plugins - conn=-1 op=-1 msgId=-1 - Connection Bind through PTA failed (91).
[04/May/2016:21:10:40 +0800] - ERROR<53761> - Plugins - conn=-1 op=-1 msgId=-1 - Connection Bind through PTA failed (91). Retrying...
[04/May/2016:21:10:40 +0800] - ERROR<53761> - Plugins - conn=-1 op=-1 msgId=-1 - Connection Bind through PTA failed (91).
檢查發現/etc/hosts設定檔有錯,127.0.0.1和::1後面的hostname寫到其它伺服器的主機名稱了。因為是/etc/hosts設定檔是從其它伺服器直接複製粘貼過來的,所以就錯了。修改為正確的,刪除原來的執行個體,重新建立後正常。
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 testldap210.com testldap210
::1 testldap210.com testldap210
……
參考資料:https://community.oracle.com/thread/2013701
ERROR<53761> - Plugins - conn=-1 op=-1 msgId=-1 - Connection Bind through PTA failed (91). Retrying...