標籤:oracle expdp sys tab ora-39166
expdp 匯出sys使用者下的表報錯ORA-39165 和ORA-39166
同事在用expdp匯出sys使用者下的table,結果報錯,全部的log 如下:
[[email protected] ~]$ expdp sys/**** directory=exp_dir dumpfile=fga_log.dmp logfile=fga_log.log tables=fga_log$Export: Release 11.2.0.3.0 - Production on Thu Jan 17 13:07:23 2014Copyright (c) 1982, 2011, Oracle and/or its affiliates. All rights reserved.UDE-01017: operation generated ORACLE error 1017ORA-01017: invalid username/password; logon deniedUsername: sys as sysdbaPassword: Connected to: Oracle Database 11g Enterprise Edition Release 11.2.0.3.0 - 64bit ProductionWith the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,Data Mining and Real Application Testing optionsStarting "SYS"."SYS_EXPORT_TABLE_01": sys/******** AS SYSDBA directory=exp_dir dumpfile=fga_log.dmp logfile=fga_log.log tables=fga_log$ Estimate in progress using BLOCKS method...Total estimation using BLOCKS method: 0 KBORA-39166: Object SYS.FGA_LOG$ was not found.ORA-31655: no data or metadata objects selected for jobJob "SYS"."SYS_EXPORT_TABLE_01" completed with 2 error(s) at 13:12:8
於是就搜到了如下文章:
ataPump Export (EXPDP) Fails With Error ORA-39165 Schema SYS Was Not Found (Doc ID 553402.1)
該文章給出了如下答案:
There is a restriction on dataPump export. It cannot export schemas like SYS, ORDSYS, EXFSYS, MDSYS, DMSYS, CTXSYS, ORDPLUGINS, LBACSYS, XDB, SI_INFORMTN_SCHEMA, DIP, DBSNMP and WMSYS in any mode. The Utilities Guide indicates the restriction only on full export mode, but the restriction actually applies to all modes.
解決該報錯的方法是:
1. 使用exp 匯出
2.ctas的方法在不受限制的schema下建立表,然後匯出該建立的表
3. use the DBMS_AUDIT_MGMT package of Audit Vault to manage and purge audit data (see Note 731908.1). This allows for the facility to move the AUD$ table out of the SYSTEM tablespace, which can negate the need to export the table.
注意:This issue also applies to other SYS owned auditing tables such as FGA_LOG$