JVM Server與Client運行模式

來源:互聯網
上載者:User

標籤:jvm server client

JVM Server模式與client模式啟動,最主要的差別在於:-Server模式啟動時,速度較慢,但是一旦運行起來後,效能將會有很大的提升.原因是:

當虛擬機器運行在-client模式的時候,使用的是一個代號為C1的輕量級編譯器, 而-server模式啟動的虛擬機器採用相對重量級,代號為C2的編譯器. C2比C1編譯器編譯的相對徹底,,服務起來之後,效能更高.

java -version 可以直接查看出你使用的是client還是 server

Jvm client代碼:

C:\Documents and Settings\Administrator>java -versionjava version "1.6.0_21"Java(TM) SE Runtime Environment (build 1.6.0_21-b06)Java HotSpot(TM) Client VM (build 17.0-b16, mixed mode, sharing)

Jvm server代碼:

[[email protected] ~]# java -versionjava version "1.6.0_06"Java(TM) SE Runtime Environment (build 1.6.0_06-b02)Java HotSpot(TM) Server VM (build 10.0-b22, mixed mode)

兩種模式的切換可以通過更改配置(jvm.cfg設定檔)來實現:
32位的虛擬機器在目錄JAVA_HOME/jre/lib/i386/jvm.cfg,64位的在JAVA_HOME/jre/lib/amd64/jvm.cfg,  配置內容大致如下

-server KNOWN-client KNOWN-hotspot ALIASED_TO -client-classic WARN-native ERROR-green ERROR

一般只要變更 -server KNOWN 與 -client KNOWN 兩個配置位置先後順序即可,前提是JAVA_HOME/jre/bin 目錄下同時存在 server 與client兩個檔案夾,分別對應著各自的jvm.

缺少其中一個,切換模式就會報錯.類似:






聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.