ORA-01280: Fatal LogMiner Error.
logminer的基本使用很簡單,按著基本步驟操作即可
1. 安裝
在Oracle10g中運行如下兩個指令碼即可:
l $ORACLE_HOME/rdbms/admin/dbmslm.sql
2 $ORACLE_HOME/rdbms/admin/dbmslmd.sql.
這兩個指令碼用於建立兩個包(DBMS_LOGMNR 和 DBMS_ LOGMNR_D)和四個V$動態效能檢視(視圖是在利用過程DBMS_LOGMNR.START_LOGMNR啟動LogMiner時建立)
比較重要的過程
dbms_logmnr_d.build 建立一個資料字典檔案
dbms_logmnr.add_logfile 在列表中增加記錄檔以供分析
dbms_logmnr.start_logmnr 使用一個個可選的字典檔案和前面確定要分析的記錄檔來啟動LogMiner
dbms_logmnr.end_logmnr 停止LogMiner分析
比較重要的視圖
v$logmnr_dictionary 顯示用來決定對象ID名稱的字典檔案的資訊
v$logmnr_logs 在LogMiner啟動時顯示被分析的日誌列表
v$logmnr_contents LogMiner啟動後,可以使用這個視圖在sql提示符下輸入sql語句來查詢重做日誌的內容
和logminer有關的視圖如下
V$LOGMNR_CONTENTS
V$LOGMNR_LOGS
V$LOGMNR_DICTIONARY
V$LOGMNR_PARAMETERS
V$LOGMNR_LOGFILE
V$LOGMNR_PROCESS
V$LOGMNR_TRANSACTION
V$LOGMNR_REGION
V$LOGMNR_CALLBACK
V$LOGMNR_SESSION
V$LOGMNR_LATCH
V$LOGMNR_DICTIONARY_LOAD
V$LOGMNR_STATS
2.建立資料字典
3.建立要分析的記錄檔列表
4.使用LogMiner進行日誌分析
5.觀察分析結果(v$logmnr_contents)
下面是一個logminer的分析日誌的過程
建立資料字典
begin
DBMS_LOGMNR_D.BUILD('logmin_dic.ora','/db06/stream/logmin');
end;
建立要分析的記錄檔列表
begin
DBMS_LOGMNR.ADD_LOGFILE('/db06/archivelog/2_4648_748374015.dbf',DBMS_LOGMNR.NEW);
end;
使用LogMiner進行日誌分析
alter session set nls_date_format='yyyy-mm-dd hh24:mi:ss';
begin
dbms_logmnr.start_logmnr(dictfilename=>'/db06/stream/logmin/logmindic3.ora');
end;
這個分析報錯,報ORA-01280: Fatal LogMiner Error.我在其他機器測試沒有問題,尋找不同的原因是這裡
把資料庫字典建立在ocfs2檔案系統的,然後重新建立資料字典在ext3檔案系統下,在按著操作步驟就沒有問題
看來這logminer的資料字典還不能建立在ocfs2檔案系統下。
終止日誌分析事務
begin
DBMS_LOGMNR.end_logmnr();
end;