RedHat Linux 6.4 安裝Oracle 10g error

來源:互聯網
上載者:User

RedHat Linux 6.4 安裝Oracle 10g error

環境:
作業系統:RedHat6.4 64位
資料庫版本:10.2.0.4 64位
搭建測試原因:

說明:在redhat6.4上安裝10.2.0.1 64位接著再升級到10.2.0.4 64位,在執行DBCA報如下錯誤
UnsatisfiedLinkError exception loading native library: njni10
…………………………
主要是因為一些包沒有安裝上,檢查glibc的包是否全部安裝,然後執行$Oracle_HOME/bin/relink all
建議最好在安裝之前檢查下面這些包是否都安裝.

[oracle@db ~]$ rpm -qa "grep make
automake-1.11.1-4.el6.noarch
make-3.81-20.el6.x86_64
[oracle@db ~]$ rpm -qa|grep glibc
glibc-2.12-1.107.el6.i686
glibc-common-2.12-1.107.el6.x86_64
compat-glibc-headers-2.5-46.2.x86_64
glibc-headers-2.12-1.107.el6.x86_64
compat-glibc-2.5-46.2.x86_64
glibc-2.12-1.107.el6.x86_64
glibc-utils-2.12-1.107.el6.x86_64
glibc-devel-2.12-1.107.el6.i686
glibc-devel-2.12-1.107.el6.x86_64
[oracle@db ~]$ rpm -qa |grep libaio
libaio-devel-0.3.107-10.el6.i686
libaio-0.3.107-10.el6.x86_64
libaio-0.3.107-10.el6.i686
libaio-devel-0.3.107-10.el6.x86_64
[oracle@db ~]$ rpm -qa |grep gcc
gcc-c++-4.4.7-3.el6.x86_64
compat-gcc-34-g77-3.4.6-19.el6.x86_64
gcc-gnat-4.4.7-3.el6.x86_64
libgcc-4.4.7-3.el6.i686
compat-gcc-34-3.4.6-19.el6.x86_64
gcc-gfortran-4.4.7-3.el6.x86_64
gcc-java-4.4.7-3.el6.x86_64
libgcc-4.4.7-3.el6.x86_64
gcc-4.4.7-3.el6.x86_64
gcc-objc-4.4.7-3.el6.x86_64
compat-gcc-34-c++-3.4.6-19.el6.x86_64
gcc-objc++-4.4.7-3.el6.x86_64
[oracle@db ~]$ rpm -qa |grep compat-libstdc
compat-libstdc++-296-2.96-144.el6.i686
compat-libstdc++-33-3.2.3-69.el6.i686
compat-libstdc++-33-3.2.3-69.el6.x86_64
[oracle@db ~]$ rpm -qa |grep compat-gcc
compat-gcc-34-g77-3.4.6-19.el6.x86_64
compat-gcc-34-3.4.6-19.el6.x86_64
compat-gcc-34-c++-3.4.6-19.el6.x86_64
[oracle@db ~]$ rpm -qa |grep libXp
libXp-1.0.0-15.1.el6.i686
libXpm-3.5.10-2.el6.i686
libXpm-3.5.10-2.el6.x86_64
libXpm-devel-3.5.10-2.el6.x86_64
libXp-devel-1.0.0-15.1.el6.i686
libXp-devel-1.0.0-15.1.el6.x86_64
libXp-1.0.0-15.1.el6.x86_64
libXpm-devel-3.5.10-2.el6.i686
[oracle@db ~]$ rpm -qa |grep openmotif
openmotif22-2.2.3-19.el6.x86_64
openmotif-2.3.3-5.el6_3.i686
openmotif-devel-2.3.3-5.el6_3.i686
openmotif-2.3.3-5.el6_3.x86_64
openmotif-devel-2.3.3-5.el6_3.x86_64
openmotif22-2.2.3-19.el6.i686
[oracle@db ~]$ rpm -qa |grep compat-db
compat-db43-4.3.29-15.el6.x86_64
compat-db42-4.2.52-15.el6.i686
compat-db42-4.2.52-15.el6.x86_64
compat-db-4.6.21-15.el6.x86_64
compat-db43-4.3.29-15.el6.i686
compat-db-4.6.21-15.el6.i686

CentOS 6.6安裝Oracle 11gR2 

CentOS 6.6 x64 自動化安裝Oracle Database 11gR2 RAC指令碼 

SUSE Linux安裝Oracle 10g及問題解決 

Linux 6下安裝Oracle 11g(64bit) 

RHEL7.0安裝Oracle 12C 

CentOS 6.3(x86_32)下安裝Oracle 10g R2 

在CentOS下安裝Oracle10g

Putty + Xming 實現Oracle圖形安裝 

Ubuntu 14.04 LTS 64位安裝Oracle 11g 

相關文章

Alibaba Cloud 10 Year Anniversary

With You, We are Shaping a Digital World, 2009-2019

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。