標籤:mysql資料庫亂碼問題 tomcat啟動過程中報無法擷取jdbc unable to set localhost caused by: java.lang.outofmemoryerror: permgen space
凝思與其他動作linux作業系統有所區別,同樣的應用,部署到凝思下面就不能正常運行,搞不清楚為啥,解決問題的過程是苦悶的,能力範圍內,儘可能為大家提供協助,也為自己經驗積累,希望對大家的問題有所協助。
1:問題描述:mysql資料庫表是小寫,應用報找不到大寫的資料表,tomcat啟動過程中報錯00:28:19,404 ERROR [JDBCExceptionReporter] - <Table ‘iswp.SBR_SYS_USER‘ doesn‘t exist>
解決辦法:設定忽略大小寫
操作步驟: vi /etc/mysql/my.cnf
找到[mysqld],在下面添加一行lower_case_table_names = 1
2:問題描述:資料庫亂碼問題,mysql -uroot -p123456進入MYSQL,查詢資料表,中文亂碼
解決辦法:修改mysql配置字元集
操作步驟: vi /etc/mysql/my.cnf
找到[mysqld],在下面添加一行default-character-set=gbk
找到[client],在下面添加一行default-character-set=utf8
3:問題描述:tomcat啟動過程報記憶體不足,Caused by: java.lang.OutOfMemoryError: PermGen space
解決辦法:修改啟動指令碼
操作步驟:vi /usr/apache-tomcat-6.0.37/bin/catalina.sh
在開頭位置,添加參數設定JAVA_OPTS=‘-server -Xms32m -XX:PermSize=64M -XX:MaxPermSize=128m -Xmx1024m‘
4:問題描述:tomcat啟動過程中報無法擷取JDBC,Could not get JDBC Connection; nested exception is java.sql.SQLException: Connections could not be acquired from the underlying database!
解決辦法:修改mysql配置
操作步驟:vi /etc/mysql/my.cnf
注釋掉以下行
#bind-address = 127.0.0.1
5:問題描述:嚴重: Unable to set localhost. This prevents creation of a GUID. Cause was: Linx: Linx
解決辦法:這裡報錯是因為主機名稱linx找不到
操作步驟:vi /etc/hosts
添加127.0.0.1 linx
本文出自 “技術成就夢想” 部落格,請務必保留此出處http://526869727.blog.51cto.com/2769621/1549456
凝思作業系統下部署應用總結