weblogic 的一個問題的解決方案!

來源:互聯網
上載者:User
在用WEBLOGIC做WEB SERVER時,伺服器是LINUX,有一次服務自動停掉了,再重啟就怎麼也啟不來了,急死了。總是報以下的錯誤,
The weblogic server did not start up properly
Exception raised:
weblogic.server.serviceFailureException:could not get exclusive access to embedded LDAP data files due to existing server
  at weblogic.ldap.EmeddedLDAP.reExclusiveAccess(EmbeddedLDAP.java:899)
  at weblogic.ldap.EmeddedLDAP.initialize(EmbeddedLDAP.java:204)
  at weblogic.tsvr.T3Srvr.initialize1(T3Srvr.java:717)
  at weblogic.t3vr.T3Srvr.initialize(T3Srvr.java:594)
  at weblogic.t3vr.T3Srvr.run(T3Srvr.java:282)
  at weblogic.server.main(Server.java:32)

後來用了一個最省心的辦法,就是把/user_projects/domains/mydomain/myserver/下的LDAP目錄重新命名,或者刪除,問題就解決了。但現在還不知道是什麼原因導致的這個錯誤呢。

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.