標籤:style http color os strong 檔案 io for
Win7 +IIS 剛配置的網站,輸入網址後報以下錯誤:
應用程式“PFIZERQUERY”中的伺服器錯誤
Internet Information Services 7.5
錯誤摘要HTTP 錯誤 404.2 - Not Found由於 Web 服務器上的“ISAPI 和 CGI 限制”列表設定,無法提供您請求的頁面。詳細錯誤資訊
| 模組 |
IsapiModule |
| 通知 |
ExecuteRequestHandler |
| 處理常式 |
ExtensionlessUrl-ISAPI-4.0_32bit |
| 錯誤碼 |
0x800704ec |
| 請求的 URL |
http://192.168.0.142:80/ |
| 實體路徑 |
E:\work\MobileQuery\MobileQuery\MobileQuery |
| 登入方法 |
匿名 |
| 登入使用者 |
匿名 |
最可能的原因:
- 找不到此請求的處理常式映射。可能要安裝某個功能。
- 伺服器上未啟用請求的資源的 Web 服務擴充。
- 擴充的映射指向的位置不正確。
- 擴充在瀏覽器或 Web 服務器中拼字錯誤。
可嘗試的操作:
- 請安裝處理此請求的功能。例如,如果您收到 .ASPX 頁的這一錯誤,則可能需要通過 IIS 安裝程式來安裝 ASP.NET。
- 確認伺服器上啟用了請求的 Web 服務擴充。
- 開啟 IIS 管理器並定位到伺服器層級。
- 在“功能”視圖中,雙擊“ISAPI 和 CGI 限制”以確認 Web 服務擴充被設定為“允許”。
- 如果該擴充不在列表中,請在“操作”窗格中單擊“添加”。
- 在“添加 ISAPI 和 CGI 限制”對話方塊中,在“ISAPI”或“CGI 路徑”框中鍵入 .dll 或 .exe 檔的路徑,或者單擊“瀏覽”導航到相應檔案的位置。
- 在“描述”框中,鍵入該限制的簡要說明。
- (可選)選中“允許執行擴充路徑”以使限制可以自動運行。如果不選中此選項,則限制狀態將為“不允許”,這是預設狀態。您可以在以後選中此選項並單擊“操作”窗格中的“允許”來允許該限制。
- 單擊“確定”。
注意: 請在確認您的 Web 服務器需要此 Web 服務擴充或 CGI 之後再將其添加到列表中。
- 確認擴充的位置正確。
- 確認擴充的 URL 在瀏覽器和 Web 服務器中均拼字正確。
- 建立跟蹤規則以跟蹤此 HTTP 狀態碼的失敗的請求。有關為失敗的請求建立跟蹤規則的詳細資料,請單擊此處。
根據提示,開啟IIS,選到根目錄找到ISAPI和CGI限制
系統預設.netframework4.0都是不允許
根據自己的系統,是64位的啟用framework64,不是就啟用FrameWorkv4.0....
開啟瀏覽器試試效果吧。