XAMPP (Linux version-x86 compatible) official website download

Source: Internet
Author: User

Label:

Welcome to the Linux version of XAMPP (x86 compatible processor edition)
By the way: The software was formerly known as LAMPP, but to avoid misunderstanding, we name it the "Linux version of XAMPP ". So, if you're looking for lampp, you're in the right place. ;)

If you encounter any questions about XAMPP, please contact us. This will help us improve the XAMPP and make it easier to use.

The installation process is only 4 steps

Step 1: Download

Just click on the link below. It's always a good idea to download the latest version. :)
A complete list of downloads (older versions) can be found at SourceForge.

Detailed XAMPP version update records can be found in the release notes.

 xampp Linux 1.8.2 107 MB apache 2.4.7, MySQL 5.5.33,  PHP 5.4.22  & PEAR + SQLite 2.8.17/3.7.17 + multibyte (mbstring) support, Perl 5.16.3, ProFTPD 1.3.4c, PhpMyAdmin 4.0.9, OpenSSL 1.0.1e, GD 2.0.35, Fr Eetype2 2.4.8, Libjpeg 8d, libpng 1.5.9, gdbm 1.8.3, zlib 1.2.3, Expat 2.0.1, Sablotron 1.0.3, Libxml 2.8.0, Ming 0.4.5, W Ebalizer 2.23-05, PDF class 0.11.7, ncurses 5.9, Mod_perl 2.0.8, FreeTDS 0.91, GetText 0.18.1.1, IMAP c-client 2007e, Open LDAP (client) 2.4.21, MCrypt 2.5.8, Mhash 0.9.9.9, Eaccelerator 0.9.6.1, CURL 7.30.0, libxslt 1.1.28, Libapreq 2.12, FPDF 1.7, bZIP 1.0.6, icu4c Library 4.8.1, APR (1.4.6), Apr-utils (1.5.1)
MD5 value: ac1d62327ff1d0c2b6d0e60b648e890d
 xampp Linux x86_64 1.8.2 111 MB apache 2.4.7, MySQL 5.5.33,  PHP 5.4.22  & PEAR + SQLite 2.8.17/3.7.17 + multibyte (mbstring) support, Perl 5.16.3, ProFTPD 1.3.4c, PhpMyAdmin 4.0.9, OpenSSL 1.0.1e, GD 2.0.35, Fr Eetype2 2.4.8, Libjpeg 8d, libpng 1.5.9, gdbm 1.8.3, zlib 1.2.3, Expat 2.0.1, Sablotron 1.0.3, Libxml 2.8.0, Ming 0.4.5, W Ebalizer 2.23-05, PDF class 0.11.7, ncurses 5.9, Mod_perl 2.0.8, FreeTDS 0.91, GetText 0.18.1.1, IMAP c-client 2007e, Open LDAP (client) 2.4.21, MCrypt 2.5.8, Mhash 0.9.9.9, Eaccelerator 0.9.6.1, CURL 7.30.0, libxslt 1.1.28, Libapreq 2.12, FPDF 1.7, bZIP 1.0.6, icu4c Library 4.8.1, APR (1.4.6), Apr-utils (1.5.1)
MD5 value: D191c03329adccd0b30b893437dbfa55
 xampp Linux 1.8.3 121 MB apache 2.4.7, MySQL 5.6.14,  PHP 5.5.6  & PEAR + SQLite 2.8.17 /3.7.17 + multibyte (mbstring) support, Perl 5.16.3, ProFTPD 1.3.4c, PhpMyAdmin 4.0.9, OpenSSL 1.0.1e, GD 2.0.35, Freetype 2 2.4.8, Libjpeg 8d, libpng 1.5.9, gdbm 1.8.3, zlib 1.2.3, Expat 2.0.1, Sablotron 1.0.3, Libxml 2.8.0, Ming 0.4.5, Webaliz Er 2.23-05, PDF class 0.11.7, ncurses 5.9, Mod_perl 2.0.8, FreeTDS 0.91, GetText 0.18.1.1, IMAP c-client 2007e, OpenLDAP ( Client) 2.4.21, MCrypt 2.5.8, Mhash 0.9.9.9, Eaccelerator 0.9.6.1, CURL 7.30.0, libxslt 1.1.28, Libapreq 2.12, FPDF 1.7, B Zip 1.0.6, icu4c Library 4.8.1, APR (1.4.6), Apr-utils (1.5.1)
MD5 checksum:449e348adaacd0e1ccd417c70d5ca5fb
XAMPP Linux x86_64 1.8.3 124 MB Apache 2.4.7, MySQL 5.6.14, PHP 5.5.6 & PEAR + SQLite 2.8.17/3.7.17 + multibyte (mbstring) support, Perl 5.16 .3, ProFTPD 1.3.4c, PhpMyAdmin 4.0.9, OpenSSL 1.0.1e, GD 2.0.35, Freetype2 2.4.8, Libjpeg 8d, libpng 1.5.9, Gdbm 1.8.3, ZL IB 1.2.3, Expat 2.0.1, Sablotron 1.0.3, Libxml 2.8.0, Ming 0.4.5, Webalizer 2.23-05, PDF class 0.11.7, ncurses 5.9, Mod_pe RL 2.0.8, FreeTDS 0.91, GetText 0.18.1.1, IMAP c-client 2007e, OpenLDAP (Client) 2.4.21, MCrypt 2.5.8, Mhash 0.9.9.9, EACC Elerator 0.9.6.1, CURL 7.30.0, libxslt 1.1.28, Libapreq 2.12, FPDF 1.7, bZIP 1.0.6, icu4c Library 4.8.1, APR (1.4.6), apr- Utils (1.5.1)
MD5 checksum:5c18e1fc59c0db32dcffb4693d9e2b66

Note: If you download these files in a Windows system that is running the McAfee virus scanner, you may experience false positives for virus warnings. This is an error between McAfee and gzip compressed files, which you can ignore.

Step 2: Install

After downloading, enter the following command:
Enter the Linux shell and log in as a system administrator:
Su
chmod 755 Xampp-linux-1.8.2-installer.run
./xampp-linux-1.8.2-installer.run

Warning: Only allow XAMPP to be installed using the above command. Do not use any Microsoft Windows tools to release compressed files, which is no use.

Warning 2: When you use this command, older versions of XAMPP that already exist will be overwritten.

This is the end. The XAMPP is installed in the/OPT/LAMPP directory.

Step 3: Start running

Use the following command to start running XAMPP:
/opt/lampp/lampp start

You should be able to see a message similar to the following on the screen:

Starting XAMPP 1.8.2 ...
Lampp:starting Apache ...
Lampp:starting MySQL ...
Lampp started.

All right. Apache and MySQL are running.

If you encounter any error messages, please check the Linux FAQ.

Step 4: Test

Well, that's simple, but how do you detect if all the components are working correctly? Just enter the following link in your browser:

http://localhost

You should now see a link to detect the working status of installed software and a XAMPP start page for some sample programs.

Real-time Art example: a small PHP/GD program (from version 0.9.6pre1 with a flash php/ming example, see screen). Thank Anke Arnold for the font»ankecalligraph«provided.

Instructions for use

Security issues (Must-read!) )

As mentioned earlier, XAMPP is not intended for production environments and is intended for use by the development environment only. XAMPP is set to be as open as possible and provides the developer with any features he or she wants. This is great for the development environment, but it can be deadly for production environments.
Here's a list of XAMPP. Lack of security protection:

MySQL Administrator (Root) does not have a password.
MySQL is accessible over the network.
ProFTPD uses "Lampp" as the password for the user name "daemon".
PhpMyAdmin can be accessed over the network.
The sample program can be accessed over the network.
MySQL and Apache run under the same user name (daemon).
To fix most of the security weaknesses, simply execute the following command:

/OPT/LAMPP/LAMPP Security
It enables a small security check feature to make the XAMPP you install more secure.

Advanced Start and Stop parameters

The previous/opt/lampp/lampp of version 0.9.4 can only start or stop XAMPP easily. Since the beginning of the 0.9.5 edition, it has learned a lot of new things.
Advanced Start and Stop parameters
Parameter description
Start starts the XAMPP.
Stop stops XAMPP.
Restart Restart XAMPP.
Startapache only launches Apache.
Startssl initiates SSL support for Apache. The command will continue to activate SSL support, for example: After executing the command, if you shut down and restart the Xampp,ssl will still be active.
Startmysql only starts the MySQL database.
Startftp start the ProFTPD server. Via FTP, you can upload files to your Web server (username "Nobody", Password "lampp"). The command will continue to activate ProFTPD, for example: After executing the command, if you close and restart Xampp,ftp will still be active.
Stopapache Stop Apache.
Stopssl Stop the Apache SSL support. The command will continue to stop SSL support, for example: After executing the command, if you shut down and restart the Xampp,ssl will still be in the stopped state.
Stopmysql Stop the MySQL database.
Stopftp Stop ProFTPD Server. The command will continue to stop ProFTPD, for example: After executing the command, if you close and restart Xampp,ftp will still be in the stopped state.
Security launches a small security check procedure.
For example: To enable Apache with SSL support, simply enter the following command (as root):
/opt/lampp/lampp Startssl
You can now access the Apache server in the form of SSL https://localhost.

Where do you put the stuff?

Where do you put the stuff? A big question Oh, here are some answers! ;)
Important Files and directories
File/directory Usage
/OPT/LAMPP/BIN/XAMPP Command Library. For example,/opt/lampp/bin/mysql executable MySQL monitor.
/opt/lampp/htdocs/apache the document root directory.
/opt/lampp/etc/httpd.conf Apache configuration file.
/OPT/LAMPP/ETC/MY.CNF MySQL configuration file.
/opt/lampp/etc/php.ini PHP configuration files.
/opt/lampp/etc/proftpd.conf proftpd Preparation file. (starting from version 0.9.5)
/opt/lampp/phpmyadmin/config.inc.php phpMyAdmin Preparation file.

Stop XAMPP

To stop XAMPP, simply enter the following command:
/opt/lampp/lampp stop

You should now be able to see:

Stopping Lampp 1.8.2 ...
Lampp:stopping Apache ...
Lampp:stopping MySQL ...
Lampp stopped.

Then XAMPP's Linux version stops running.

Unloading

To uninstall XAMPP, simply enter the following command:
Rm-rf/opt/lampp

Uninstall complete. :)

Reprint Please specify: XAMPP Chinese Group official website»xampp (Linux version-x86 compatible) official website download

XAMPP (Linux version-x86 compatible) official website download

Related Article

Beyond APAC's No.1 Cloud

19.6% IaaS Market Share in Asia Pacific - Gartner IT Service report, 2018

Learn more >

Apsara Conference 2019

The Rise of Data Intelligence, September 25th - 27th, Hangzhou, China

Learn more >

Alibaba Cloud Free Trial

Learn and experience the power of Alibaba Cloud with a free trial worth $300-1200 USD

Learn more >

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.