Time of Update: 2017-01-13
在Windows上使用VirtualBox+Vagrant安裝CentOS 7環境,需要安裝VirtualBox和Vagrant工具,以及下載一個CentOS 7的box鏡像檔案。一、安裝好以上工具,下載好box檔案後,使用vagrant命令添加鏡像到Vagrant:vagrant box add 名稱 路徑這裡成功添加鏡像到Vagrant,如下:二、初始化開發環境由於是在Windows下,在D盤建立一個檔案夾dev,然後進行如下操作:D:\dev>vagrant upBringing
Time of Update: 2017-01-13
在某個VPS上執行wget操作結果逾時,資訊如下:•wget http://blog.is36.com/•--2012-09-15 09:13:14-- http://www.111cn.net•Resolving blog.is36.com... failed: Temporary failure in name resolution.•wget: unable to resolve host address
Time of Update: 2017-01-13
今天在協助一個朋友在阿里雲ECS伺服器中掛載資料盤和安裝LNMP環境的時候,因為需要用到screen,預設是沒有安裝的,於是開始yum直接安裝發現沒有資料來源,所以準備全部update更新發現也沒有發現源。這個問題也是有過的,於是老左就準備重新更新yum源。 第一、備份原有鏡像檔案 代碼如下複製代碼 mv /etc/yum.repos.d/CentOS-Base.repo /etc/yum.repos.d/CentOS-Base.repo.backup&
Time of Update: 2017-01-13
一直用CentOS 6 習慣了,一下沒適應過來。防火牆配置後執行service iptables save 出現”Failed to restart iptables.service: Unit iptables.service failed to load: No such file or directory.”錯誤,在CentOS 7或RHEL
Time of Update: 2017-01-13
源碼編譯安裝 LNMP 環境雖然便於自訂,但是對於小型伺服器來說,漫長的編譯時間讓人無法等待。如果能在 10 分鐘後內搞定環境安裝,再好不多了。那麼如何在 10 分鐘內快速安裝完 LNMP 環境呢,答案是 使用 YUM 安裝。什麼 YUM ?官網給出的解釋yum is a software package manager that installs, updates, and removes packages on RPM-based systems. It automatically
Time of Update: 2017-01-13
鑒於香港主機那可憐的頻寬,linode又選不到東京機房,嘗試了一下Conoha的東京機房,除了開始註冊時有些問題外,還算比較滿意,主要是頻寬In & Out均為100 Mbps,裝了稅速後,速度那叫一個爽。不過由於系統安裝的是CentOS 7.1,還是出現了一些小問題,不過最終都解決了!現把完整安裝流程在此記錄,作為備忘。首先,下載ShadowSocksR一鍵安裝包,之後賦予執行許可權,並運行bash指令碼,中間會提示輸入密碼、連接埠、頻寬等資訊#chmod +x
Time of Update: 2017-01-13
一、下載安裝 代碼如下複製代碼 [root@localhost src] wget http://cronylab.pl/codes/sshc-0.8.tar.gz[root@localhost src] tar zxvf sshc-0.8.tar.gz[root@localhost src] cd ssh_connector-0.8[root@localhost ssh_connector-0.8]# sh install.sh[#] Uncompressing
Time of Update: 2017-01-13
一、checkinstall的安裝目前最新版本是1.6.2,可以按下面的方式下載安裝。 代碼如下複製代碼 wget http://asic-linux.com.mx/~izto/checkinstall/files/source/checkinstall-1.6.2.tar.gztar zxvf checkinstall-1.6.2.tar.gzcd checkinstall-1.6.2make && make install
Time of Update: 2017-01-13
一、安裝前準備1、擷取系統資訊 代碼如下複製代碼 # cat /etc/redhat-releaseCentOS release 6.5 (Final)# uname -px86_64 由上可知,當前系統:64位CentOS 6.5。2、安裝基礎包 代碼如下複製代碼 # yum install gcc# yum install wget 二、安裝Nginx模組基礎庫1、安裝HTTP rewrite(偽靜態)模組需要的PCRE庫。
Time of Update: 2017-01-13
本文是 tracker.conf 設定檔的詳細介紹。1
Time of Update: 2017-01-13
那是不是所有執行主動關閉的SOCKET都會進入TIME_WAIT狀態呢?有沒有什麼情況使主動關閉的SOCKET直接進入CLOSED狀態呢?答案是主動關閉的一方在發送最後一個ACK後就會進入TIME_WAIT狀態,並停留2MSL(Max Segment
Time of Update: 2017-01-13
1.修改SSH遠程登入連接埠為 8888# vi /etc/ssh/sshd_configPort 8888 #把 #Port 22 修改為 Port 8888# servicesshd restart #重啟SSH服務 或者 service sshd restart 2、防火牆添加連接埠預設下iptables只開啟了一部分連接埠,使用額外連接埠如 8888 需要在iptables中添加白名單 不然你會串連不上SSH伺服器的# iptables -I
Time of Update: 2017-01-13
service httpd restart1、先執行一下操作開啟php擴充檔案目錄:cd /www/wdlinux/php/lib/php/extensions2、然後32位系統Linux執行:wget -c http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz64位系統Linux執行:wget -c
Time of Update: 2017-01-13
系統:centos 6.4 預設mail就是指向mailxcentos 5 系列暫不清楚 需要的軟體包:mailx-12.4.tar.bz21.卸載sendmail或postfix 代碼如下複製代碼 yum remove sendmail -yyum remove postfix -y 2.下載並安裝mailx 代碼如下複製代碼 wget
Time of Update: 2017-01-13
在Xen的Linux機器的本地時鐘是由與物理主機時鐘同步的預設(做),為了改變它使用的時間同步服務為NTP,核心參數必須設定的虛擬機器:Shell代碼echo 1 > /proc/sys/xen/independent_wallclock虛擬機器中/etc/sysctl.conf 設定檔增加下面兩條,加完重啟後生效。Config代碼# Set independent wall clock
Time of Update: 2017-01-13
指令碼 代碼如下複製代碼 #!/bin/bashfunction installVPN(){ echo "begin to install VPN services"; #check wether vps suppot ppp and tun yum remove -y pptpd ppp iptables --flush POSTROUTING --table nat iptables
Time of Update: 2017-01-13
本帖的配置環境為CentOS5 32bit,配置安裝PPTP的過程就不寫了,如果不會請在本部落格自行搜尋,下面貼出整合freeradius需要進行的配置:pptp用戶端配置部分 代碼如下複製代碼 wget http://apt.sw.be/redhat/el5/en/i386/rpmforge/RPMS/radiusclient-0.3.2-0.2.el5.rf.i386.rpmrpm -i radiusclient-0.3.2-0.2.el5.rf.i386.rpm
Time of Update: 2017-01-13
1、kvm 相關軟體安裝 代碼如下複製代碼 sudo apt-get install qemu-kvm libvirt-bin virt-manager bridge-utils 2、橋接網路設定sudo vim /etc/network/interfaces 編輯設定檔,修改IP網路資訊如下: 代碼如下複製代碼 auto loiface lo inet loopbackauto eth0iface eth0 inet manualauto
Time of Update: 2017-01-13
1 檢查當前開發的連接埠#netstat -an假設發現了不必要的連接埠 6312 尋找連接埠對應的服務#lsof -i :631631對應的服務是cupsd3 查看當前所有的服務#chkconfig –list發現cupsd的服務名是cups4 關閉服務 #/sbin/service cups stop5 關閉服務自動啟動如果cups是隨伺服器自動啟動的,那麼還需要將cups服務設定為off.#/sbin/chkconfig cups
Time of Update: 2017-01-13
在前些時間學習遇到好多問題,都沒有時間記錄。此篇是講linux centos 部署FTP伺服器的事。一個WEB伺服器,除能讓網站跑起來還需要FTP。直接進主題示範環境linux centos 6.2 x64 +vsftpd一、登陸你的系統,記得要使用root帳號二、安裝#yum install vsftpd -y / -y 是表示在同意安裝三、開啟服務#service vsftpd restart