Time of Update: 2016-08-10
exp和expdp 匯出效能比較EXP常規模式、EXP直接路徑模式和EXPDP三種方式匯出的效能對比1.首先是EXP的常規路徑匯出:exp bkjia/zhejiang file=/data1/zj_regular.dmp buffer=20480000常規EXP匯出方式執行了1小時24分鐘。2.直接路徑匯出方式:exp bkjia/zhejiang file=/data1/zj_direct.dmp buffer=20480000recordlength=65535
Time of Update: 2015-04-05
Oracle索引合并coalesce操作索引rebuild和rebuild
Time of Update: 2015-02-25
在sql*plus中如何查看一些命令的用法有些時候在使用sql*plus時忘記了一些命令的用法,其實我們大可不必到什麼地方去查,我們只需要在sql*plus中查看就可以了,使用help | ? parameter例如在sql*plus中:SQL> help column COLUMN ------ Specifies display attributes for a given column, such as: - text
Time of Update: 2014-07-18
PostgreSQL模組——pg_stat_statements詳解和安裝測試其實很簡單,最近可能需要對postgresql進行監控,所以接觸了很多相關的監控命令和工具,這邊文章主要是記錄下工作過程,怕之後會忘記。我想要的功能:記錄每條sql的執行時間,能夠查詢每天執行最慢的top10。下面先介紹下pg_stat_statements:(翻譯)pg_stat_statements模組提供了一種跟蹤執行的所有SQL語句的統計資訊的方法。這個模組必須改寫設定檔postgresql.conf中的sha
Time of Update: 2014-06-15
昨天,一個朋友公司的Oracle資料庫崩潰。 這再次印證了我反覆提到的一個命題:資料庫也需要休息。 每逢節假日,資料庫也經常會自我選擇放假。 以前我說:年終難終
Time of Update: 2015-07-22
Mysql匯出逗號分隔的csv檔案,mysql匯出逗號csv CleverCode在實際的工作中,經常需要將一些報表,或者日誌資料等匯出來,如果直接做頁面,如果次數也不是很多,需求也不同。所以直接匯出csv檔案,更加直觀。1 匯出csv檔案1.1 語句格式 SELECT [列名] FROM table [WHERE 語句] [order by 語句] [limit 語句]
Time of Update: 2015-07-01
資料庫複習11——關係模式與範式,資料庫複習11範式 資料庫複習CH11 關係模式與範式11.1
Time of Update: 2015-06-23
Redis配置詳解,redis詳解 Web程式猿部落格:http://blog.csdn.net/thinkercode如果是一個專業的 DBA, 那麼執行個體啟動時會加很多的參數以便使系統啟動並執行非常穩定, 這樣就可能會在啟動時在 Redis 後面加一個參數,以指定設定檔的路徑,就象 mysql 一樣的讀取啟動設定檔的方式來啟動資料庫。源碼編譯完成後,在 Redis目錄下有一個redis.conf 檔案,這個檔案即是 Redis
Time of Update: 2015-06-04
OGG "Loading data from file to Replicat"table資料的靜態同步配置過程,loadingreplicatOGG "Loading data from file to Replicat"table資料的靜態同步配置過程一、mgr進程GGSCI (lei1) 3> view params mgrport 7809 二、抽取進程extftorGGSCI (lei1) 4> view params
Time of Update: 2015-05-26
SqlServer
Time of Update: 2015-05-21
MySQL伺服器SWAP使用率高導致db很慢很卡,mysqlswapMySQL伺服器SWAP使用率高導致db很慢很卡環境介紹:CentOS:6.XMySQL版本:5.5.40故障原因分析:實體記憶體是16G,swap是4G。此時MySQL本身已經佔用了14G實體記憶體,而同時其他應用程式或者系統進程又需要3G記憶體,這時候作業系統就可能把MySQL所擁有的一部分地址空間映射到swap上去,有可能產生swap的操作事件:產生的主要原因: 1.mysqldump以及mysql
Time of Update: 2014-06-15
資料庫一張表進行insert時,出現ORA-01659錯誤ERROR at line 1:ORA-01659: unable to allocate MINEXTENTS beyond 56 in tablespace USER01同時後台alert 日誌出現ORA-1652: unable to extend temp segment by 8192 in tablespace
Time of Update: 2015-05-14
報表開發執行個體——動態多層次KPI鑽研報表(II),kpiii 在報表開發執行個體——動態多層次KPI鑽研報表(I)中,我們說到了動態層次報表需要層次切入的情境,並介紹了利用oracle複雜sql的實現方法。這裡仍然通過該報表來瞭解一下使用“指令碼+本地檔案”的開發方法。
Time of Update: 2015-03-11
mongodb 詳解 error:10061 由於目標電腦積極拒絕,無法串連,mongodb10061串連mongodb的時候首先用mongod.exe啟動程式之後,用mongo.exe來串連資料庫。但是在串連的時候,出現如的錯誤:error:10061 由於目標電腦積極拒絕,無法串連。解決方案:建立如下與mongodb並行的兩個檔案夾data和log,然後建立mongoconfig。並且在log檔案夾下建立一個mongo.log的記錄檔。後來發現在設定檔中輸入:##資料檔案dbpath=
Time of Update: 2013-12-15
1. 啟動執行個體(db2inst1):db2start2. 停止執行個體(db2inst1):db2stop3. 列出所有執行個體(db2inst1)db2ilist5.列出當前執行個體:db2 get instance4. 察看樣本設定檔:db2 get dbm cfg|more5. 更新資料庫管理員參數資訊:db2 update dbm cfg using para_name para_value6. 建立資料庫:db2 create db test7. 察看資料庫配置參數資訊db2
Time of Update: 2014-09-13
升級資料字典,解決ORA-01092: ORACLE instance terminated. Disconnection forced問題,oracleinstance在oracle 執行個體關閉的情況下,Oracle 軟體從10.2.0.1升級到 10.2.0.5 之後,存在的資料庫也要升級。此時啟動執行個體會報錯 ORA-01092: ORACLE instance terminated. Disconnection forcedSQL> alter database
Time of Update: 2014-09-01
MYSQL中利用select查詢某欄位中包含以逗號分隔的字串的記錄方法,mysqlselect首先我們建立一張帶有逗號分隔的字串。CREATE TABLE test(id int(6) NOT NULL AUTO_INCREMENT,PRIMARY KEY (id),pname VARCHAR(20) NOT NULL,pnum VARCHAR(50) NOT NULL);然後插入帶有逗號分隔的測試資料INSERT INTO test(pname,pnum) VALUES('產品1
Time of Update: 2014-07-18
關於10g DG中的ORA-19527和ORA-00312錯誤解決樣本,ora-19527ora-00312這幾天在搭建10g DG Windows 2008 R2的測試環境,主要是明天要去給一客戶重新搭建一套生產庫的DG,其中發現一些問題,特此記錄一下由於將要部署到生產環境,所以考慮線上搭建DG的方案,即不停庫的情況下,而問題主要就是出在不停庫時,用RAMN建立STANDBY的時候通常線上搭建DG,主要是下面幾個步驟:1. 確保主庫開啟歸檔,並開啟force logging模式2.
Time of Update: 2014-07-04
前兩天有位朋友在QQ群問了一個問題,背景如下:繼續問後,有如下回複:1、對方伺服器串連無問題。2、從client可以telnet伺服器的1521連接埠。3、tnsping正常。4、對方伺服器沒有設定IP信任。5、windows 2003 server,Oracle 10.1.0.2.0但從用戶端sqlplus就是逾時,無法串連。首先,看下ORA-12170的定義:oerr ora 1217012170, 00000, "TNS:Connect timeout
Time of Update: 2014-06-21
最近在啟動監聽器的時候收到了TNS-01201: Listener cannot find executable...的錯誤提示。這個錯誤還真是一個一直沒有碰到過的錯誤。咋一看還真不明白是怎麼一回事呢。下面是錯誤的具體描述與解決方案。 1、故障描述#在啟動監聽器時收到了TNS-01201錯誤,監聽器無法找到可執行檔oracle@DevDB02:~> lsnrctl start LISTENER_USBO2 &