Time of Update: 2014-06-15
CentOS下python-mysqldb安裝過程居然耗費了3個小時,遇到詭異的問題就是python setup.py build 會出現一大堆亂碼。看到網上有朋友也遇到同樣的問題,貼出來分享一下,希望能節約大家的時間。 _mysql.c: At top level:_mysql.c:647: error: expected ????=????, ????,????, ????;????, ????asm???? or ????__attribute__???? before ????*????
Time of Update: 2014-06-15
在 Oracle 的世界裡,一個執行個體只能開啟一個資料庫,如果我想在本機中同時運行兩個資料庫,那就要開啟兩個執行個體了,而不同的執行個體的標識就是SID。 關閉現有資料庫,設定好一個新的 SID 後,通過複製參數檔案為 spfile<New SID>.ora 作為新執行個體的參數檔案,將控制檔案、資料檔案和重做日誌複製一份到相應的目錄,此時新的資料庫就有一個雛形了;將資料庫啟動 nomout
Time of Update: 2014-06-15
一、REPORT1、報告目標資料庫的物理結構 RMAN>REPORT SCHEMA2、報告需要備份的資料檔案 在執行備份之前,常常需要取得需要備份的資料檔案資訊,通過執行REPORT NEED BACKUP 命令,可以列出需要備份的資料檔案。當使用REPORT NEED BACKUP命令時,可以帶
Time of Update: 2014-06-15
1.安裝rpm包nano /v.sh將下面內容複寫進去對於 x64位版#!/bin/bashrpm -Uvh kernel-headers-2.6.18-194.el5.x86_64.rpmrpm -Uvh glibc-headers-2.5-49.x86_64.rpmrpm -Uvh glibc-devel-2.5-49.i386.rpmrpm -Uvh glibc-devel-2.5-49.x86_64.rpmrpm -Uvh
Time of Update: 2014-06-15
1 Swingbench 簡述1.1 概述這是Oracle UK的一個員工在一個被拋棄的項目的基礎上開發的。目前穩定版本2.2,最新版本2.3,基於JDK1.5。該工具是免費的,可以在作者的網站上自由下載,並且擁有詳細的使用文檔。除了Swingbench,作者還開發了兩個相關工具:測試資料產生工具DataGenerator和追蹤檔案分析工具Trace
Time of Update: 2014-06-15
vmware workstation 7 上 安裝 Oracle 11.2 rac 進行的過程很痛苦,記錄一下虛擬機器檔案的配置:.encoding = "GBK"scsi1.sharedBus = "virtual"disk.locking = "FALSE"diskLib.dataCacheMaxSize = "0"diskLib.dataCacheMaxReadAheadSize = "0"diskLib.DataCacheMinReadAheadSize =
Time of Update: 2014-06-15
本例是基於ASMLib建立,
Time of Update: 2014-06-15
ORA-03111錯誤,導致系統無法運行問題現象描述: 系統在運行時報“java.sql.SQLException: ORA-03111”錯誤。問題分析:通過在metalink對故障代碼進行定位。文檔號[ID 1219453.1]與客戶的故障資訊類似,“ORA-03111: break received on communication
Time of Update: 2014-06-15
1.
Time of Update: 2014-06-15
產生問題的原因主要以下兩點:1. 有較大的事務量讓Oracle Undo自動擴充,產生過度佔用磁碟空間的情況;2. 有較大事務沒有收縮或者沒有提交所導制;說明:本問題在ORACLE系統管理中屬於比較正常的一現象,日常維護多注意對磁碟空間的監控。UNDO資料表空間介紹UNDO資料表空間用於存放UNDO資料,當執行DML操作(INSERT,UPDATE和DELETE)時,oracle會將這些操作的舊資料寫入到UNDO段,在oracle9i之前,管理UNDO資料時使用(Rollback
Time of Update: 2014-06-15
更改Oracle資料庫的非歸檔模式需要重新啟動資料庫,在mount模式下修改,簡要步驟1 以shutdown immediate方式關閉資料庫2 啟動執行個體到mount狀態3 更改運行非模式並開啟資料庫操作步驟:1 登入資料庫查看資料庫的歸檔狀態SQL> archive log list;Database log mode
Time of Update: 2014-06-15
五、索引Index的最佳化設計1、管理組織索引索引可以大大加快資料庫的查詢速度,索引把表中的邏輯值對應到安全的RowID,因此索引能進行快速定位元據的物理地址。但是有些DBA發現,對一個大 型表建立的索引,並不能改善資料查詢速度,反而會影響整個資料庫的效能。這主要是和SGA的資料管理方式有關。Oracle在進行資料區塊快取管理時, 索引資料比普通資料具有更高的駐留許可權,在進行空間競爭時,ORACLE會先移出普通資料。對一個建有索引的大型表的查詢時,索引資料可能會用完所有的數
Time of Update: 2014-06-15
開發人員有個需求,要求把某個schema中所有對象移到另一個shema中,後來一想,不就是把schema的名字改了就可以了嗎?這樣就不用移來移去的,準備用DDL語句直接改的:alter user scott rename to scott2; 發現根本沒有這個語句,後來在網上查了一下,才發現,Oracle本身沒有提供這個功能的語句,但有一個資料字典的表:user$,所有的使用者都存在這張表中,可以直接update,就嘗試著改
Time of Update: 2014-06-15
在主鍵中增加一個欄位出現ora-00955錯誤將表mytable加上一個id2欄位,並使其成為主鍵之一,原主鍵名為:mytable_pk,欄位為(id),步驟如下:1.刪除主鍵:alter table mytable drop constraint mytable_pk cascade;2.增加欄位alter table mytable add id2 varchar2(6);3.設定新增欄位初值update mytable set id2='sx';4.將新增欄位改為非空alter
Time of Update: 2014-06-15
環境:linux x86 64 10.2.0.1報錯: sqlplus / as sysdba ORA-01031 insufficient privileges而sqlplus sys/password as sysdba可以登陸檢查: 一 重新命名orapwd檔案,sqlplus sys/password登陸也失敗,證明登陸時口令檔案在生效,sqlplus / as sysdba表示作業系統驗證失敗二 檢查使用者和組 cat /etc/passwd cat
Time of Update: 2014-06-15
當我更新一個視圖的時候,遇到這個錯誤:ORA-01779: 無法修改與非索引值儲存表對應的列01779, 00000, "cannot modify a column which maps to a non key-preserved table"// *Cause: An attempt was made to insert or update columns of a join view which// map to a
Time of Update: 2014-06-15
運行Eclipse,建立一個新的Java工程“HBaseClient”,右鍵項目根目錄,選擇 “Properties”->“Java Build Path”->“Library”->“Add External
Time of Update: 2014-06-15
前言:表壓縮應該是從10g開始支援的吧,Oracle 11g exadata將這個特性用到了極點,並大力推廣壓縮技術,在現代機器cpu效能井噴的狀態下,對IO,記憶體佔用的減少顯得尤為重要,壓縮技術肯定是未來的一種普遍技術,現在這個技術也越來越成熟,那就讓我們在以後的維護過程中用起來,早日實現這個功能的普及,福利DBA。oracle 12c同樣對壓縮技術進行了支援,下面是各種壓縮方法的優缺點,文法和介紹:基本表壓縮 壓縮層級高 &
Time of Update: 2014-06-15
為了做備份,需要將伺服器上的11g的使用者的完整資料匯出來。機器上的用戶端是Oracle10g的。用命令:exp ***/***@*** file=****.dmp
Time of Update: 2014-06-15
環境:平台:RedHat EnterPrise 5.8 X86_X64資料庫:Oracle EnterPrise 11.2.0.3叢集軟體:Oracle grid 11.2.0.3故障現象:資料庫出現了歸檔失敗,其中有一個節點的執行個體出現HANG死的狀況。日誌資訊如下: Fri Feb 28 19:49:04 2014 ARC1: Error 19504 Creating archive log file to '+DATA02' ARCH: Archival