Time of Update: 2014-06-15
第一問:是否選擇增量備份?所有增量備份都必須先建立0級備份。0級備份相當於全庫備份,但二者並不等同,因為,全庫備份不包含增量備份策略。對users 資料表空間建立增量備份:RMAN> backup incremental level=0 tablespace users;
Time of Update: 2014-06-15
串連MySQL操作是串連進程和MySQL資料庫執行個體進行通訊。從開發的角度來說,本質上是進程通訊,常用的進程通訊方式有管道、具名管道、命名字、TCP/IP通訊端、Unix網域名稱通訊端TCP/IP串連:TCP/IP通訊端串連方式是MySQL在任何平台都提供的一種串連方式,也是網路中使用最多的一種方式。這種方式在TCP/IP串連上建立一個基於網路的串連請求,一般情況下用戶端在一台伺服器上,而MySQL執行個體在另外一台伺服器上,這兩台機器通過TCP/IP網路連接mysql> us
Time of Update: 2014-06-15
在Mysql資料庫中,Merge表有點類似於視圖。mysql的merge引擎類型允許你把許多結構相同的表合并為一個表。之後,你可以執行查詢,從多個表返回的結果就像從一個表返回的結果一樣。每一個合并的表必須有完全相同表的定義和結構。Mysql Merge表的優點:A. 分離靜態和動態資料B. 利用結構接近的的資料來最佳化查詢C. 查詢時可以訪問更少的資料D. 更容易維護大資料集E. 可以通過修改.mrg檔案來修改Merge表,當然也可以用alter進行修改,修改後要通過FLUSH
Time of Update: 2014-06-15
這篇文章詳細介紹了Oracle RAC環境下的串連管理,分別介紹了什麼是 Connect Time Load Balancing、Runtime Connection Load Balancing、Connect Time Connection Failover 和 Runtime Connection Failover,以及裡面所涉及到的 TAF、ONS、FCF、FAN、LBA 等諸多知識點。本文主要是針對 Oracle RAC 11gR2 環境下的串連管理,但同時也會對比說明一下
Time of Update: 2014-06-15
最近為了搞Linux下MySQL的自動定時備份,特意寫了個教程,方便以後查閱,並跟大家分享,如有問題,歡迎吐槽。前提設定為淩晨零點零分,這樣儲存起來的資料都是昨天的。廢話少說。開始1.首先我建立了 /home/user/mysql_autobackup.sh 註:mysql_autobackup.sh 內容如下:/usr/bin/mysqldump -uroot -ppassword_card >/st_backup/stcard/stcard_$(date +%Y%m%d).sql
Time of Update: 2014-06-15
在windows下的proc中不支援通過參數列表訪問,而Linux下的則可以!void insert_sale_to_db(float tm){ EXEC SQL WHENEVER SQLERROR GOTO ERROR; EXEC SQL INSERT INTO SALE VALUES(:tm); EXEC SQL COMMIT WORK; return;ERROR: makelog("debug.log","db_show");
Time of Update: 2014-06-15
今天把一個rac的資料重啟時遇到了如下錯誤,提示找不到一個叫FGDG的磁碟組資源:[grid@srcbdb1 ~]$ srvctl start database -d dcdbPRCR-1079 : Failed to start resource ora.dcdb.dbCRS-2640: Required resource 'ora.FGDG.dg' is missing.改磁碟組的確不存在,之前刪除掉了,而且使用crsctl -t -v查看資源群組時的確沒有看大:[grid@srcbdb1
Time of Update: 2014-06-15
1.MySQL匯出本機資料庫資料到本地檔案mysql -A service_db -h your_host -utest -ptestmysql> select * from t_apps where created>'2012-07-02 00:00:00' into outfile /tmp/apps.csv2.MySQL匯出遠端資料庫資料到本地檔案mysql -A service_db -h your_host -utest -ptest -ss -e "SELECT *
Time of Update: 2014-06-15
在mysql中,單純的mysql 主從配置會出現單點故障:(SPOF:Single pointof failure),通過mysql MMM項目可以實現避免這個致命的問題。一 何為mysql MMM ,摘錄官方的解釋 如下,很有意思When you eat something tasty, you say: “Mmm…”. Sometimes “Mmmmmmm”… or “HmMMmmmmm” - but we decided to go with just
Time of Update: 2014-06-15
Oracle 11G: 產生PFILE檔案: create pfile='/home/oracle/initorcl.ora' from spfile;修改PFILE中的*.memory_target=536870912 值。然後重啟資料庫從新的PFILE檔案啟動到NOMOUNT狀態。SQL> startup nomount pfile='/home/oracle/initorcl.ora';ORA-00845: MEMORY_TARGET not supported on this
Time of Update: 2014-06-15
開發一直在本地mysql資料進行,完成後測試連接LINUX伺服器資料庫,結果一直報錯找不到表!另我納悶的是伺服器資料庫裡明明是建了表的,用mysql控制台測試連接執行查詢也沒問題,可程式就是一直報錯!於是開始反覆測試找問題,剛開始以為是驅動或mysql版本不匹配等引起的原因,但是重新寫了個JDBC串連執行查詢發現沒問題!說明驅動沒問題!於是懷疑串連池的問題,於是將程式裡的串連改成新寫的JDBC串連,仍然出錯!這時候我都快瘋了!於是將項目裡的SQL語句拷貝出來一句放到新寫的JDBC程式裡去執行,終
Time of Update: 2014-06-15
這裡主要驗證了number 和 varchar2 兩種資料類型null值的儲存先來介紹一下row piece的結構引用官方文檔的一張結構圖通常情況下,不包括(cluster table 和 chain row)一個rowpiece 包括row header 和 column data 關於其他情況,會在以後的研究中陸續放出。BBED> dump /vFile: /u01/apps/Oracle/oradata/david/users01.dbf(4)Block: 531
Time of Update: 2014-06-15
主庫:my.cnfserver-id=1 ######只能有一個server-idlog-bin=mysql-binmaster-host = 192.168.0.121master-user = copy ###授權遠端連線master-password =
Time of Update: 2014-06-15
wmsys.wm_concat的作用是將多行合并為一行,如一個人買了3隻股票A,B,C 正常我們會記錄成三條資料,現在要以一條資料顯示該人的股票,這是wmsys.wm_concat方法就有用了。但是,在Oracle 10G中該方法傳回值可直接轉為String後使用,但是在11G中卻是Clob類型,我們必須將clob轉為String 或其他類型後才可以使用。/** * 將CLOB轉成String ,靜態方法
Time of Update: 2014-06-15
MySQL異地全備份:#bash/sh! echo "start backup..." #MySQL Info sql_user=root sql_psw=root sql_db=buke_user name=$sql_db$(date +%y%m%d).sql
Time of Update: 2014-06-15
看到網上有人在尋找SQL Server儲存Email資料,其實SQL Server提供了OLE DB Provider可以訪問Exchange.Microsoft OLE DB Provider for Exchange 以表格形式公開儲存在 Microsoft Exchange 2000 Web Store 中的資料。可以使用類似於 OLE DB Provider for Microsoft Indexing Service 所支援的 SQL 子集的 SQL
Time of Update: 2014-06-15
1、PHP與mysql建立連結php.ini 載入mysql組件: extension=php_mysql.dll 前的; 去掉 extension_dir = " " 路徑是否正確PHP連結mysql函數mysql_connect: 開啟 MySQL 連結mysql_select_
Time of Update: 2014-06-15
第一次在CentOS6版本的環境下安裝Oracle 10g,遇到了如下錯誤:INFO: Generating BASE ORASDK library...INFO: Creating /u01/oracle/10g/product/10.2.0/db_1/lib/liborasdkbase.so.10.2INFO: gcc: INFO: /usr/lib/libstdc++.so.5: No such file or directoryINFO: INFO:
Time of Update: 2014-06-15
(1)唉,系統裝了一天,雖然說Ubuntu不折騰幾次分區不算用過,但是真的折騰起來費時費力(2)說一下,我的筆記本分區情況,由於我主要在ubuntu下做開發,所以我裝了雙系統,windows主要是為了玩遊戲的,大家都懂得,不多說了。ubuntu的分區規劃是:/boot 256M /swap 8G /home 120G /root
Time of Update: 2014-06-15
名稱角色server(RHEL6.0)伺服器1、前置條件的準備(1)解壓壓縮檔[root@localhost ~]# unzip linux_11gR2_database_1of2.zip //解壓尾碼為.zip的檔案包[root@localhost ~]# unzip linux_11gR2_database_2of2.zip[root@localhost ~]# ls database/ //查看產生的database資料檔案doc&