Time of Update: 2013-12-13
伺服器正常使用ssh登入 開啟終端,運行 sudo gedit /etc/apt/sources.list 把這個freeNX的源加進去,網上提供的其他源我都試了,我這裡只有這個源可以連上 deb http://mirror.ubuntulinux.nl feisty-seveas freenx deb-src http://mirror.ubuntulinux.nl feisty-seveas freenx 然後下載GPG key,並安裝 wget
Time of Update: 2013-12-13
對所有的Linux系統和網路系統管理員來說,一個最基本的技巧是知道如何從頭開始編寫一個強健的iptables防火牆,並且知道如何修改它,使其適應多種不同的情況。然而,在現實世界中,這看起來似乎少之又少。對iptables的學習並非是一個簡單的過程,不過筆者在這裡向您推薦外網上如下資料,這樣使用起來你就得心應手了。 筆者認為所有的管理員都應徹底地理解Iptables,不過,另外一個可選擇的方法是運用出色的Linux防火牆產生工具。 Firewall Builder
Time of Update: 2013-12-13
OLPC組織推廣廉價筆記本的努力已經被越來越多的公司接受。OLPC前總裁沃爾特-本德(Walter Bender)日前正在與英特爾等4家筆記本廠商談判,推廣Linux系統。 OLPC組織在誕生之初其發展前景並不明朗,然而該機構推出的XO廉價筆記本近日卻逐漸成為業界關注焦點。 本德於上月從OLPC組織離職,並成立開源軟體公司蜜糖實驗室(Sugar Laboratories)。近日有訊息稱該公司正在與Pixel Qi進行談判,並且對於與英特爾結為夥伴關係很有興趣。
Time of Update: 2013-12-13
在核心的代碼和驅動程式中經常見到ERR_PTR, IS_ERR, PTR_ERR這三個內嵌函式。 許多的核心功能需要返回一個指標,但是函數的調用可能失敗,一般我們處理這樣的情形都是返回一個NULL指標,就像malloc或kmalloc在沒有獲得指定的空間申請時的傳回值一樣。但是有時我們想知道導致函數失敗的原因,但是返回NULL就顯得資訊不夠。因此有些函數返回一個實際的錯誤編碼以便對引起錯誤的原因做一些處理。很多核心介面通過把錯誤值編碼到一個指標值中來返回錯誤資訊。當處理這樣的函數時,
Time of Update: 2013-12-13
該版本基於紅帽企業 Linux 5.5,來自 CentOS 社區網站的報道。歡迎來到 CentOS 5.5 的發行。CentOS 是一個企業級的 Linux 發行版本,它源於上遊作業系統提供者(UOP)免費公開的原始碼。CentOS 完全遵守上遊提供者的再發行政策,並且以百分之百的軟體相容性為目標。(CentOS 對組件的修改主要是去除上遊供應商的商標及美工圖)。CentOS 是一個免費的作業系統。CentOS 5.5 是 CentOS 5
Time of Update: 2013-12-13
下載相關軟體mod_perl-1.27.tar 下載:http://perl.apache.org/download/index.html下載mod_perl壓縮包,要下載mod_perl 2.0,因為我用的是APACHE2.X的,如果是apache1.X的就下載mod_perl1.0 解包,執行:perl Makefile.PL MP_APXS=/usr/local/apache/bin/apxsmake make test make install
Time of Update: 2013-12-13
學會這 10 個技巧後,您將成為世界上最強大的 Linux® 系統管理員,整個世界是有點誇張,但要在一個大團隊中工作,這些技巧是十分必要的。學習 SHH 通道、VNC、密碼恢複、控制台偵察等等。各個技巧都附有例子,可以將這些例子複製到自己的系統中。好的系統管理員區分在效率上。如果一位高效的系統管理員能在 10 分鐘內完成一件他人需要 2 個小時才能完成的任務,那麼他應該受到獎勵(得到更多報酬),因為他為公司節約了時間,而時間就是金錢,不是嗎?
Time of Update: 2013-12-13
轉載地址: 先設定SecureCRT上傳檔案儲存路徑 options -> session -> Xmodem/Zmodem -> upload / download -> ok 然後確認一下系統中是否有 sz rz 這兩個命令(FreeBSD下命令是 lrz、lsz) 如果有就跳過這裡,如果沒有,則安裝lrzsz 在網上可以很容易找到,比如說 之後是常規安裝方法,解壓,configure;make;make
Time of Update: 2013-12-13
紅帽企業級Linux 6版本是紅帽最新發行的一款最成功的資料中心平台,該版本能夠提供先進效能的應用程式以及優秀的可擴充性和安全性。通過該版作業系統,你可以輕鬆的在你的資料中心上搭載虛擬化和雲端運算服務,減少實際操作的複雜性、減少實際開銷、充分發揮系統的效能。那麼目前備受關注的Redhat 企業版Linux 6究竟有哪些新特性呢? 效率、可擴充性和可靠性 紅帽企業版Linux
Time of Update: 2013-12-13
在centos5.4上按常規方法編譯高版本核心重啟後會出錯, 解決辦法是cp /boot/config-2.6.18-164.el5 .config後, 在make menuconfig, 然後修改.config, 把CONFIG_SYSFS_DEPRECATED選項開啟, 在make的時候會提示是否要開啟CONFIG_SYSFS_DEPRECATEDV2,選擇開啟, make modules_install install完畢, 重啟後應該還是會報錯的:insmod: error
Time of Update: 2013-12-13
一個應用需要在linux伺服器上運行,不能保證每個伺服器都有應用依賴的庫,又懶得每個伺服器都去安裝下,也不太現實,於是就將應用所用到的庫全部編譯為靜態庫,直接丟到伺服器上跑吧。此為應用調用xml設定檔依賴tinyxml庫樣本,記錄下,備忘。 1.下載tinyxml庫,直接從官方下載,http://sourceforge.net/projects/tinyxml/。
Time of Update: 2013-12-13
解決ssh連線逾時的有效辦法(ssh的usedns選項) ssh登入伺服器時總是要停頓等待一下才能串連上,這是因為OpenSSH伺服器有一個DNS尋找選項UseDNS預設是開啟的。 UseDNS選項開啟狀態下,當用戶端試圖登入OpenSSH伺服器時,伺服器端先根據用戶端的IP地址進行DNS PTR反向查詢,查詢出用戶端的host name,然後根據查詢出的用戶端host name進行DNS
Time of Update: 2013-12-13
linux user account&group linux帳號: /etc/passwdroamer:x:500:500:personal:/home/roamer:/bin/bash帳號名稱:口令:UID:GID:使用者資訊說明欄:家目錄:Shell www.2cto.com
Time of Update: 2013-12-13
複製CentOS 6網卡無法自動識別的解決方案 VMware 下LINUX下使用ifconfig查看時無eth0網卡相應資訊! 最近裝了虛擬機器系統centos 6.2,為了以後使用方便對虛擬機器進行複製或複製。當使用複製後的虛擬機器時發現原來在基本系統中的網卡eth0到了新系統卻沒有了,使用 ifconfig
Time of Update: 2013-12-13
如何閱讀不同格式的Ubuntu/Linux協助文檔 Ubuntu和Linux的協助文檔有各種各樣的格式,下面簡單說下如何閱讀這些協助文檔。 1)通過man命令閱讀軟體或命令的manual page。例如閱讀man命令的manual頁面可使用如下命令: man man www.2cto.com 2)less命令閱讀普通文字檔 less
Time of Update: 2013-12-13
很多人貌似認為compiz必須要emerland,但事實上,沒這個必要。 compiz+gnome,實用,而又華麗,是個不錯的選擇。 compiz需要顯卡驅動,一般情況下不成問題(別忘了這是很新的cent),如果你真有問題,自行找其他教程解決,本教程假設你的顯卡被預設支援。 如果你沒有安裝rpmfusion的源,先安裝。方法很多,這裡不講了。 在你安裝了centos6.x+gnome的前提下:首先進入root,> yum install
Time of Update: 2013-12-13
問題描述: 今天突然發現除了root之外的使用者都啟動不起來startx,報: Java代碼 Fatal server error: PAM authentication failed, cannot start X server. Perhaps you do not have console ownership? When reporting a problem
Time of Update: 2013-12-13
ubuntu下手動安裝jre全過程 1、jre安裝包:jre-6u21-linux-i586.bin(解壓後為jre1.6.0_21); 2、將解壓後的jre1.6.0_21移至/usr/lib/java下; 3、添加環境變數:$sudo vim /etc/environment //添加如下行 www.2cto.com
Time of Update: 2013-12-13
SUSE Linux 10配置裸裝置(raw devices) 裸裝置,是沒有經過格式化的分區或磁碟,也叫裸分區(原始分區),不被Unix通過檔案系統來讀取的特殊字元裝置。它由應用程式負責對它進行讀寫操作。不經過檔案系統的緩衝,是不被作業系統直接管理的裝置。由於跨過作業系統管理,使得I/O效率更高。 在基於SUSE Linux 10上安裝Oracle 10g RAC的話,由於Oracle 10g 不支援將ocr與votingdisk 存放在ASM
Time of Update: 2013-12-13
CentOS安裝完畢後,會要求進行初始化配置。[1] CentOS 6初次開機時的歡迎介面,點擊“Forward” [2] License Agreement, 當然是選擇Argee.[3] 建立使用者,此處先不建立,直接Forward,暫時先使用root帳號。[4] 時間設定,設定為正確的時間,也可以勾選複選框“Synchrconize date and tim of your system”自動從網路同步[5]