Oracle中有關Latch的介紹

   本文向各位闡述Oracle的Latch機制,Latch,用金山詞霸翻譯是門插栓,閉鎖,專業術語叫鎖存器,我開始接觸時就不大明白為什麼不寫Lock,不都是鎖嗎?只是翻譯不同而以?研究過後才知道兩者有很大的區別。  Latch是Oracle提供的輕量級鎖資源,他用於快速,短時間的鎖定資源,防止多個並發進程同時修改訪問某個共用資源,他只工作在記憶體中,我們可以不大準確的說,記憶體中資源的鎖叫latch,資料庫物件(表,索引等)的鎖叫Lock。比如資料緩衝中的某個塊要被讀取,我們會獲得這個塊的la

匯出oracle 資料庫中的資料字典

使用工具   1、PowerDesigner 15              2、PDMReader方法    1、 開啟PowerDesigner 15, 建立Physical Database Model          2、 設定Oracle伺服器, 選擇菜單 Database -> Configure Connections -> ODBC File Data Sources -> Add Data Sources  在Create New Data Source

DBA入門之Oracle資料庫參數

在Oracle資料庫中,有一系列的初始化參數用來進行資料庫約束和資源限制,這些參數通常儲存在一個參數檔案中,在資料庫執行個體啟動時讀取並載入。初始化參數對資料庫來說非常重要,很多參數通過合理的調整可以極大地提高資料庫效能,下面對資料庫參數進行相關探討,有關參數檔案請留意後續文章。  初始化參數的分類按照得出方式不同,初始化參數可以分為3類:推導參數、作業系統依賴參數和可變參數。 1. 推導參數(Derived

oracle 11g ORA-12541: TNS: 無監聽程式 (DBD ERROR: OCIServerAttach)

em無法瀏覽,同時監聽起不來。同時他的監聽服務還是正常的,我做了兩步修改  這個問題,最被大家認可的原因是IP地址變動,或者是其它原因,導致Oracle設定檔中的機器名或者IP不能被識別。有種解決辦法是修改Network Configuration File: %ORACLE_HOME%\network\admin\下的tnsnames.ora和listener.ora檔案,

Oracle 分區索引詳解

文法:Table Index CREATE [UNIQUE|BITMAP] INDEX [schema.]index_nameON [schema.]table_name [tbl_alias](col [ASC | DESC]) index_clause index_attribsindex_clauses:分以下兩種情況1. Local Index 就是索引資訊的存放位置依賴於父表的Partition資訊,換句話說建立這樣的索引必須保證父表是Partition1.1

ORACLE使用者常用資料字典查詢

ORACLE使用者常用資料字典查詢         查看目前使用者的預設資料表空間        SQL>select username,default_tablespace from user_users;        查看目前使用者的角色        SQL>select * from user_role_privs;        查看目前使用者的系統許可權和表級許可權        SQL>select * from user_sys_privs;       

Oracle 輸入錯誤次數修改、使用者解鎖、密碼到期

   一般資料庫預設是10次嘗試失敗後鎖住使用者;1、查看FAILED_LOGIN_ATTEMPTS的值                  select * from dba_profiles;2、修改為30次alter profile default limit FAILED_LOGIN_ATTEMPTS 30;3、修改為無限次(為安全起見,不建議使用)alter profile default limit FAILED_LOGIN_ATTEMPTS unlimited; 使用者解鎖:    

Oracle Error Workaround

在實際項目中使用ORACLE時出現的一些問題,通過變通的方案將問題避免了,特撰此文,以備忘用!1.ORA-01403:NO DATA FOUND-未找到資料  a.加一個exception異常處理Code highlighting produced by Actipro CodeHighlighter (freeware)http://www.CodeHighlighter.com/-->EXCEPTION WHEN NO_DATA_FOUND THEN ...  

關於.net操作Oracle資料庫,parameters參數順序的問題。

 代碼Code highlighting produced by Actipro CodeHighlighter (freeware)http://www.CodeHighlighter.com/--> 1  /// <summary> 2         /// 插入資料 3         /// </summary> 4         public void Insert(Users _users, IDbTransaction transaction) 5   

【原】Oracle使用者名稱和密碼鎖定處理

新安裝了Oracle 11g 第2版,直接連接,提示使用者名稱scott鎖定。看來需要先解鎖scott使用者了。開啟sql plus,提示如下:請輸入使用者名稱:(這裡輸入內容後斷行符號)sys/as sysdba輸入口令:(這裡不輸入,直接斷行符號)這種登陸啟用的是OS驗證方式,因此不用輸入使用者名稱,密碼 提示如下:Oracle Database 11g Enterprise Edition Release 11.2.0.1.0...字樣 再輸入:SQL>alter user

ORACLE 9i資料庫伺服器的體繫結構

  2.4.1 進程結構    Oracle 9i網路環境裡共有兩大類進程。    1. 使用者進程    使用者進程是在客戶機記憶體上啟動並執行程式,如客戶機上啟動並執行【SQL Plus】、【企業治理器】等。使用者進程向伺服器處理序提出操作請求。    2. 伺服器處理序    主要的伺服器處理序如表2.5所示。表2.5 Oracle

oracle 9i下線上重定義表

9i提供了聯機重定義表的方法,可以讓你在基本不影響原表的DML情況下修改表結構。實際上,聯機重定義表並不是完全的聯機重定義,在最後交換表名的時候會短暫地鎖定原表和中間表,但這個過程很短暫,相對於傳統方法來說,這是一個進步。/*9i提供了聯機重定義表的方法,可以讓你在基本不影響原表的DML情況下修改表結構。實際上,聯機重定義表並不是完全的聯機重定義,在最後交換表名的時候會短暫地鎖定原表和中間表,但這個過程很短暫,相對於傳統方法來說,這是一個進步。利用聯機重定義功能可以線上實現如下功能:修改表的儲存

oracle 分頁 sql

在項目改造中,原同事寫的分頁是從資料庫查詢出所有記錄後再分頁,現在改造成動態查詢出所分出來的頁和記錄數。//查詢第100條到第199條記錄select * from(select B.*,RowNumber rn from  (select * from A) B  where B.rn>=100) where

學習oracle的幾個角色

 相信大家都知道的. 角色是一組許可權的集合.而Oracle內建了一些角色,便於我們進行簡單的管理少說廢話,進入正題。   一.oracle的幾個簡單角色          1.CONNECT          2.RESOURCE   二.逐個分析內建角色         1.CONNECT                查詢CONNECT角色的許可權                   select grantee,privilege from dba_sys_privs where

Oracle維護:每天的工作

檢查資料庫狀態確認所有的INSTANCE狀態以及listener狀態正常,登陸到所有資料庫或常式,檢測ORACLE後台進程: $ ps –ef|grep ora $ lsnrctl statusSQL> select status from v$instance;檢查檔案系統如果檔案系統的剩餘空間過小或增長較快,需對其進行確認並刪除不用的檔案以釋放空間。$df –k$df -h檢查警告記錄檔(alert_SID.log)Oracle在運行過程中,會在警告記錄檔(alert_SID.log)

oracle之報錯:ORA-00054: 資源正忙,要求指定 NOWAIT

問題如下:SQL> conn scott/tiger@vm_databaseConnected to Oracle Database 11g Enterprise Edition Release 11.1.0.6.0Connected as scott。。。。。。SQL> drop table student2;drop table student2ORA-00054: 資源正忙, 但指定以 NOWAIT 方式擷取資源, 或者逾時失效=========================

oracle資料檔案(2)

一、 控制檔案控制檔案是一個相當小的檔案(最多增長到64Mb左右)。參數檔案告知執行個體控制檔案的位置,控制檔案則告知執行個體資料庫和線上重做記錄檔位置。控制檔案還告知ORACLE一些事情,如已發生檢查點的有關資訊、資料庫名(必須與DB_NAME參數匹配)、建立資料庫的時間戳記、歸檔重做日誌的曆史(有時這會讓控制檔案變大)、Rman資訊等。二、

Oracle SQLPlus的一個低級錯誤

       前幾天在RedHat AS 4.1上安裝Oracle 10G ,在建立資料庫的過程中始終報告:ORA-12154: TNS:could not resolve service name。 不知道為什麼這樣,然後就到網上到處搜尋解決辦法。每一種可能想到的原因試了,Oracle

Oracle各種日期計算方法

一個月的第一天  SELECT to_date(to_char(SYSDATE,'yyyy-mm')||'-01','yyyy-mm-dd')FROM dualsysdate 為資料庫伺服器的當前系統時間。to_char 是將日期型轉為字元型的函數。to_date 是將字元型轉為日期型的函數,一般使用 yyyy-mm-dd hh24:mi:ss格式,當沒有指定時間部分時,則預設時間為 00:00:00dual 表為sys使用者的表,這個表僅有一條記錄,可以用於計算一些運算式,如果有好事者用

Oracle的列操作(增加列,修改列,刪除列),包括操作多列

增加一列:   alter table emp4 add test varchar2(10);修改一列:   alter table emp4 modify test varchar2(20);刪除一列:alter table emp4 drop column test;   這裡要注意幾個地方,首先,增加和修改列是不需要加關鍵字COLUMN,否則會報錯ora-00905。  其次,對刪除單列的話,一定要加COLUMN,然後記住,刪除是不需要加列類型的。 增加多列:   alter table

總頁數: 1509 1 .... 150 151 152 153 154 .... 1509 Go to: 前往

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.