使用者的最大串連數查看該使用者的最大串連數select profile from dba_users where username='APP_TEST';select * from dba_profiles where profile='PF_APP_TEST' and resource_name='SESSIONS_PER_USER';查看該使用者當前的串連數select count(*) from v$session where username='
1.參數檔案的設定(1)查看動態參數檔案select * from sys.props$ wherename='NLS_CHARACTERSET';動態參數檔案:spfile:其中的動態參數修改能夠立即生效(2)修改動態參數alter system set 參數=值 scope=<memory><spfile><both>#memory 僅當前生效;(適用於動態參數)#spfile: 當前不生效;重啟後生效;(適用於動態,靜態參數)#both:
DATAGUARD配置如下:PROD為主庫,SBDB為備庫日誌組1-3組為redolog file,4-6組為standby log在建立standby log後主庫關庫,使用冷備tar包將資料轉送到備庫進行的恢複。DG配置完成之後,啟動備庫之後,備庫alert日誌報錯如下:Errors in file /u01/app/oracle/admin/SBDB/udump/sbdb_rfs_14903.trc:ORA-00313: open failed for members of log
called an Oracle Local Registry (OLR): each node in a cluster has a local registry for node-specific resources測試一:類比olr異常丟失的情況:這裡首先將olr renam[root@vmrac2 cdata]# mv vmrac2.olr vmrac2.olr.bak然後嘗試去啟動crs[root@vmrac2 cdata]# crsctl start crsCRS-4124:
預設情況下,AWR的資訊每隔一個小時收集一次AWR資訊,並保留7天。這些資料存放在SYSAUX資料表空間中,可能會導致SYSAUX資料表空間不足,如果SYSAUX空間嚴重不足,將會在alter日誌報ORA-1683和ORA-1688錯誤,建議修改為每隔4小時收集一次並保留3天的資料。現象描述:版本:oracle 11.0.7oracle日常檢查中發現alter日誌報如下錯誤:ORA-1683: unable to extend index SYS.WRH$_LATCH_PK
Oracle 11g預設安裝資料庫啟動了audit功能,導致oracle不斷累積sys.aud$表及相關索引資料量增加;如果導致資料表空間滿了,在alert日誌中將會報ORA-1654: unable to extend index SYS....錯誤。如果不用到審計功能,建議關閉審計。處理過程:1、用oracle使用者登入到資料庫伺服器,執行:sqlplus / as sysdba2、取消audit,將初始化參數audit_trail設定為NONEalter system set audit_
今天在往一個壓縮表增加一個欄位可以增加成功,但在刪除的時候報了個ORA-39726 unsupported add/drop column operation on compressed tables的錯誤。錯誤是不能對壓縮表增加或刪除欄位,奇怪的可以增加,但是不能刪除。即使將表MOVE為非壓縮表也還是不可以刪除。最後終於找到了一種方法那就是先將該欄位設定為UNUSED,然後在刪除UNUSED欄位即可。例如:ALTER TABLE test SET UNUSED COLUMN
今天一台測試機器的oracle服務端,在測試人員建庫的時候字元集設定成了WE8MSWIN1252字元集,導致無法儲存俄文等其他國家語言。於是我建議測試將字元集修改為AL32UTF8。首先查看服務端字元集select * from v$nls_parameters where parameter = 'NLS_CHARACTERSET'NLS_CHARACTERSET WE8MSWIN1252然後用sys使用者進行修改#sqlplus "/as
1.DBA_LOGSTDBY_EVENTS可以把該視圖看成邏輯Standby動作記錄,因此如果發生了錯誤,可以通過該視圖查看近期邏輯Standby都做了些什麼。預設情況下,該視圖只保留最近100條事件的記錄(可以通過相關過程修改儲存的記錄條數)。例如:SQL> SELECT EVENT_TIME,STATUS,EVENT FROM DBA_LOGSTDBY_EVENTSORDER BY EVENT_TIMESTAMP;EVENT_TIM STATUS