ora-12516 tns listener could not find available handler with matching protocol

      今天EPP(Enterprise Product Protal)系統間用戶端連線出現如題ORA-12516錯誤.      根據其需求,首先確認伺服器端監聽器和DB並沒有問題後,即判斷為用戶端串連問題;其二,尋找ORA-12516錯誤引起的原因,發現為Processes數量導致,Oacle的sessions和processes的關係是sessions=1.1*processes +

ORA-19905: log_archive_format must contain %s, %t and %r 出現及解決過程

歸檔日誌儲存的路徑由初始化參數log_archive_dest_N和db_recovery_file_dest指定:1.log_archive_dest_N,n最大值為31,即意味著可以有31個歸檔路徑,每個路徑上儲存的歸檔日誌一樣,但是,Oracle的歸檔又可以分為將日誌儲存在本地檔案系統上的和發送到遠程另一個資料庫上的本地歸檔和遠程歸檔,其中可以被用做本地歸檔的只有1~10.測試環境為:Windows 7,將歸檔日誌路徑設定為:D:\RMAN\archivelogSQL>alter

如何展現欄位名和值均以字串形式儲存到第三方表的資料集

今天在CSDN論壇上看到一個網友提的問題,他將欄位名和值均以字串的形式儲存在一個表中,這樣他的這個表可以擴充無數的紀錄,用不同紀錄代表的欄位來修飾不同的對象,但是他在寫查詢的時候遇到了難題,就是如何把字串還原成對應的一個資料集。問題連結請看:http://community.csdn.net/Expert/topic/4595/4595459.xml?temp=.9010736/*we have two table ,one is master table as

一個查看MSSQL資料庫中所有表資訊的SQL語句

SELECT        (case when a.colorder=1 then d.name else '' end)表名,       a.colorder 欄位序號,       a.name 欄位名,       (case when COLUMNPROPERTY( a.id,a.name,'IsIdentity')=1 then '√'else '' end) 標識,       (case when (SELECT count(*)FROM sysobjects      

關於在使用rowid和rownum時遇到ORA-01446錯誤的原因即解決方案。

 關於在使用rowid和rownum時遇到ORA-01446錯誤的原因即解決方案。ORA-01446: cannot select ROWID from view with DISTINCT, GROUP BY, etc. Cause:     A SELECT statement attempted to select ROWIDs from a view            containing columns derived from functions or expressions.

Win作業系統知識大全

Windows作業系統檔案夾     Cursors檔案夾     這是滑鼠指標檔案夾,用來存放除系統預設之外的滑鼠指標。一些美化系統案頭的程式在美化滑鼠時也是將自己的滑鼠指標存放在這個檔案夾中的。可以將檔案夾中的滑鼠指標刪除,對Windows系統預設的滑鼠指標不會有影響。     Debug檔案夾

你知道什麼是DBA嗎?

資料庫管理員,英文是Database

按成績排序

 IDUserNameClassIDScore1Aaa9802662Bbb9801703Ccc9801694ddd980188 設Score 不重複,得到每個 UserName 的 Score排名 2-2.f.1                     ------------------------------------------------------SELECT UserName,(SELECT COUNT(*) FROM Student WHERE

oracle10g監聽加密

author:skatetime:2011/05/12oracle10g監聽加密oracle10g的監聽安全管理機制和oracle9i有很大的變化,Listener的安全機制使用了Password方式和Local OS Authentication方式,在使用了Local OS

ORA-01280: Fatal LogMiner Error( 資料字典建立在ocfs2下)

author:skatetime:2011/05/30 ORA-01280: Fatal LogMiner Error. logminer的基本使用很簡單,按著基本步驟操作即可 1. 安裝在oracle10g中運行如下兩個指令碼即可:l $ORACLE_HOME/rdbms/admin/dbmslm.sql 2 $ORACLE_HOME/rdbms/admin/dbmslmd.sql.  這兩個指令碼用於建立兩個包(DBMS_LOGMNR 和 DBMS_

利用NFS遠程備份報 ORA-27054 錯誤解決辦法

生產系統需要匯出資料到一個NFS目錄下報錯bash-3.00$ expdp \'/ as sysdba\' directory=bak_data_pump_dir schemas=epm_ha dumpfile=epm_ha.dmp logfile=epm_ha.logExport: Release 10.2.0.4.0 - 64bit Production on Friday, 21 May, 2010 16:09:25Copyright (c) 2003, 2007, Oracle.

ORA-02050,ORA-02051 ERROR

今天在一個使用了DBLINK insert到本機資料庫的時候,執行insert操作本身正常,但是當COMMIT時,就報ORA-02050,ORA-02051 ERROR。/orabakup$oerr ora 205002050, 00000, "transaction %s rolled back, some remote DBs may be in-doubt"// *Cause: network or remote failure in 2PC.// *Action: Notify

TNS 12560 錯誤解決辦法

alert.log 錯誤 Fatal NI connect error 12170.  VERSION INFORMATION:        TNS for Solaris: Version 11.2.0.1.0 - Production        Oracle Bequeath NT Protocol Adapter for Solaris: Version 11.2.0.1.0 - Production        TCP/IP NT Protocol Adapter for

RMAN 備份概念的理解

RMAN 備份的概念和術語1、open 狀態的備份2、closed 狀態的備份3、complete backup4、Incremental backup冷備份:一致性備份、離線備份、closed 備份熱備份:非一致性備份、熱備份、open 備份open 狀態的備份只能在處于歸檔日誌方式進行,在非歸檔模式下只能進行clean closed 備份,並且資料庫必須啟動到 mounted 狀態RMAN 可以備份的檔案:data filecontrol filearchived redo

AIX 6.1 上 NTP 時鐘同步配置詳解

ntp同步伺服器時間NTP服務目前用的並不多,最近做一個項目,DB2叢集,對時間一致性有些要求,所以想了ntp,雖說timed也可以用,但是只對廣播域有效,還是ntp功能強大些。配置:首先,選擇一台伺服器作為校準伺服器。AIX5L已經內建了ntp服務,名字叫做xntp,用lssrc -a可以看到,預設是不啟動。xntp服務使用/etc/ntp.conf檔案作為啟動設定檔,如果/etc下沒有這個檔案,可以從/usr/sample/xntp/下找到例子,不過例子非常簡單,沒啥用編輯

如何將rdba轉換成資料檔案的地址

很多時候我們在進行進一步研究時需要轉儲(dump)Oracle的資料區塊,以研究其內容,Oracle提供了很好的方式,我們通過以下例子簡單說明一下: [oracle@jumper udump]$ sqlplus "/ as sysdba"SQL*Plus: Release 9.2.0.3.0 - Production on Tue Aug 31 17:01:27 2004Copyright (c) 1982, 2002, Oracle Corporation.  All rights

/u01/app/grid/11.2.0/bin/clscfg.bin: error while loading shared libraries: libcap.so.1: cannot ope

[root@rac1 11.2.0]# ./root.shPerforming root user operation for Oracle 11gThe following environment variables are set as:    ORACLE_OWNER= grid    ORACLE_HOME=  /u01/app/grid/11.2.0Enter the full pathname of the local bin directory: [/usr/local/bin]:

【rman】命名格式串

--format='/u01/backup/arch_%U_%T' 這個是我們指定備份組命名的格式串,RMAN提供了與格式串關聯的一些文法元素,這些元素叫:預留位置。        rman 將使用相應的定義值來替換他們。 例如樣本中的 %U 文法元素告訴RMAN要使用系統產生的唯一表示符替換檔案名稱。 使用FORMAT參數時可使用的各種替換變數,如下(注意大小寫)所示:%a:Oracle資料庫的activationID即RESETLOG_ID。%c:備份片段的複製數(從1開始編號,最大不超過2

如何終止特定 RAC 執行個體上的 session

很多情況下,我們需要使用 alter system kill session 終止資料庫上的某個 session,釋放該 session 所佔用的資源來解決問題。比如,daniel 所在的環境就經常使用如下語句批量語句殺死資料庫中的 session。select 'ALTER SYSTEM KILL SESSION '''||b.sid||', '||b.serial#||''';'from gv$access a,gv$session bwhere a.SID=b.SIDand

【道森試聽】壞塊處理(data block)——Roger大師

資料庫壞塊是指由於硬體錯誤等問題導致資料庫在寫入資料區塊時出現異常(nologing也可能導致).通常,我們將壞塊分為2類,物理壞塊和邏輯壞塊。產生原因:硬體io問題,作業系統問題記憶體錯誤,磁碟修複導致例如fsck,oracle本身問題以及nologging操作等等。Badheader - the beginning of the block (cache header)is corrupt with invalid valuesThe block is

總頁數: 61357 1 .... 7690 7691 7692 7693 7694 .... 61357 Go to: 前往

聯繫我們

該頁面正文內容均來源於網絡整理,並不代表阿里雲官方的觀點,該頁面所提到的產品和服務也與阿里云無關,如果該頁面內容對您造成了困擾,歡迎寫郵件給我們,收到郵件我們將在5個工作日內處理。

如果您發現本社區中有涉嫌抄襲的內容,歡迎發送郵件至: info-contact@alibabacloud.com 進行舉報並提供相關證據,工作人員會在 5 個工作天內聯絡您,一經查實,本站將立刻刪除涉嫌侵權內容。

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.