Time of Update: 2016-09-05
如題 回複內容:PHPhub - PHP & Laravel的中文社區 一個乾淨, 純粹的, 積極向上的 PHP 中文社區, 歡迎加入. 網站是使用 Laravel4 編寫的, 代碼基於 MIT Licence 開源 summerblue/phphub · GitHub , 歡迎大家貢獻代碼.推薦一下自己的小站:LaraBase - PHP工匠之家@二先生 瀉藥,我知道你現在在學習 laravel
Time of Update: 2016-08-27
現在很多雲主機的Integration Environment或者各種公用雲端也預設提供的都是lighttpd或者nginx伺服器,為什麼這些效能更高的伺服器軟體沒有取代apache?
Time of Update: 2016-08-22
之前在MySQL建表和查詢的時候都用的單引號,後來發現有問題,同學提醒要用反引號,最近發現反引號也會出問題:1.2.在網上看到有說,反引號是為了區分MySQL的保留字和一般字元,這樣的話第2個可以解釋,但是第1個是為什麼呢。其實單引號和反引號的實際不同是什嗎?MySQL在對這兩個符號的操作是怎樣的?求解,謝謝。回複內容:注意學習。Certain objects within MySQL, including database, table, index, column, alias,
Time of Update: 2016-08-18
要提交的資料必須放在input標籤或者textarea標籤內嗎?放在別的標籤裡面就不行嗎?比如span標籤為什麼就不行?如果用input或者textarea不方便怎麼辦?
Time of Update: 2016-08-18
xxd filename可以將一個檔案的二進位形式顯示在終端,無需考慮檔案是什麼形式的編碼。如何用php實現同樣的功能?1.fopen2.fread3.ehco不行,不能顯示文本的二進位,顯示的是文本,請問,這裡如何做?我寫了一段代碼發現不行,顯示的是字元本身,不是字元的二進位表達。預計這個ehco要改,請問,如何修改。fwrite(STDOUT,$byte); 替換 echo $byte; 也不行。修改了一下,離成功不遠了。用一個只包含換行鍵的檔案測試xxd -b
Time of Update: 2016-08-18
js操作就這樣ws = new WebSocket($("#uri").val()); //串連成功建立後響應 ws.onopen = function() { } //收到伺服器訊息後響應 ws.onmessage = function(e) { } //串連關閉後響應 ws.onclose = function() { ws = null; }有什麼js介面嗎
Time of Update: 2016-08-18
下面是一行nginx錯誤記錄檔,為了便於查看,我給大家做了分隔:016/08/14 14:34:49 [error] 2819#0: *59 FastCGI sent in stderr: "PHP message: PHP Warning: log4php: Configuration failed. Error loading configuration file: failed to load external entity
Time of Update: 2016-08-18
首先,我的運行環境是Ubuntu14.04+Nginx1.4+MySQL5.6+PHP;其次,我現在遇到的問題是,我瀏覽器訪問nginx根目錄下的PHP項目的時候,報403forbidden錯誤,但是,訪問單個的php檔案是沒有問題的。求各位大神指導一下
Time of Update: 2016-08-17
1、在視圖間共用資料除了在單個視圖中傳遞指定資料之外,有時候需要在所有視圖中傳入同一資料,即我們需要在不同視圖中共用資料。要實現這一目的,需要使用視圖工廠的share方法。全域協助函數view和response類似,如果傳入參數,則返回Illuminate\View\View執行個體,不傳入參數則返回Illuminate\View\Factory執行個體。所以我們可以通過在服務提供者的boot方法中使用如下方式實現視圖間共用資料:share('sitename','Laravel學院'); }
Time of Update: 2016-08-08
定義和用法parse_ini_file() 函數解析一個設定檔,並以數組的形式返回其中的設定。文法parse_ini_file(file,process_sections)參數描述file必需。規定要檢查的 ini 檔案。process_sections可選。如果設定為 true,則返回一個多維陣列,包括了設定檔中每一節的名稱和設定。預設是 false。說明ini 檔案的結構和 php.ini 的相似。常量也可以在 ini 檔案中被解析,因此如果在運行
Time of Update: 2016-08-08
在php中字元替換函數有幾個如有:str_replace、substr_replace、preg_replace、preg_split、str_split等函數:1,Str_replace()函數:使用一個字串替換字串中的另一些字元。(大小寫敏感,二進位安全)(1)格式:str_replace(find,replace,string,count)(2)參數 描述:find 必需。規定要尋找的值。replace 必需。規定替換 find 中的值的Í
Time of Update: 2016-08-08
與註冊一樣,discuz修改密碼是單向修改,不會主動通知其它應用網站。要實現此功能只能改UCenter的機制,下面給出步驟:修改一:UC後台更改密碼後的通知程式:主目錄/uc_server/control/admin/user.php 277行將:$_ENV['note']->add('updatepw', 'username='.urlencode($username).'&password=');更改為: $_ENV['note']->add('updatepw', 'username='.
Time of Update: 2016-08-08
參考自RFC 2616,並由RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等規範擴充。紅字代表比較常見的幾種STATUS CODE"100" : Continue"101" : Switching Protocols"102" : Processing (WebDAV;RFC 2518)"200" : OK"201" : Created"202" : Accepted"203" : Non-Authoritative Information
Time of Update: 2016-08-08
我們都知道,只要合理正確使用PDO,可以基本上防止SQL注入的產生,本文主要回答以下兩個問題:為什麼要使用PDO而不是mysql_connect?為何PDO能防注入?使用PDO防注入的時候應該特別注意什麼?一、為何要優先使用PDO?PHP手冊上說得很清楚:Prepared statements and stored proceduresMany of the more mature databases support the concept of prepared statements.
Time of Update: 2016-08-08
轉載:http://blog.csdn.net/huyanping/article/details/7068356經常會碰到需要從資料庫中匯出資料到Excel檔案,用一些開源的類庫,比如PHPExcel,確實比較容易實現,但對大量資料的支援很不好,很容易到達PHP記憶體使用量上限。這裡的方法是利用fputcsv寫CSV檔案的方法,直接向瀏覽器輸出Excel檔案。 // 輸出Excel檔案頭,可把user.csv換成你要的檔案名稱 header('Content-Type:
Time of Update: 2016-08-08
先來說一說HTTP的異常處理問題。當urlopen不能夠處理一個response時,產生urlError。不過通常的Python APIs異常如ValueError,TypeError等也會同時產生。HTTPError是urlError的子類,通常在特定HTTP URLs中產生。
Time of Update: 2016-08-08
情境:一個類比鴨子的遊戲,遊戲中有各類鴨子,鴨子會叫,會遊泳。初步設計方案圖如下uml類圖所示:Change:這個初期看上去無懈可擊,直到有一天遊戲需要鴨子會飛,此時最簡單的解決方案莫過於在父類中增加一個fly方法,uml圖如下所示:有一天災難發生了:遊戲中有很多橡皮鴨飛來飛去。。。。此時最簡單的解決方案莫過於:覆蓋掉RubberDuck類中的fly方法,類圖如下:Change:遊戲越來越受歡迎,除了橡皮鴨,還有很多各種各樣的鴨子加入了進來,如DecoyDuck(誘餌鴨),不會叫也不會飛,我們也
Time of Update: 2016-08-08
話就不多說了,nginx安裝與配置,還有負載平衡呢,可以看我寫的另一篇文章《nginx負載平衡實戰》,還有關於負載平衡呢,大家可以看一下我寫的另外兩篇文章,一個是《lvs+keepalived負載平衡》,另一個是《haproxy+keepalived負載平衡》,三種負載平衡的區別呢,可以看一下我轉載的一篇文章《軟體級負載平衡器(LVS/HAProxy/Nginx)的特點簡介和對比》,下面直接進入配置步驟:1.系統內容[plain] view
Time of Update: 2016-08-08
1、nginx相對於apache的優點: 輕量級,同樣起web 服務,比apache佔用更少的記憶體及資源 抗並發,nginx 處理請求是非同步非阻塞的,而apache 則是阻塞型的,在高並發下nginx 能保持低資源低消耗高效能 高度模組化的設計,編寫模組相對簡單 社區活躍,各種高效能模組出品迅速啊 apache 相對於nginx 的優點: rewrite ,比nginx 的rewrite 強大 動態網頁面模組超多,基本想到的都可以找到 少bug ,nginx 的bug 相對較多 超穩定
Time of Update: 2016-08-08
$criteria = new CDbCriteria(); $criteria->addCondition("customid = :customid"); $criteria->params= array(':customid'=>$customid); if(trim($groupid)!=""){ $criteria->addCondition ('groupid' = :groupid);$criteria->params= array('