Time of Update: 2016-08-08
轉自:http://blog.csdn.net/a600423444/article/details/12720543前言開發中必不可少的環節就是調試,而調試的方式直接影響到開發效率和軟體品質。之前開發PHP擴充,一直不會DEBUG調試,每次調試都是重新編譯、執行再運行PHP指令碼看健全狀態再調試。太痛苦、太影響效率了。也百度、Google了如何調試PHP擴充的問題,但回答的幾乎都是GDB,可惜也不知道如何實際操作。VS用的不多,很多功能也不知道幹嘛的,前幾天有位同事說可以用VS的“附加到進程”
Time of Update: 2016-08-08
vim 代碼規範工具php-cs-fixer.phar (參考https://github.com/FriendsOfPHP/PHP-CS-Fixer) INSTALLcurl http://get.sensiolabs.org/php-cs-fixer.phar -o php-cs-fixer sudo chmod a+x php-cs-fixer sudo mv php-cs-fixer
Time of Update: 2016-08-08
.表示除\n之外的任一字元;*表示匹配0-無窮;+表示匹配1-無窮;.* — 表示匹配0個或多個處分行符號以外的字元;.+ — 表示匹配1個或多個處分行符號以外的字元;後邊沒有?時表示貪婪模式(非懶惰模式);後邊多一個?表示懶惰模式;?必須跟在*或者+後邊用;如:如果用正則匹配src中內容非懶惰模式比對src=".*"匹配結果是:src="test.jpg" width="60" height="80"意思是從="往後匹配,直到最後一個"匹配結束懶惰模式正則:src=".
Time of Update: 2016-08-08
class MaxHeap extends SplHeap{ public function compare($value1, $value2) { return ($value1 - $value2); } public function GetKMinNum($arr, $k){ if(is_array($arr) && $k > 0){ $count = count($arr); for($i=0;
Time of Update: 2016-08-08
我們一直致力於提升PHP7的效能, 上個月我們注意到GCC的PGO能在Wordpress上能帶來近10%的效能提升, 這個讓我們很激動.然而, PGO正如名字所說(Profile Guided Optimization 有興趣的可以Google), 他需要用一些用例來獲得反饋, 也就是說這個最佳化是需要和一個特定的情境綁定的.你對一個情境的最佳化, 也許在另外一個情境就事與願違了. 它不是一個通用的最佳化. 所以我們不能簡單的就包含這些最佳化,
Time of Update: 2016-08-08
$method();}//取到攔截鏈中的下一個攔截器$handler = $this->interceptorChain->getHandler();//遞迴迴圈,把所有攔截鏈中的攔截器都迴圈一遍,並挨個執行這個方法if (null !== $handler){ $handler->handle($method);}return;} /** * 設定攔截鏈對象(用以傳遞控制到下一個攔截器) * * @param interceptorChain
Time of Update: 2016-08-08
php擷取當前頁面url路徑#測試網址: http://localhost/blog/testurl.php?id=5 //擷取網域名稱或主機地址 echo $_SERVER['HTTP_HOST'].""; #localhost //擷取網頁地址 echo $_SERVER['PHP_SELF'].""; #/blog/testurl.php //擷取網址參數 echo $_SERVER["QUERY_STRING"].""; #id=5
Time of Update: 2016-08-08
最近又要開始用 PHP 做開發,每次都要查一遍怎麼安裝配置環境,各個地方寫的還不一樣很煩。自己寫。Apache進入官網,開啟 Download頁面,下載最新版的壓縮包;解壓到自己想安裝的目錄下,我這裡是放到了 F:\Program Files\Apache 中;進入 F:\Program Files\Apache\conf 目錄,編輯器開啟 httpd.conf 檔案。修改如下部分: line 37: ServerRoot "c:/Apache24" -> ServerRoot
Time of Update: 2016-08-08
同事昨天接到一個任務,要用php處理oracle資料庫的內容,但是php開啟oracle擴充不是像mysql那樣直接用就行,需要下一點東西才能開啟第一步 需要到oracle官方下載一個install client 包,在win下找到你對應系統版本的zip(注意這裡是系統版本)截止到2015-06-25,下載地址如下http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html例如選擇
Time of Update: 2016-08-08
Class 'SQLite3' not found沒啟用php_sqlite3.dll,所以找不到那個類。在php.ini中找到 extension=php_sqlite3.dll 將其前面的分號去掉,表示啟用。最好把php_sqlite.dll前面的分號也去掉。extension=php_sqlite.dllextension=php_sqlite3.dll重啟Apache或IIS伺服器還有個最重要的地方: 類型的擴充路徑檔案 extension_dir = "D:/worktool/php/
Time of Update: 2016-08-08
這篇文章主要介紹了PHP捕獲Fatal error錯誤的方法,使用register_shutdown_function來捕獲Fatal error錯誤,需要的朋友可以參考下Fatal error 一般是不需要捕獲的, 但是在一個複雜的程式中, 如果偶然出現記憶體不足導致fatal error就難以處理了.比如. fatal error 出在MySQL類中fetch的時候. 這個時候就很難定位到真正問題所在了.PHP異常處理中 可以通過set_error_handler來捕獲. 但是卻只能捕獲
Time of Update: 2016-08-08
轉自:http://www.jb51.net/article/58796.htm伺服器上的Nginx和PHP都是源碼編譯安裝的,不像ubuntu一樣有內建service啟動指令碼,所以不支援類似以前的nginx (start|restart|stop|reload)了。自己動手豐衣足食。以下指令碼應該在RHEL, Fedora, CentOS下都適用。一、Nginx啟動指令碼/etc/init.d/nginx複製代碼代碼如下:#!/bin/bash## Startup
Time of Update: 2016-08-08
個人使用過程中儲存一些使用PHPExcel的經驗,以便後來翻閱:與PHP的Yii架構結合,可以便於使用。而且根本不用網上所說的修改Yii的自動負載檔案等方法。具體使用方法:下載phpoffice http://phpexcel.codeplex.com/releases/view/119187下載後首級目錄結構是 Classes, Documentation, Examples, changelog.txt, install.txt,
Time of Update: 2016-08-08
centos+mono+nginx+jexus 搭建linux下c#運行環境測試----Centos 7.0 安裝Mono 3.4 和 Jexus 5.6----引自 http://www.cnblogs.com/shanyou/p/3887223.html一、更新系統,安裝編譯環境,為編譯Mono源碼做準備。1、 更新系統 yum –y update2、安裝Mono源碼安裝需要的庫yum -y install wget glib2-devel libtiff
Time of Update: 2016-08-08
php靜態包括:一、純靜態純靜態是指使用php產生純html檔案,然後前端訪問這個html檔案的過程;如果細分純靜態,那麼可以分為“局部純靜態”、“全部純靜態”;“全部純靜態”指完全靜態html檔案;“局部純靜態”即局部動態化,指靜態檔案中部分內容為動態內容(通過ajax來實現局部動態);二、偽靜態;偽靜態是指將動態網頁面的url地址轉換成類似於靜態頁面的url地址的過程;
Time of Update: 2016-08-08
laravel部署在nginx 總是出現 nginx 403 forbidden 如果不是許可權問題,也不是索引檔案的問題。那就是,laravel的主目錄指定錯了。原來不能指定laravel程式的根目錄。要指定在public目錄。Nginx 伺服器location / { try_files $uri$uri/ /index.php?$query_string;}著作權聲明:本文為博主原創文章,未經博主允許不得轉載。
Time of Update: 2016-08-08
一、PHP在Apache與ngnix下的運行模式。1)、Apache下有三種運行模式:CGI模式,模組化模式,FastCGI模式。CGI模式會是比較原始的方式,每一次接到請求會調用php.exe,解析php.ini,載入DLL等,速度自然慢。模組化模式,Apache預設以這種方式運行php,這是將php編譯成自己本身的一個模組,在處理php指令碼的時候不需要去調用php.exe程式,整個過程只有Apache進程進行處理,相對較為穩定。FastCGI模式是CGI模式的升級版,實現了類似
Time of Update: 2016-08-08
原因分析:可能是上傳的檔案損壞,或者是上傳目錄無寫入權限! 解決方案:第一:可以嘗試上傳其它圖片。第二:給uploads寫入許可權!linux服務的設定辦法ftp設定777許可權,子檔案夾選擇繼承!windows2003的話需要右鍵檔案夾屬性-->安全-->添加賬戶-->增加IUSER_機器名 可寫入許可權。第三:系統--系統基本參數--圖片/上傳檔案預設路徑:/uploads第四:要確定你的WEB目錄下 uploads 檔案夾裡檔案是否都存在,對照下織夢預設程式裡的檔案夾。
Time of Update: 2016-08-08
在之前的PHP基礎教程中我介紹了Nginx+PHP5(FastCgi)安裝配置教程,其中涉及了nginx的基礎操作命令-nginx啟動命令,為了更好的讓PHP在nginx上運行,我們需要掌握一些基礎的nginx命令,比如啟動、停止nginx服務命令、配置改變時重載nginx、檢查nginx設定檔命令等,下面來詳細介紹一下nginx基礎命令及其參數的含義。說明:我的nginx命令的作業環境是Windowsnginx命令:啟動nginx 在Windows上安裝好nginx後,我們需要啟動n
Time of Update: 2016-08-08
本次主要是在win7 64 上示範操作。web應用構建Memcached安裝配置啟動Tomcat配置所需jar包memcached-session-manager序列化contextxml配置Nginx安裝配置啟動測試參考web應用構建簡單構造web應用,這裡就不做描述了,具體的可以訪問我的Github。 為了方便顯示,在success.jsp上做區別,一個加上8080,一個加上8081。Memcached安裝、配置、啟動本次樣本使用了2個memcached節點,都在一台機子上。win7