Time of Update: 2018-12-05
定期自動執行的維護計劃: 用新的填充(占空)因子重建索引以重組資料和索引頁上的資料。這確保資料庫頁包含相等分布的資料和剩餘空間 ,這允許未來更快速成長。 從資料庫頁中移出空資料頁壓縮資料檔案。更新索引統計以確保查詢最佳化有表分布資料值得最新資訊。這允許查詢最佳化作出訪問資料的最優途徑的更好的判斷,因為它有關於資料存放區在資料庫中的更多資訊。雖然索引統計被sql
Time of Update: 2018-12-05
導讀: 前言 本文通過一個Bug的分析、解決,概述了使用Lumigent Log Explorer對SQL Server的交易記錄進行分析的方法,以及常見的資料庫誤操作後的恢複、撤銷方法 Bug描述 網站的文章模組有一個評分的功能: 使用者選擇1-5分,點擊提交後,文章的評分次數(Stars) + 1、總分(StarTotal) + 分數、平均分(StarAvg) = 新總分 / 新評分次數 文章頁面顯示使用者的平均分以及評分次數 評分功能中使用者最多打5分,最少打1
Time of Update: 2018-12-05
清除資料和執行計畫緩衝:DBCC DROPCLEANBUFFERSDBCC FREEPROCCACHE開啟統計資料:SET STATISTICS IO ONSET STATISTICS TIME ON開啟執行計畫:SETSHOWPLAN_TEXT ONSETSHOWPLAN_ALL ONSETSTATISTICS PROFILE ONSETSHOWPLAN_XML ONSETSTATISTICS PROFILE XML各選項的區別 CommandExecute Query?Include
Time of Update: 2018-12-05
◆優點: 執行速度更快。預存程序只在創造時進行編譯,而一般SQL語句每執行一次就編譯一次,所以使用預存程序執行速度更快。 預存程序用於處理複雜的操作時,程式的可讀性更強、網路的負擔更小。 使用預存程序封裝事務效能更佳。 能有效放注入,安全性更好。 可維護性高,在一些商務規則發生變化時,有時只需調整預存程序即可,而不用改動和重編輯程式。 更好的代碼重用。 ◆ 缺點: 預存程序將給伺服器帶來額外的壓力。 預存程序多多時維護比較困難。 移植性差,在升級到不同的資料庫時比較困難。
Time of Update: 2018-12-05
做項目時,最常用的資料庫即Sqlserver與Access資料庫莫屬了!但使用會經常發現很多SQL執行的問題。這裡整理出之間的差異,做個十大差異的總結。 ACCESS結構簡單容易處理,而且也能滿足多數的網站程式要求,也是初學者的試牛刀。 ACCESS是小型資料庫,既然是小型就有他根本的局限性: 1)、資料庫過大,一般ACCESS資料庫達到50M左右的時候效能會急劇下降! 2)、網站訪問頻繁,經常超過100人的線上時,處理速度會有影響!
Time of Update: 2018-12-05
SQL Server 2000 SP4 企業版 精簡版 8M 以前從網上下載了個精簡版,但需要安裝太多的東西,把我機器上的原版SQL 都給破壞了,前些日子修改了一下一直使用的自己的綠色版SQL ,打包做了個安裝程式,內附 SQL Server 2000 查詢分析器 和 用戶端網路工具 + 生產力 ,效能也不差,在XP、2000上試用通過,沒問題的。本沒想發布,但還是希望能給大家一點方便,特別是測試資料庫時。:(作者提供的失效了!我重新上傳到網盤)http://drag0n.qupan.com/4
Time of Update: 2018-12-05
在使用SQL Server 的過程中,使用者遇到的最多的問題莫過於串連失敗了。一般而言,有以下兩種串連 SQL Server 的方式,一是利用 SQL Server 內建的用戶端工具,如企業管理器、查詢分析器、事務探查器等;二是利用使用者自己開發的用戶端程式,如ASP 指令碼、VB程式等,用戶端程式中又是利用 ODBC 或者 OLE DB 等串連 SQL Server。下面,我們將就這兩種串連方式,具體談談如何來解決串連失敗的問題。 一、用戶端工具串連失敗
Time of Update: 2018-12-05
關於SQL Server 2000對XML支援的一些見解主要針對"select 欄位1,欄位2,...,欄位n from 表或多表聯集查詢 where 條件 for xml auto"類似語句的討論本人在使用以上語句產生XML資料時,發現了一些SQL Server
Time of Update: 2018-12-06
資料的匯入匯出是資料庫管理員常見的工作任務之一,尤其是一般檔案的匯入匯出。BCP 工具則為這些任務提供了強有力的支援,它是基於DB-Library,尤其是在生產環境中,從本地傳送資料到伺服器或從伺服器傳送資料到本地,因它無需提供圖形介面,減少網路頻寬,提高了傳輸速率。BCP的全稱是BULK COPY PROGRAM,它是一個命令列程式,可以完全脫離SQL server進程來實現。 常用的匯入方式:bcp, BULK INSERT,OPENROWSET,or SSIS。
Time of Update: 2018-12-06
--需求說明: /* id col ---------- ---------- AB00001 a AB00002 b --當再插入資料的時候讓id自動變成AB00003 */ --1.求最大值法(高並發時不適用,只是介紹個思路) --測試資料 if object_id('[macotb]') is not null drop table [macotb] create table [macotb] (id varchar(
Time of Update: 2018-12-06
本執行個體主要介紹如何將圖片存入資料庫。將圖片存入資料庫,首先要在資料庫中建立一張表,將儲存圖片的欄位類型設為Image類型,用FileStream類、BinaryReader把圖片讀成位元組的形式,賦給一個位元組數組,然後用ADO.SqlCommand對象的ExecuteNonQuery()方法來把資料儲存到資料庫中。主要代碼如下: private void button1_Click(object sender, EventArgs e) {
Time of Update: 2018-12-06
如果你的hmailserver使用的是sql server或mysql就簡單了,sql server的企業管理器和phpmyadmin都能輕鬆搞定,如果使用的是hmailserver內建的SQL Server Compact Edition資料庫呢?怎麼查詢裡面的資料?首先得先安裝一個SQL Server 2008的Management Studio,免費的Express版本就行了,試了一下2005版還不能用,在微軟網站上有,裝好後運行SQL Server Management
Time of Update: 2018-12-06
突然之間Sqlserver不能啟動。從服務裡面啟動Sqlserver服務。快顯視窗的錯誤資訊是:"本機電腦上的MSSQLSERVER服務啟動後又停止了。一些服務自動停止,如果它們沒有什麼可做的,例如“效能記錄檔及警示“服務"。在網上查了一些資源,發現了問題的原因是:系統時間更改了,變得比安裝Sqlserver的時間更早。於是把系統時間修改回現在的時間,就可以啟動了
Time of Update: 2018-12-06
.NET Framework 工具ASP.NET SQL Server 註冊工具 (Aspnet_regsql.exe) ASP.NET SQL Server 註冊工具用於建立供 ASP.NET 中的 SQL Server 提供者使用的 Microsoft SQL Server 資料庫,或者用於在現有資料庫中添加或移除選項。Aspnet_regsql.exe 檔位於 Web 服務器上的 [drive:]\WINDOWS\Microsoft.NET\Framework\versionNumber
Time of Update: 2018-12-06
/*--用預存程序實現的分頁程式顯示指定表、視圖、查詢結果的第X頁對於表中主鍵或識別欄位的情況,直接從原表取數查詢,其它情況使用暫存資料表的方法如果視圖或查詢結果中有主鍵,不推薦此方法*//*--調用樣本exec p_show '地區資料'exec p_show '地區資料',5,3,'地區編號,地區名稱,助記碼','地區編號'--*//*因為要顧及通用性,所以對帶排序的查詢語句有一定要求.如果先排序,再出結果.就是:exec p_show 'select top 100 percent *
Time of Update: 2018-12-06
如果先安裝vs2005 2010 再安裝sqlserver開發版,可能會發現 Management Studio安裝了依然找不到的緣故. 網上常見的解決方案一、 你安裝的SQLServer2005開發版安裝問題安裝完成後沒有SQL Server Management Studio是SQL Server 2005 Express Edition版快速開發版SQL Server 2005
Time of Update: 2018-12-06
SQL SERVER 2000使用者sa 登入失敗的解決辦法2009-03-30 15:43一.控制台-》服務-》MS SQL SERVER-》登陸--》本地系統帳戶--》重新啟動MS SQL SERVER用windows驗證登陸查詢分析器--》執行 sp_password null,sa新密碼,'sa'二."無法串連到伺服器,使用者xxx登陸失敗"該錯誤產生的原因是由於SQL Server使用了"僅 Windows"的身分識別驗證方式,因此使用者無法使用SQL Server的登入帳戶(如
Time of Update: 2018-12-06
1、開啟查詢分析器,輸入命令DUMP TRANSACTION 資料庫名 WITH NO_LOG2、開啟企業管理器--右鍵你要壓縮的資料庫--所有任務--收縮資料庫--收縮檔案--選擇記錄檔--在收縮方式裡選擇收縮至: ,這裡會給出一個允許收縮到的最小M數,直接輸入這個數,確定就可以了。3、在資料庫上點右鍵->屬性->選項->故障恢複-模型-選擇-簡單模型。4、企業管理器--伺服器--右鍵資料庫--屬性--選項--選擇"自動收縮" =====================1
Time of Update: 2018-12-06
用了一個笨辦法,不知道還有沒有其他的好方法: 把要修改的欄位和預存程序中的欄位對照,改為一樣大小,一樣的類型,順序也改為完全一樣,這樣還是不行,重新編譯也不成功,把SQL SERVER停了再重起也不行,只好把預存程序中的一些參數作為注釋,引用起來,執行一遍,作用相當於重新編譯一遍預存程序,去掉這些注釋,再執行就可以了! 不知道是為什麼!我是新手,有人可以解釋一下嗎?
Time of Update: 2018-12-07
今天開園,分享一下我一直在使用的資料備份預存程序,歡迎轉載!!!USE [master]GOSET ANSI_NULLS ONGOSET QUOTED_IDENTIFIER OFFGOCREATE Proc [dbo].[SQL_Backup]@DataBase Nvarchar(50)ASDUMP TRANSACTION @DataBase WITH NO_LOGBACKUP LOG @DataBase WITH NO_LOGDBCC SHRINKDATABASE (@DataBase)--