I. Purpose of the backup
Disaster recovery. Recovering corrupted data in the event of a disaster
Audit. What is the database at a certain point in time?
Test. Test if new features are available
Second, the classification
First, abnormal informationorg.springframework.jdbc.BadSqlGrammarException: # # # Error querying database. Cause:com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException:Expression #2 of the SELECT list is not in the GROUP by clause and contains
8.12.3.2 Mysql-mmm Frame compositionMysql MMM featuresAdvantages: High availability, scalability, automatic failover, for master synchronization, at the same time only provide a database write operation, to ensure the consistency of the
MySQL password is correct but cannot log on locallyThe error is as follows:ERROR 1045 (28000): Access denied for user ' root ' @ ' localhost ' (using Password:yes)The test found that the user table in the MySQL library was missing a data entry with
Original link: https://mariadb.com/kb/en/mariadb-vs-mysql-features/Xiaomo translation------Support for more storage enginesIn addition to the standard MyISAM, blackhole, CSV, memory, and ARCHIVE, the following storage engines are also included in
MySQL default port number is 3306, if install multiple or conflict need to modify the port number, modify the port number of the My.ini, the file is normally under the installation directory. Here are the specific instructions:Method/Step
Stop
Wamp Build Note Portal: http://www.cnblogs.com/jianming348/p/3952649.htmlBecause I do not want to delve into the principle, just need to build the environment. So using Yum on Linux is a great tool to use.It downloads and installs the latest version
http://heylinux.com/archives/1004.html MySQL Master-slave Replication (master-slave) and read-write separation (Mysql-proxy) practiceAs the most widely used free database in the world, MySQL believes that all engineers engaged in system operations
Why is this problem? After some thought, I found the reason because the current user's operation permission is too low and there is a problem.
The screenshot of the error is as follows:
The solution is as follows:
Running Net start MySql in DOS
It is easy to use MySQL-proxy to implement read/write splitting and load balancing in MySQL. However, large-scale processing still needs to be improved in terms of performance. The main configuration steps are as follows:
1.1. Install
Installation and configuration in Windows
This article describes how to install and configure Windows XP.
To run MySql in Windows, you must:
Ø 32-bit Windows OS, such as 9x, me, NT, 2000, XP, or Windows Server 2003.
Based on Windows NT Operating
Jdbcexceptionreporter. logexceptions (72) |
You have an error in your SQL syntax;
Check the manual that corresponds to your MySQL Server version for the right syntax to use near 'lock = '0', content = '1' where id = 1' at line 1[Bjxd] error [http-8
1. How to create a management user for the mysqld database?
After the database is installed, we should create a management account for the mysql database. To set the root user as the administrator, we should run the following command;
[Root @
PHP file for test
$ Link = mysql_connect ('localhost', 'root', 'zz ') or die (mysql_error ());
Mysql_select_db ('test') or die ('no db ');
Mysql_query ('set NAMES utf8 ');
Echo 99;
?>
Error reported after running
Can't connect to local MySQL server
This article mainly describes the example of the MySQL Grant command. the actual operation of the MySQL Grant command in this article is mainly on MySQL 5.0 and later versions, the following describes the specific operation steps. I hope you will
Ubuntu SQL tutorial for mysql beginners
Ubuntu SQL tutorial for mysql beginners
1. Start the mysql database:
Effect:
2. Enter mysql:
Effect:
3. view all databases:
Effect:
4. Create a database:
Vc3ryb25np1_vcd4kpha + pgltzybzcm9 "http:
How to forget the mysql super administrator root password in windowsToday, I helped a friend retrieve the MYSQL super administrator's ROOT password. When I started to enter the command, I played less "point" for several hours and finally solved the
Common Data Storage Methods in mysql include MyISAM and InnoDB. We don't need to think about any other memory. Let's introduce the advantages and disadvantages of MyISAM and InnoDB.
When using MySQL, you will certainly access the MySQL storage
Next, I will provide a summary of mysql Data Types, that is, field types, including type descriptions and string lengths of different data types. I will introduce them below.
I. numeric type
Storage required for column typesTINYINT 1 byteSMALLINT 2
Copy codeThe Code is as follows:DELIMITER $Set @ stmt = 'select userid, username from myuser where userid? And? ';Prepare s1 from @ stmt;Set @ s1 = 2;Set @ S2. = 100;Execute s1 using @ s1, @ s2;Deallocate prepare s1;$DELIMITER; For a query written
The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion;
products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the
content of the page makes you feel confusing, please write us an email, we will handle the problem
within 5 days after receiving your email.
If you find any instances of plagiarism from the community, please send an email to:
info-contact@alibabacloud.com
and provide relevant evidence. A staff member will contact you within 5 working days.
A Free Trial That Lets You Build Big!
Start building with 50+ products and up to 12 months usage for Elastic Compute Service