Very concise usage: Index < rating return TRUE or False
for (Index, button) in ratingbuttons. Enumerate() {
//If The index of a button is less than the rating, then button should be selected.
button. Selected = Index < rating
}
Greatly simplifies the statement, the readability is very strong. Compare old wording:
Button.selected = False
If index < rating {
Button.selected = True
}
or button.selected = (Index < rating)? True:false
This code iterates through the button, array to set, the state of each button, according to whether it index in the array is Less than the rating. If It is, index < rating
evaluates true
to, which sets the button's state to selected and makes it display the filled-in star imag E. Otherwise, the button is unselected and shows the empty star image.
Swift Alternative Judgment statement Usage button.selected = Index < rating