Time of Update: 2015-03-31
標籤:1.下載源碼wget http://dev.mysql.com/get/Downloads/MySQL-5.6/mysql-5.6.23.tar.gz2.解壓tar zxvf mysql-5.6.23.tar.gz3.安裝必要的包sudo yum install cmake gcc-c++ ncurses-devel perl-Data-Dumper4.進入mysql源碼目錄,產生makefilecmake .5.編譯make6.安裝sudo make installmysql將會安裝到/
Time of Update: 2015-03-31
標籤:mysql in 的兩種用法簡述MySQL 的in 的兩種用法:他們分別是在 in 關鍵字後跟一張表(記錄集),以及在in後面加上字串集。先講後面跟著一張表的。首先闡述三張表的結構:s(sno,sname.sex,age,dept) //學生資訊表c(cno,cname,tname)
Time of Update: 2015-03-31
標籤:MySQL有很多的可視化管理工具,比如“mysql-workbench”和“sequel-pro-”。
Time of Update: 2015-03-27
標籤:有一次面試的時候,面試官問我,mysql在建表的時候int類型後的長度代表什麼? 是該列允許儲存值的最大寬度嗎? 為什麼我設定成int(1), 也一樣能存10,100,1000呢.之前沒有想過這個問題.結果面完回來查了一下.如下,最後得出結論是:只是告訴資料庫說正常長度應該是1,而不是說只能存的長度為1.當時我雖然知道int(1),這個長度1並不代表允許儲存的寬度,但卻沒有一個合理的解釋. 或者說對這個長度也沒有真正的研究過到底代表什麼,
Time of Update: 2015-03-18
標籤:mysql新安裝的一台Centos伺服器,安裝完lamp後,重啟了一下系統,發現mysql啟動不了並報如下的錯誤: /etc/init.d/mysqld startStarting MySQL... ERROR! The server quit without updating PID file (/var/lib/mysql/feixiag.pid).查看日誌如下:InnoDB: Apply batch completed2015-03-18 17:28:05 24592
Time of Update: 2015-03-22
標籤: 1.用於不要使用select * from table xxx。 需要查詢哪些列就在語句中指明,一個表結構複雜時,可能會有上百列,使用*來查詢時會造成很大的浪費。 2.選擇合適的屬性及大小 例如郵遞區號使用char(6)就要比varchar(255)合適的多,省份、性別定義為enum也會提高效率。
Time of Update: 2015-03-18
標籤:問題現象 com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failureThe last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server. I
Time of Update: 2015-03-18
標籤:1.假設已經有mysql-5.5.10.tar.gz以及cmake-2.8.4.tar.gz兩個源檔案(1)先安裝cmake(mysql5.5以後是通過cmake來編譯的)[[email protected] rhel5 local]#tar -zxv -f cmake-2.8.4.tar.gz[[email protected] rhel5 local]#cd cmake-2.8.4[[email protected] rhel5 cmake-2.8.4]#
Time of Update: 2015-03-18
標籤:linux mysql 使用者 建立 安裝環境系統:centos6.5_86X64Mysql: mysql-5.6.16.tar.gz注意:mysql-5.6.16安裝和5.5、5.1不同,編譯不再使用./configure來進行,而是使用cmake來編譯。1.建立存放資料的目錄[[email protected] beauty]# mkdir
Time of Update: 2015-03-18
標籤:最近剛剛接觸MySQL,在建立表示遇到了一些問題,總是提示錯誤碼:150 can‘t create table ...,所以就到網上搜尋了一下發現還有以下幾點需要注意的:[CONSTRAINT [symbol]] FOREIGN KEY [index_name] (index_col_name, ...) REFERENCES tbl_name
Time of Update: 2015-03-17
標籤:一.提示由於沒有密碼,拒絕登陸ERROR 1045 (28000): Access denied for user ‘root‘@‘localhost‘ (using password: NO)1.關閉mysql # service mysqld stop2.屏蔽許可權 # mysqld_safe --skip-grant-table 螢幕出現: Starting demo from .....3.新開起一個終端輸入&
Time of Update: 2015-03-17
標籤:linux mysql [[email protected] ~]# rpm -qa | grep mysql // 這個命令就會查看該作業系統上是否已經安裝了mysql資料庫有的話,我們就通過 rpm -e 命令 或者 rpm -e --nodeps 命令來卸載
Time of Update: 2015-03-18
標籤: 1. 基本概念如果你不知道什麼是位元運算的話, 那麼請你先去看看基礎的C語言教程吧。 與運算 a & b , 或運算 a | b , 異或運算 a ^ b ,或者 你也可以將 與運算理解為 + 法 例如 1|2 = 3 (1+2 = 3)1|2|4 = 7 (1+2+4 = 7)將 異或運算理解為 - 法例如 3^2 = 1 (3-2 = 1)3^1 = 2 (3-1 = 2)最後將 與運算 作為判斷例如 3&2 = 1 (3 = 1 + 2,
Time of Update: 2015-03-16
標籤:http://blog.csdn.net/yangyu112654374/article/details/4251624比如一條sql語句select * from TABLE1 where A1=1 and A2=2 and A3=3 order by A4 ASC; 最佳化後是這樣: select A4,A1,A2 ... FROM TABLE1 where A1=1 and A2=2 and A3=3 order by A4 ASC; 並且給
Time of Update: 2015-03-12
標籤:什麼是索引:索引即資料庫通過一定的組織方式(B-tree等)把建立索引列上數值和位置儲存已達到快速查詢的目的。索引的種類:(1) 主鍵索引,一張表指定主鍵,自動建立索引。(2)
Time of Update: 2015-03-11
標籤:1.準備工作下載mysql的最新免安裝版本mysql-noinstall-5.1.53-win32.zip,解壓縮到相關目錄,如:d:\ mysql-noinstall-5.1.53-win32。這個就是mysql的根目錄了。---------------------------------------------------------------------------------------------2.配置在根目錄下有幾個檔案如下:my-small.ini
Time of Update: 2015-03-13
標籤:mysqlMysql 學習筆記1、安裝 環境: Windows 7 Mysql 5.5 從 http://www.mysql.com下載 EMS Mysql Query 1.6.0.1 本機IP:172.5.1.1832、安裝Mysql,採用預設安裝即可
Time of Update: 2015-03-13
標籤: 做畢業設計要用到MySql,介面方面想用下QT,順便學習一下QT的使用。上去就碰到問題,沒有MySql的驅動(其實在.\Qt\4.6.0\plugins\sqldrivers目錄下有,後來編譯完了才發現,這裡要崩潰一下~)。GOOGLE了一下,翻了翻網頁,就開始編譯驅動了。
Time of Update: 2015-03-19
install_driver(mysql) failed,installfailed 安裝好了mysql監控神器innotop,正得意,innotoop不可用,其錯誤提示為install_driver(mysql) failed: Can't load '/usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBD/mysql/mysql.so' for module
Time of Update: 2015-03-19
MYSQL ERROR 1862 (HY000): Your password has expired.,hy000expired遇到錯誤:ERROR 1862 (HY000): Your password has expired. To log in you mustchange it using a client that supports expired passwords.原因是:MySQL 5.6 introduces password-expiration capability,