Time of Update: 2015-02-02
標籤:1.AngularJS的雙向資料繫結(bi-directional data binding)<!doctype html><html ng-app> <head> <script src="http://code.angularjs.org/angular-1.0.1.min.js"></script> </head> <body> Your name:
Time of Update: 2015-02-02
標籤:由於放假,近來無事就隨便找點事來玩一下,就學了以後要用到的web開發,看到CSS樣式中定位時absolute非常不理解,在網上找了很多解釋反而弄得我更困惑了,於是決定自己實驗,找出各種關係。關於CSS定位中absolute的特點,我總結起來無非是以下幾點:1.定位position為absolute屬性的容器會脫離標準文檔流,可以放在整個頁面的各個位置(這個當然要與其他屬性結合使用);2.定位的標準為整個頁面或者外包裹容器,同級元素不會成為absolute容器的定位標準;3.當定位為abso
Time of Update: 2015-02-03
標籤:自學mvc,看了園子裡李林峰寫的李林峰寫的無廢話MVC入門教程筆記,現在有的平時忽略的或是不太清楚的點記下來1,Html.DropDownList//服務端寫法 @{ //下拉式清單的值 List<SelectListItem> selectList = new List<SelectListItem>(); selectList.Add(new SelectListItem { Value = "1",
Time of Update: 2015-02-02
標籤:做的項目中需要用到通過JS擷取GET參數,上網找了一下,找到如下外掛程式: 例如 當前你的URL是: http://www.xxx.com/index.php?test=1&kk=2 如果想擷取test,則可以引入外掛程式後, 用如下方法擷取: var test = $.query.get(’test’); 如果參數有多個相同的名稱 ,則可以這樣: var arr =
Time of Update: 2015-02-01
標籤: 1 /** 2 * 格式化金額 3 * 4 * @param int $money 5 * @param int $len 6 * @param string $sign 7 * @return string 8 */ 9 function format_money($money, $len=2, $sign=‘¥‘){10 $negative = $money > 0 ? ‘‘ : ‘-‘;11 $int_money =
Time of Update: 2015-02-02
標籤:發現問題:IIS網站全部消失了。原因不明。報錯:The Path specified cannot be used at this time解決步驟:為IIS添加localhost,報錯:The Path specified cannot be used at this time尋找原因:得出需要重啟sharepoint
Time of Update: 2015-02-01
標籤:參考自RFC 2616,並由RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等規範擴充。紅字代表比較常見的幾種STATUS CODE"100" : Continue"101" : Switching Protocols"102" : Processing (WebDAV;RFC 2518)"200" : OK"201" : Created"202" : Accepted"203" : Non-Authoritative
Time of Update: 2015-02-02
標籤:這是一篇我喜歡的思想,經驗,理念,以及過去幾年中我所實驗的理念的集合。它覆蓋了HTML語義,前端架構的組件和方法,類命名模式,和HTTP內容壓縮。我們不會停止探索而我們一切探索的終點將會到達我們出發的地方於是我們第一次認識了這個地方。T.S. Eliot —
Time of Update: 2015-02-01
標籤:簡單整理一下工作中經常用到的php路徑函數1、basename($path, $suff):返回基本的檔案名稱,如果是以$suff 結束的就去掉$path = ‘E:\centos\index.php‘;echo basename($path, ‘.php‘); // indexecho basename($path); // index.php2、dirname($path):返迴路徑中的目錄部分$url =
Time of Update: 2015-02-01
標籤:問題背景:用php刪除資料,希望在點擊“刪除”(button)的時候JS彈出confirm來確認是否刪除。 此段代碼為php中的form:1 <form action="?form=delete" method="POST">2 <button type="submit" name="id" value="<?php echo $row[‘id‘];?>"> 刪除 </button>3
Time of Update: 2015-02-02
標籤:http協議我們在使用HttpServletRequest和HttpServletReonse等工具類的時候,這些工具類走的協議就是http協議,http協議也是我們日常WEB開發通用的協議。因為http協議封裝的很好,因此我們往往忽視了它,但是在對效能的極致追求中,這些基礎協議,又成為我們繼續努力的基礎。1、HTTP協議HTTP是hypertext transfer protocol(超文字傳輸通訊協定
Time of Update: 2015-02-03
標籤:hi all: 由於UIWebView無法實現離線緩衝,因此想利用Archieve機制來實現檔案形式的離線緩衝機制。同時,由於NSURLRequest每一次對連結的請求,都將觸發NSURLProtocol的回調,因此對NSURLProtocol合理應用可以很好的達到離線緩衝的目的。一、NSURLProtocol與NSURLProtocolClient簡介:
Time of Update: 2015-02-01
標籤:開發各種軟體或系統都需要進行壓力測試等,近來有一個後台web系統新需要進行測試,怎麼才能很方便的測試呢,curl就ok了。curl是linux/unix下很強大的命令,全稱 command url,web測試中最重要的應該算是維持session,而用戶端實現的方式是使用cookie。curl參數介紹:--data post方式參數-L 自動重新導向-c 將cookies儲存到檔案-b 將cookie一起發送至服務端下面看一下具體的操作:類比登陸:1curl -L -c&
Time of Update: 2015-02-01
標籤:樣本:更改日期格式下面的程式碼範例使用 Regex.Replace 方法將 mm/dd/yy 格式的日期替換為 dd-mm-yy 格式的日期。static string MDYToDMY(string input) { return Regex.Replace(input, "\\b(?<month>\\d{1,2})/(?<day>\\d{1,2})/(?<year>
Time of Update: 2015-02-01
標籤:在接入第三方渠道SDK的時候,經常會看到其設定檔AndroidManifest.xml有類似如下的定義:<!-- appid --> <meta-data android:name="APP_ID
Time of Update: 2015-02-01
標籤:代碼如下:<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en"><head> <meta http-equiv="Content-Type"
Time of Update: 2015-02-03
24天學會設計模式------策略模式,24天設計模式林炳文Evankaka原創作品。轉載請註明出處http://blog.csdn.net/evankaka一、策略模式(Stragegy Pattern)1、簡介Strategy模式也叫策略模式是行為模式之一,它對一系列的演算法加以封裝,為所有演算法定義一個抽象的演算法介面,並通過繼承該抽象演算法介面對所有的演算法加以封裝和實現,具體的演算法選擇交由用戶端決定(策略)。Strategy模式主要用來平滑地處理演算法的切換
Time of Update: 2015-02-03
VB.NET視頻總結,vb.net總結 Visual Basic.NET是基於.NET Framework上的物件導向的程式設計語言,可以看做是Visual Basic在.NET
Time of Update: 2015-02-03
Activiti入門,activiti相關文章:《史上最權威的Activiti架構學習》《Activiti入門——環境搭建和核心API簡介》在Activiti中,相對前身JBPM基礎上又額外多了5張,架構預設提供了23張表。今天這章來和大家分享一下關於Activiti資料庫結構相關知識。資料庫Activiti 的後台是有資料庫的支援,所有的表都以 ACT_開頭。 第二部分是表示表的用途的兩個字母標識。 用途也和服務的 API 對應;AC
Time of Update: 2015-02-02
寒假集訓.Discrete-Function,.discrete-functionDiscrete FunctionTime Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64uSubmit StatusDescriptionThere is a discrete function. It